[Stable Security Update] 2020-03-11 - Firefox 74.0

Hello community,

here is another Stable/Security Update.


Mozilla Firefox 74 aims for more security. The headline change in Firefox 74 is the use of DNS over HTTPS by default for users in the USA.

  • A privacy-minded feature, DNS over HTTPS encrypts all DNS requests made in Firefox 74 (requests which are normally done ‘in the open’). This helps prevent people snooping on internet traffic from discerning detail about the requests being made.
  • Firefox 74 defaults to Cloudflare as the DNS resolver but users are able switch to NextDNS through the Preferences > Network Settings dialog.
  • On the subject of privacy, Firefox 74 also (apparently) makes a dedicated Facebook Container available. Like other ‘containers’ the browser offers fwiw — this aim is to insulate and isolate web activity from pervasive online trackers, in this instance Facebook.
  • Finally, be aware that Firefox 74 disables TLS 1.0 and TLS 1.1. Sites which do not support TLS 1.2 will error out when loaded in the browser.

For more details on this release and its particulars you can pore over the Firefox 74.0 release notes, and dive in to the developer change-log on the Moz Dev blog for additional insight.

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.215
  • linux49 4.9.215
  • linux414 4.14.172
  • linux419 4.19.107
  • linux54 5.4.23
  • linux55 5.5.7
  • linux56 5.6-rc3
  • linux419-rt 4.19.106_rt44
  • linux54-rt 5.4.22_rt13

Package Changes (Sun Mar 1 13:56:58 CET 2020)

  • stable extra x86_64: 97 new and 0 removed package(s)

A detailed list of all package changes of our last update can be reviewed here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Older issues

(2020-02-14) Can't boot into a graphical session anymore

[Stable Update] 2020-02-10 - Kernels, KDE Apps, Gnome Settings

We deeply apologize for the inconvenience this error may have caused.

Even if your graphical session is broken, you should still be able to access a TTY session with CTRL+ALT+F3 (and other similar key combinations), where you can then run sudo pacman -Syyu.

several flatpaks have issues to get a secure connection

This is a known bug and related to p11-kit update to 0.23.19. With 0.23.20-1 that issue is fixed. Please update to that version as soon our mirrors synced.

wpa_supplicant update broke Wifi for Broadcom

By enabling new features in revision 4 of v2.9 by Arch a connection with a Broadcom Wifi card was not possible anymore. This is a known bug. Either try to downgrade to revision 3 or upgrade to revision 5.

sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-3-x86_64.pkg.tar.xz
sudo pacman -U https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-5-x86_64.pkg.tar.zst

(From Arch Linux) rsync compatibility

(2020-01-15, by Christian Hesse)
(This is relevant on Manjaro, as Manjaro imports rsync package directly from Arch Linux.)

Our rsync package was shipped with bundled zlib to provide compatibility with the old-style --compress option up to version 3.1.0. Version 3.1.1 was released on 2014-06-22 and is shipped by all major distributions now.

So we decided to finally drop the bundled library and ship a package with system zlib . This also fixes security issues, actual ones and in future. Go and blame those running old versions if you encounter errors with rsync 3.1.3-3 .

Source: https://www.archlinux.org/news/rsync-compatibility/

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

Update of Firefox 74.0 went fine.

Move to other Thread:

Get this errors on pamac (9.3.0-2):

By trigger pamac upgrade

(process:3530): GLib-GObject-WARNING **: 17:15:29.947: ../glib/gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x55a0ba468c30' of type 'GSettings'

(process:3530): GLib-GObject-WARNING **: 17:15:29.949: ../glib/gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x55a0ba469480' of type 'GSettings'

(process:3530): GLib-GObject-WARNING **: 17:15:29.953: ../glib/gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x55a0ba4695c0' of type 'GSettings'

(process:3530): GLib-GObject-WARNING **: 17:15:29.953: ../glib/gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x55a0ba468f00' of type 'GSettings'

(process:3530): GLib-GObject-WARNING **: 17:15:29.954: ../glib/gobject/gsignal.c:2617: signal 'changed::' is invalid for instance '0x55a0ba468dc0' of type 'GSettings'

And pamac (9.4.0rc3):

Gets stuck at pamac upgrade
After password input

On Arch Linux

I just updated the fall back computer. All seems good to go here. Thanks!

What's that supposed to mean?

I have pamac installed on Arch Linux System, today I updated it to the latest version and noticed that the pamac upgrade Command doesn’t work anymore

Everything went OK, with Manjaro XFCE installed natively.

Also, my VirtualBox 6.1.4 Virtual Machines, with Manjaro LXQT, Manjaro MATE, and Manjaro XFCE, were updated without an issue.

We are currently updating Pamac almost daily. Check and report issues:

Fixed see > [BUG] pamac upgrade hangs [Resolved: 9.4.0rc4]

I experienced problems with downloading files and images from Firefox 74.0. I tried to save the files and pictures but "save as" function isn't responding. I'm using Macbook Pro 13" Retina early 2015.

Same issue for me on all my laptop (3).
Chromium is not affected by the problem.
The same problem (like Firefox) for Thunderbird.

Thanks to both for reporting this problem; so I'll wait to update Firefox on my system (and so I reply here to receive notifications about).

I don't have that issue.

PS : You can simply change the notification level by clicking on the bell on the right or below the thread and selecting Tracking or Watching. It doesn't require you to post. :cookie:

1 Like

Thank you for the tip.
However, since I figured that I could - in case of emergency - downgrade Firefox from ALA (sudo DOWNGRADE_FROM_ALA=1 downgrade firefox) I've updated it and works fine for me.

1 Like

I solved the problem.
I had installed manjaro-kde-settings-19. Instead of this I installed manjaro-kde-settings and the problem was gone: now thunderbird and firefox can download or attach any file.

1 Like

Are you using GTK_USE_PORTAL=1 to use a custom filechooser?
I had precisely this problem after upgrading and removing that from my Firefox command fixed it.

Filechooser wasn't appearing for saving or uploading files.

This was solved by removing my custom filechooser which was specified by GTK_USE_PORTAL=1

I don't know if it's because of this update, but when I make downloads via Firefox, the browser only accepts one download at a time.
The others go into "failure" and when one of them finishes, I have to restart the second download and so on...
Previously, I was able to download several files at the same time.

Forum kindly sponsored by