[Stable-Staging Update] 2020-05-30 - Kernels, Toolchain, KDE Apps, Gnome, Cinnamon, Deepin

Hello community,

Another stable-staging branch update with some interesting updates for you!


Our next point-release of #Lysia is about to be ready this weekend. Report an issues you may have in stable-staging to us now. #stayhome, #staysafe, #stayhealthy*

  • All our Kernels got renewed or rebuilt against the new GCC10
  • KDE-git packages got updated
  • KDE Apps are now at 20.04.1
  • Mesa got another point-release
  • Cinnamon got updated to 4.6.0
  • More updates Deepin
  • Gnome updates to several packages
  • AMDVLK is now at 2020.Q2.4
  • NetworkManager got updated to 1.24.2
  • Calamares got some needed fixes to work again for our hardware vendors
  • openjdk got updated to 11 series
  • LibreOffice is now at 6.4.4
  • Regular Haskell, Python and Browser updates
  • The usual upstream updates by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest release Manjaro Lysia 20.0.1! XFCE, KDE and Gnome


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.225
  • linux49 4.9.225
  • linux414 4.14.182
  • linux419 4.19.125
  • linux54 5.4.43
  • linux56 5.6.15
  • linux57 5.7-rc7
  • linux54-rt 5.4.43_rt25
  • linux56-rt 5.6.14_rt7

Package Changes Sat May 30 08:51:43 CEST 2020)

  • stable-staging community x86_64: 1892 new and 1963 removed package(s)
  • stable-staging core x86_64: 72 new and 74 removed package(s)
  • stable-staging extra x86_64: 1810 new and 1824 removed package(s)
  • stable-staging multilib x86_64: 44 new and 45 removed package(s)

A detailed list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

I've uploaded 20.0.2 ISOs for final review...

1 Like

Huge update - 1,8GB! But all works fine at three machines.
That´s manjaro :star_struck:

Thanks to the manjaro-team
regards
caho

I added some more packages:

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-05-30           2020-05-31
-------------------------------------------------------------------------------
                           baloo-git5.71.0.r2786.gfec72078-15.71.0.r2787.gc1fadaa0-1
                          breeze-git5.19.80.r1999.gf1145515-15.19.80.r2002.gd93dcf78-1
                            hw-probe1.6+beta.16.gf54f5c0231-11.6+beta.17.g8d37e65061-1
                         kapidox-git5.71.0.r474.g525886b-15.71.0.r475.gb1f4149-1
                        kcmutils-git5.71.0.r399.g97b703a-15.71.0.r400.g52b1b8b-1
                  kconfigwidgets-git5.71.0.r463.ge91ccdf-15.71.0.r465.gd82db29-1
                    kdeclarative-git5.71.0.r777.g1aefe2a-15.71.0.r779.gb711c25-1
                    kglobalaccel-git5.71.0.r360.g42b9f1e-15.71.0.r361.gf784038-1
                       kholidays-git5.71.0.r865.g104386b-15.71.0.r868.gb8d529b-1
                     kinfocenter-git5.19.80.r1681.g4b78e56-15.19.80.r1682.g4346cb0-1
                             kio-git5.71.0.r3996.g9d68a216-15.71.0.r4009.gfce58001-1
                       kirigami2-git5.71.0.r2208.g92e51c17-15.71.0.r2211.g8c4b36c3-1
                         krunner-git5.71.0.r431.gd29aef1-15.71.0.r434.g41ecf60-1
                       ksysguard-git5.19.80.r3260.g7e35ac9e-15.19.80.r3267.g2af0539e-1
                     ktexteditor-git5.71.0.r2363.gc374e269-15.71.0.r2368.g99eb9bfb-1
     libnautilus-extension-typeahead             3.36.2-1             3.36.3-1
                    linux54-rt-r8168           8.048.02-4           8.048.03-1
                    linux56-rt-r8168           8.048.02-4           8.048.03-1
                  nautilus-typeahead             3.36.2-1             3.36.3-1
                plasma-framework-git5.71.0.r15438.g50a699f9e-15.71.0.r15439.g773d05d29-1
                           solid-git5.71.0.r572.g6330c33-15.71.0.r573.gc9f3a08-1
             syntax-highlighting-git5.71.0.r1117.g960aaca-15.71.0.r1119.gebb2a2d-1
                              ventoy             1.0.11-1             1.0.12-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-05-30           2020-05-31
-------------------------------------------------------------------------------
                            backuppc              4.3.2-1              4.3.2-2
                       cataclysm-dda                0.E-1              0.E.2-1
                 cataclysm-dda-tiles                0.E-1              0.E.2-1
                          cozy-stack            1:1.4.7-1           1:1.4.12-1
                             cryptol            2.8.0-125            2.8.0-126
                           cuneiform             1.1.0-19             1.1.0-20
                            dokuwiki         20180422_b-1         20180422_c-1
                              dqlite              1.4.2-1              1.4.3-1
                            electron              8.2.5-2              9.0.0-1
                              fcitx5     0.0.0.20200530-1   0.0.0.20200530.1-1
               fcitx5-chinese-addons     0.0.0.20200529-1     0.0.0.20200530-1
                       ffmpeg2theora               0.30-4               0.30-6
                   firefox-tridactyl             1.19.0-1             1.19.1-1
                              fossil               2.10-1               2.11-1
                              gitlab             13.0.1-1             13.0.3-1
                       gitlab-gitaly             13.0.1-1             13.0.3-1
                    gitlab-workhorse             8.32.1-1             8.33.0-1
                                gmtp             1.3.11-1             1.3.11-2
                  haskell-aeson-diff           1.1.0.9-11           1.1.0.9-12
           haskell-ghc-lib-parser-ex           8.10.0.5-4           8.10.0.6-1
                      haskell-hakyll          4.13.3.0-41          4.13.3.0-42
                       haskell-ipynb           0.1.0.1-21           0.1.0.1-22
                         haskell-sbv               8.6-84               8.6-85
                               hlint              3.0.4-2              3.0.4-3
                                i2pd             2.31.0-1             2.32.0-1
                             ipython             7.14.0-2             7.15.0-1
                                jake             10.7.1-1             10.8.1-1
                                 k9s             0.20.1-1             0.20.2-1
                          kcm-fcitx5     0.0.0.20200528-1     0.0.0.20200530-1
                           libsigrok              0.5.2-2              0.5.2-3
                            minitube                3.3-1                3.4-1
                                ncdu             1.14.2-1               1.15-1
                 nextcloud-app-notes              3.3.1-1              3.4.0-1
                            openntpd              6.2p3-3              6.2p3-4
                              pandoc           2.9.2.1-55           2.9.2.1-56
                     pandoc-citeproc             0.17-116             0.17-117
                     pandoc-crossref            0.3.6.3-2            0.3.6.3-3
                           partimage             0.6.9-12             0.6.9-13
                    perl-test2-suite           0.000129-1           0.000130-1
                          photoflare              1.6.4-1              1.6.4-2
                               pyrit              0.5.0-3              0.5.0-4
                         python-flit              2.3.0-3              2.3.0-4
                    python-flit-core              2.3.0-3              2.3.0-4
                     python-graphene              2.1.3-2            3.0.0b2-1
                python-graphql-relay              0.4.5-3              3.0.0-1
          python-graphql-server-core              1.1.1-2              2.0.0-1
                     python-identify             1.4.17-1             1.4.18-1
                      python-pikepdf             1.13.0-1             1.14.0-1
            python-pyproject2setuppy                  6-1                  7-1
                  python-pysol_cards             0.8.16-1             0.8.18-1
                                raft             0.9.21-1             0.9.22-1
                            razercfg               0.41-2               0.42-1
               react-native-debugger             0.11.3-1             0.11.3-2
                        riot-desktop              1.6.2-1              1.6.2-2
                            riot-web              1.6.2-1              1.6.2-2
                          shellcheck             0.7.1-34             0.7.1-35
                      signal-desktop             1.34.1-1             1.34.1-2
                           sniffglue             0.11.0-1             0.11.1-1
                  sqlite-replication           3.31.1.4-1           3.32.1.4-1
                              tipp10              3.1.0-1              3.2.0-1
                               udpxy          1.0.23.12-1          1.0.23.12-2
                          unrealircd              5.0.5-1            5.0.5.1-1
                               v2ray             4.23.1-2             4.23.2-1
                              warsow              2.1.2-1              2.1.2-2
                                 wlc             0.0.11-1             0.0.11-2
                                xosd             2.2.14-9            2.2.14-10
                          youtube-dl         2020.05.08-1         2020.05.29-1
                               zcash            2.1.2_3-1              3.0.0-1
                             ziproxy              3.3.1-2              3.3.1-3
                             fusesoc                    -               1.10-1
                      python-edalize                    -              0.2.2-1
                    python-httptools                    -              0.1.1-2
                      python-ipyxact                    -              0.2.4-1
                  python-okonomiyaki                    -              1.2.0-2
                    python-simplesat                    -              0.8.2-1
                       python-uvloop                    -             0.14.0-1
                     python-watchgod                    -                0.6-1
                           screenkey                    -                1.1-2
                             uvicorn                    -             0.11.5-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-05-30           2020-05-31
-------------------------------------------------------------------------------
                      linux414-r8168           8.048.02-6           8.048.03-1
                      linux419-r8168           8.048.02-8           8.048.03-1
                       linux44-r8168           8.048.02-6           8.048.03-1
                       linux49-r8168           8.048.02-6           8.048.03-1
                       linux54-r8168           8.048.02-9           8.048.03-1
                       linux56-r8168          8.048.02-11           8.048.03-1
                       linux57-r8168        8.048.02-0.12         8.048.03-0.1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-05-30           2020-05-31
-------------------------------------------------------------------------------
                   audacious-plugins              4.0.3-2              4.0.3-3
                              breezy            3.0.2.3-2            3.0.2.3-3
                        capi4hylafax            010300-11                    -
                              evince             3.36.1-2             3.36.3-1
                           farstream              0.2.9-1              0.2.9-2
                                 fmt              6.2.1-2              6.2.1-3
                       four-in-a-row             3.36.2-1             3.36.3-1
                          gnome-2048             3.36.2-1             3.36.3-1
                         gnome-chess             3.36.0-1             3.36.1-1
                       gnome-klotski             3.36.2-1             3.36.3-1
                         gnome-music           1:3.36.2-1           1:3.36.3-1
                        gnome-taquin             3.36.2-1             3.36.3-1
                      gnome-tetravex             3.36.2-1             3.36.3-1
                      gtksourceview3            3.24.11-13.24.11+28+g73e57b57-1
                           hyphen-it           20071127-4           20071127-5
                               iagno             3.36.2-1             3.36.3-1
                               icewm              1.6.5-1              1.6.6-1
                         imagemagick          7.0.10.14-1          7.0.10.15-1
                     imagemagick-doc          7.0.10.14-1          7.0.10.15-1
                            libfido2              1.4.0-3              1.4.0-4
                     libmusicbrainz5              5.1.0-3              5.1.0-4
                              libqmi            1.24.12-1            1.24.14-1
                           misdnuser             2.0.22-2                    -
                              netpbm           10.73.31-2           10.73.31-3
                 perl-perl4-corelibs              0.004-4              0.004-5
                         python-cffi             1.14.0-2             1.14.0-3
                       python-django              3.0.6-1              3.0.6-2
                    python-hyperlink             19.0.0-4             19.0.0-5
                        python2-cffi             1.14.0-2             1.14.0-3
                   python2-hyperlink             19.0.0-4             19.0.0-5
                        zabbix-agent              4.4.8-1              5.0.0-1
                       zabbix-agent2              4.4.8-1              5.0.0-1
                 zabbix-frontend-php              4.4.8-1              5.0.0-1
                        zabbix-proxy              4.4.8-1              5.0.0-1
                       zabbix-server              4.4.8-1              5.0.0-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-05-30           2020-05-31
-------------------------------------------------------------------------------
                       steam-manjaro           1.0.0.62-1           1.0.0.62-2
                        steam-native           1.0.0.62-1           1.0.0.62-2

Is there a way for status of stable-staging ?
The link isn't it.

And another thing: Why is stable-staging in the forum a thread in "Development" and not like the real development unstable in "Announcements" ?

I think that is a reason for the less traffic here ...

just click the ring bell

Not sure ?:?
I ask for mirror status.
Which bell?

sorry, I mean click the icon bell for announcement notification. My bad.
bell

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by