[Stable Staging Update] 2020-07-17 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers

Hello community,

Another stable-staging branch update with some interesting updates for you! So far it is one of our biggest updates we prepared so far.

More work went into our #Phosh edition for the #pinephone #stayhome, #staysafe, #stayhealthy

  • We updated all of our Kernels
  • For Linux57 kernel series we added the FSync/Futex patches by Valve to speed up some processes, especially for Proton gaming.
  • Renewed our Firmware for the kernels
  • Worked on our ARM-tools
  • Some Cinnamon and Deepin updates
  • Plasma5 got updated to 5.19.3
  • KDE Frameworks is now at 5.72.0
  • KDE Apps got renewed to 20.04.3
  • A lot of KDE-git package updates to showcase the latest features of KDE software
  • Wine is renewed to 5.10
  • Brave browser has new versions in standard and beta
  • Virtualbox is now at 6.1.10
  • Mesa got updated to 20.1.3
  • PHP is now at 7.4.8
  • Pamac got some fixes and updated to 9.5.6
  • Firefox is now at 78.0.2
  • Firefox developer edition is now at 79.0b7
  • Palemoon got another release
  • Thunderbird updated to 68.10.0
  • Some more fixes to our Jade desktop
  • LibreOffice got renewed to 6.4.5
  • The development IDE Gambas is now at 3.15.0
  • AMD kicks of Q3 with AMDVLK on 2020.Q3.1
  • The usual upstream updates rebuilds/updates including python and haskell by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest release candidate of Manjaro Mikah 20.1! XFCE, KDE and Gnome

Setup instructions

  • first update your stable branch to get the latest pacman-mirrors package
  • issue: sudo pacman-mirrors -a -B stable-staging
  • issue: sudo pacman -Syyu or pamac upgrade --force-refresh

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.230
  • linux49 4.9.230
  • linux414 4.14.188
  • linux419 4.19.133
  • linux54 5.4.52
  • linux56 5.6.19 [EOL]
  • linux57 5.7.9
  • linux58 5.8-rc5
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes (Wed Jul 15 22:32:50 CEST 2020)

  • stable-staging community x86_64: 4054 new and 3985 removed package(s)
  • stable-staging core x86_64: 81 new and 79 removed package(s)
  • stable-staging extra x86_64: 1428 new and 1407 removed package(s)
  • stable-staging multilib x86_64: 54 new and 54 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable-Staging Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

@philm: :astonished: Indeed, there are quite a few updates to be made. Thanks to you to provide these new updates for this part of the stable branch. :wink:

I will download the new Manjaro 20.1 KDE RC version to see if it works fine. If necessary, I will do a little debriefing.

Can I use that RC as my main system without waiting the final version ? I know if I update that RC with the futur stable updates that one will become a final version. Isn't it ?

Note: The 20.1-rc1 is not available when I click on the link (file not found) :disappointed:

1 Like

comming from testing...
the ffnvcodec-headers downgrade and rebuild of ffmpeg made hardware encoders work again, yes. But libx264, libx265 and mp3 still have problems and are not available in KDEnlive and Shotcut. Seems you should ship the old ffmpeg package for now (2:4.2.3-2) instead of a 4.3.1 rebuild.

Awesome update :heart:. Everything went smooth. I can feel the new speed.

Updated via TTY - XFCE, Kernel 5.7, nouveau

I experienced this issue with grub-vanilla:

Resolved by instalingl zfs-utils.

Also ran the the following to remove zfs errors on boot:

systemctl disable zfs-mount.service
systemctl disable zfs-import-scan.service 
1 Like

Openbox updated with Pamac-GTK without issues. I only have one warning about old perl module:

Reloading system bus configuration...
Warn about old perl modules
WARNING: '/usr/lib/perl5/5.30' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'
Updating fontconfig cache...
Probing GDK-Pixbuf loader modules...
⟨recbox⟩∙⟨~⟩ $ pacman -Qqo '/usr/lib/perl5/5.30'                                                                   

I've seen this type of warning long ago and if I remember correctly I can remove it, right?

When I'm trying to remove it Pamac shows me that obmenu-generator will be removed, so I just don't touch it right now because I need this package.

all good on my laptop: linux57+xfce+xfs

Updated from Testing, this update (with downgrade of ffmpeg) fixed this issue with NVENC in OBS.

Everything is OK on Manjaro Testing & Stable : linux57, xfce :slight_smile:

obmenu-generator has been fixed some time ago when I encountered the update.

June 24. - obmenu-generator-0.88-1

This is an announcement thread. If you want to complain please do it in #general-discussion:rants-and-raves.

I'll be culling unrelated content from this thread.


Everything looking good! Switched my stable machine to stable-staging and everything works, thanks again Manjaro!

My XFCE updated and look OK to me.

Sorry but I probably don't understand, you guys are too smart for me :smiley:

Is that mean that I should remove perl-linux-desktopfiles with obmenu-generator package and install obmenu-generator package once more?

Fixes should be coming.

1 Like

Laptop with linux57+ryzen9+nvidia prime+gnome works out of the box from -rc1.
Thank you very much !

1 Like

When Arch ships out a new ffmpeg most likly applications depending on it will be rebuilt against the new version. So a rebuild for NVenc is the best thing I can do for now.

I want to happily report that cracking noises from headphones have really reduced/stopped. What ever the dev team did, they are AMAZING.


1 Like

Seems this is not a ffmpeg bug, but a MLT rebuild could help:

Arch didn't rebuild MLT against newest ffmpeg yet (latest update on 2020-04-06):

Forum kindly sponsored by