[Stable Update] 2016-10-09 - Kernels, Manjaro Tools, Deepin, NM, LibreOffice, Steam

FOR SYSTEMD USERS HAVING STILL v231-1 INSTALLED, IT IS RECOMMENDED TO USE PACMAN, AS X-SESSION MIGHT GET LOST DUE THIS UPDATE. THEREFORE WE SUGGEST TO FOLLOW OUR UPDATE RECOMMENDATION. YOU CAN TRY IF FOLLOWING CMD MIGHT CRASH YOUR SYSTEM: sudo systemctl --system daemon-reexec


Hi community,

coming closer to our next stable release we adjusted some packages. With this update pack we have renewed haskell, deepin, lxqt, libreoffice, nvidia legacy drivers and networkmanager. Also some of our kernels got updated including v4.8.1. Additional work went into our steam clients. We offer now our own steam-manjaro and upstream versions of steam including native libraries. Some work went into our OpenRC packages. Also we updated our manjaro-tools, so we can prepare our first release candidate of Manjaro Linux 16.10. As usual we also provide the upstream updates, such as python2, packagekit and multimedia codecs.

Archlinux upstream fixes are now from: Tue Oct 05 19:26 CEST 2016

Please report any issues you may have with this update. Also read our troubleshoots to avoid known issues. Packages for our next stable review can be found here.

Kind regards,
Philip Müller and the Manjaro Development Team


Troubleshoots

Information for Catalyst users

If you are using an AMD card with Catalyst it is STRONGLY RECOMMENDED to use pacman for this update!!! The new style how Catalyst works now, would be this:

  • Catalyst-Utils needs now three new packages: catalyst-video, catalyst-input and catalyst-server.
  • Catalyst-Video provides some needed drivers like Intel and Vesa, since we have some hybrid systems too
  • Catalyst-Input provides the needed input drivers
  • Catalyst-Server provides the compatible Xorg-Server

Without these packages it would be not possible to still provide Catalyst at all. So it is logical to remove conflicting packages on these AMD systems. It can be tested with a new dev-build. If there are still issues regarding Catalyst, open an issue or a new thread, so we can discuss it.

Disable random mac address for your WLAN

Use nmcli to set 802-11-wireless.mac-address-randomization to never on a per connection basis or set

[device]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf to disable the feature completely.

Issues with updating MATE

Some users have mate-menu installed from AUR. Please remove this package if you use the GTK2 version of MATE before trying to update. If you have a different issue with updating, please post.

LibreOffice and GTK3

LibreOffice might be broken on gtk-based Desktop Environments. Workaround would be to force a look to Libreoffice by editing /etc/profile.d/libreoffice*sh. We recommend to uncomment SAL_USE_VCLPLUGIN=gtk. Our KDE edition isn't affected by this issue.

GTK3

With this we updated Gnome and GTK to 3.20. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.20-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.20 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

We support now several different steam-clients:

  • steam-manjaro: is our definition how steam should work on Manjaro.
  • steam-native: is our definition how steam should be used with our native libraries
  • steam: is the upstream client by Archlinux
  • steam-native-runtime: is the addon by upstream Archlinux to use native libraries

The clients by Manjaro are better tested and prefered for Manjaro Linux. However the upstream versions might also work for you.

Reference: Archlinux wiki


Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Current supported kernels

  • Linux310 3.10.103
  • Linux312 3.12.64
  • Linux314 3.14.79 [EOL]
  • Linux316 3.16.37
  • Linux318 3.18.41
  • Linux41 4.1.33
  • Linux44 4.4.24
  • Linux46 4.6.7 [EOL]
  • Linux47 4.7.7
  • Linux48 4.8.1
  • Linux-RT-LTS 4.4.23_rt33
  • Linux-RT 4.6.7_rt14

Package Changes

  • stable community i686: 394 new and 380 removed package(s)
  • stable community x86_64: 427 new and 414 removed package(s)
  • stable core i686: 26 new and 25 removed package(s)
  • stable core x86_64: 26 new and 25 removed package(s)
  • stable extra i686: 379 new and 378 removed package(s)
  • stable extra x86_64: 379 new and 378 removed package(s)
  • stable multilib x86_64: 40 new and 31 removed package(s)
15 Likes

All the updates works fine. Thanks to the manaro-team :+1:

regards
caho

How do you do this? Exactly......

@xircon Well, you can read it up here.

Got that, but how do you use nmcli? I edited /etc/NetworkManager/NetworkManager.conf

Hi, I cannot apply the update. It is giving me an error related to nvidia. Basically, says that nvidia-340xx-utils = 340.96 is missing but I have its updated version 340.96-1 installed. Attached are screenshots of the error

and of nvidia programs I have in pacmac

I tried to reinstall nvidia-340xx-utils = 340.96-1, but I got an error message asking me to install 340.96.

I can't find 340.96 in pacmac, there is only 340.96-1 so I'm not so sure how to proceed.
On my machine I have linux 316, 318, 44 and I am running 44.
For reference, a couple of months back, I had a problem with nvidia where my pc wouldn't start and I would get "failed to start load kernel modules". Back then I was running linux 318. The problem was solved when I installed linux 44. Haven't had such issues since then.

Would the solution be to uninstall linux 316? Maybe it's too old?
Thank you,

Seems you found an issue I missed. Thx for reporting. linux316-nvidia-340xx needs an update.

2 Likes

Update went smoothly, except for a conflict between qt5-base and qtchooser, which I resolved by removing qtchooser.

pacman recommended to keep qtchooser, but it looks like the package got removed from the Arch repositories, so I guessed that it is safe to remove it.

why netbeans doesn't upgrade in this update ...? :unamused:

During the update my system left me with a black screen and a blinking cursor, I went to a TTY and rebooted and the update continued, without further more issues.

2 Likes

Same problem there but also was able to restart computer and finish update process correctly, seems to work ok now.

Because netbeans was updated on 2016-10-07 (https://www.archlinux.org/packages/community/any/netbeans/) but Manjaro uses packages from Tue Oct 05 19:26 CEST 2016 as stated at the beginning of this post.

All good except Kodi fails to start > ERROR: Unable to create GUI. Exiting

/usr/bin/kodi: line 165: 1857 Segmentation fault (core dumped) "$LIBDIR/${bin_name}/${bin_name}.bin" $SAVED_ARGS

Log:

2:20:58 T:139776061167104 ERROR: CWinSystemX11::XErrorHandler: BadValue (integer parameter out of range for operation), type:0, serial:87, error_code:2, request_code:154 minor_code:3
12:20:58 T:139776061167104 ERROR: GLX Error: Could not create context
12:20:58 T:139776061167104 ERROR: InitRenderSystem() glewInit returned 1: Missing GL version
12:20:58 T:139776061167104 FATAL: CApplication::Create: Unable to init rendering system

Seems to be an X problem, maybe GLX?

Mine went to a blackscreen too, I had to shutdown. When I restarted, Konsole had a bunch of downgrade suggestions. So I said Y, figuring that the upgrade went bad and I could do it again. No such luck, now Konsole says there is nothing to do but I can see that is not true. It just will not upgrade anymore. Anyone know how I can try again?

Update: I shut down my machine and when I restarted the updates were there again, only this time there were 850 MB of them! I used Konsole again: sudo pacman -Syyu and again it went into a black screen. Restarted again and the update stuck! A bit rough on the nerves...

One more thing, I had to delete Qtchooser else the update stops dead in its tracks.

The update went smooth so far, but while updating a console appears. I had insert a sd card.

1 Like

Same issue. However additionally running the 4.8.1 kernel with the latest updates freezes my system. Returning to the 4.7 kernel gets me back up and running. Installed the 4.8 kernel first and then the updates without restarting the pc, could this have caused issues?

Also my favorites disappeared and xfce logo appeared on my start button instead of manjaro logo. First time manjaro updates don't work out of the box in a year time, still very good job. Will remain on the 4.7 kernel for now.

1 Like

Ok EDIT, corrected due to a third part repo. That's my fault. But I NEED CUDA

1st time ever that I report a problem with the update

I run xfce version so why is it trying to install the Mate DE

http://storage5.static.itmages.com/i/16/1009/h_1476012163_6562825_221c2bcadb.png

Regards Zeb...

i never did updates with pamac.
but if you do the update. it will tell you why it want to install new package. (required by.... )

Hi

[zebedee@i7-manjaro ~]$ sudo pacman -Syyu
:: Synchronising package databases...
core 138.9 KiB 5.90M/s 00:00 [################################################] 100%
extra 1923.3 KiB 8.31M/s 00:00 [################################################] 100%
community 4.0 MiB 8.48M/s 00:00 [################################################] 100%
multilib 193.4 KiB 8.21M/s 00:00 [################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: qt5-base and qtchooser are in conflict. Remove qtchooser? [y/N] y

Packages (82) babl-0.1.18-1 cups-2.2.1-1 deluge-1.3.13+2+g6c73105-1 device-mapper-2.02.166-1 ffmpeg-1:3.1.4-2 ffmpeg2.8-2.8.7-4
gc-7.6.0-1 ghostscript-9.20-2 gst-plugins-bad-1.8.3-2 hplip-3.16.9-1 iana-etc-20160927-1 jbig2dec-0.13-1
jsoncpp-1.7.6-1 lib32-libdrm-2.4.71-1 lib32-libx11-1.6.4-1 lib32-libxfixes-5.0.3-1 lib32-libxi-1.7.7-1
lib32-libxrender-0.9.10-1 lib32-libxtst-1.2.3-1 lib32-mesa-12.0.3-2 lib32-util-linux-2.28.2-1 lib32-wayland-1.12.0-1
libcups-2.2.1-1 libdrm-2.4.71-1 libfbclient-2.5.6.27020-1 libindicator-gtk2-12.10.1-7 libindicator-gtk3-12.10.1-7
libmm-glib-1.6.2-1 libnm-glib-1.4.2-1 libsystemd-231-4 libtool-2.4.6-6 libx11-1.6.4-1 libx264-2:148.20160920-1
libxfixes-5.0.3-1 libxi-1.7.7-1 libxrandr-1.5.1-1 libxrender-0.9.10-1 libxtst-1.2.3-1 libxv-1.0.11-1 linux44-4.4.24-1
linux44-ndiswrapper-1.59-25 linux44-nvidia-1:370.28-5 linux47-4.7.7-1 linux47-ndiswrapper-1.59-7
linux47-nvidia-1:370.28-5 lvm2-2.02.166-1 mate-desktop-1.16.0-1 mesa-12.0.3-2 mhwd-nvidia-304xx-304.132-1
mhwd-nvidia-340xx-340.98-1 modemmanager-1.6.2-1 mono-4.6.1.3-1 mpfr-3.1.5-1 nettle-3.3-1 network-manager-applet-1.4.2-1
networkmanager-1.4.2-1 networkmanager-openvpn-1.2.6-1 networkmanager-pptp-1.2.4-1 networkmanager-vpnc-1.2.4-1
nm-connection-editor-1.4.2-1 openjpeg2-2.1.2-1 openssh-7.3p1-2 pacman-mirrorlist-20161003-1 pluma-1.16.0-2
python2-setuptools-1:28.1.0-1 qt4-4.8.7-10 qt5-base-5.7.0-3 qtchooser-53-2 [removal] rtkit-0.11+6+g417bb7d-1
smplayer-16.9.0-1 steam-manjaro-1.0.0.52-3 sudo-1.8.18-1 systemd-231-4 systemd-sysvcompat-231-4 thunderbird-45.4.0-1
tzdata-2016g-1 vlc-2.2.4-4 x265-2.1-1 xf86-input-evdev-2.10.4-1 xf86-input-libinput-0.20.0-1 xfce4-notifyd-0.3.3-1
xkeyboard-config-2.19-1

Total Download Size: 343.54 MiB
Total Installed Size: 1016.64 MiB
Net Upgrade Size: 8.74 MiB

:: Proceed with installation? [Y/n] n
[zebedee@i7-manjaro ~]$

it doesn't tell me why - it just lists it

Regards Zeb...

Forum kindly sponsored by