[Stable Update] 2016-10-09 - Kernels, Manjaro Tools, Deepin, NM, LibreOffice, Steam

If bash is broken there is little way to fix anything.

This one was missing in my notes for manual procedure... added, thank you!

Edit/deleted my comment, I see you solved it already

This is needed for kernel manipulations, source Arch Wiki.

Ahh, gotcha! Adding a note so I know why it is there :-)))

I had this same issue with my 4.4 Kernel.
Should I open a thread about this?

It seems that Phil fixed this with a package update request, perhaps the same should be done with "linux42-nvidia-340xx" ?

It has happened since ever in manjaro xfce, my network applet just doesn't work if I put my laptop to sleep and wake it up after a while. It shows no connection and no network to select but the internet acess is working fine.

@Luks

sudo systemctl restart NetworkManager 

Works as a temporary fix.

Automate by creating:

/etc/systemd/system/resume@.service
[Unit]
Description=User resume actions
After=suspend.target

[Service]
User=%I
Type=simple
ExecStart=systemctl restart NetworkManager

[Install]
WantedBy=suspend.target 

Works for me most of the time.

2 Likes

Thanks for your tip \o

And if you scroll up or search the forums there are many many more posts about this.
A better fix would be to downgrade networkmanager and network-manager-applet to 1.4.0-1 until upstream gets it together. It's less work, less overhead, and it works flawlessly :wink:

To watch the ongoing saga that is the buggy applet keep an eye on this thread (started May 16)
Network Manager Applet Error after Suspend

Is this true ? Does it 'urge' or 'inform' ? Either way, is this not a setting of MSM Notifier ?
Anyone else want to confirm ?

I confirm. You can turn off all notification in the msm notifier settings. Or even uninstall it :wink:

The good news is that all my missing icons came back except the one for vte terminal.

The bad news is:

  1. Manjaro Settings Manager fails silently
  2. Login Window setting manager fails silently
  3. In vte terminal, the font has changed such that the 'm' character looks like a black square
  4. I had to fixup .config/fontconfig/fonts.conf

434 packages updated. It went well following philms' advice to upgrade systemd first.

One issue I notice is firefox has a dark theme (before upgrade the theme was light theme) and the menus overwrite themselves so they can't be read. What can I do to fix this?

Using 4.7 kernel, firefox 49.0.2 on KDE5.

Thanks.

I have an unsolved problem with update:

"udiskie: signature from "Ambrevar ambrevar@gmail.com" is unknown trust
file /var/cache/pacman/pkg/udiskie-1.5.1-1-any.pkg.tar.xz is broken (incorrect or broken pack (PGP signature))." (translated on my own from polish output in terminal).

Removing and downloading the file doesn't help.

[quote="Mleko, post:309, topic:10663"]
I have an unsolved problem with update:
[/quote]Did you mean to post in
[Stable Update] 2016-10-23 - Manjaro 16.10 Final Release thread at
[Stable Update] 2016-10-23 - Manjaro 16.10 Package Release ?

This is the OLD update thread for Stable.

All of Ambrevar SW is tagged as untrusted because the keys don't match. DO a
sudo pacman-key --refresh-keys
If that does not do it, remove the package(s) and do the update [2016-10-23-manjaro]. You can re-install once the key/signature is fixed if you want the SW.
NB: udiskie is "Required By : None" (here, at least), ;).

sudo pacman-key --refresh-keys

Thanks a lot, that helped! :slight_smile:
I'm sorry, I haven't noticed the date of the post. Somehow it appeared as the newest one so I wrote my comment under it. :frowning:

glad it helped, :slight_smile:.
...no problem just thought the current topic might yield more help 4U.

[quote="Mleko, post:311, topic:10663"]
Somehow it appeared as the newest
[/quote]Yea, related issue is being discussed here:
Topic "Announcement" should get 3 sub-topics.

GL@U and ...
Have Fun!

Hi guys,
Update KDE to Lenovo Edge worked flawlessly, Thanks (again).

System: Host: laptop Kernel: 4.4.27-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.8.2
Distro: Manjaro Linux
Machine: System: LENOVO (portable) product: 0578F9U v: ThinkPad Edge
Mobo: LENOVO model: 0578F9U BIOS: LENOVO v: 80ET52WW (1.29 ) date: 05/30/2011
CPU: Dual core Intel Core i3 M 370 (-HT-MCP-) cache: 3072 KB
clock speeds: max: 2399 MHz 1: 1466 MHz 2: 1599 MHz 3: 1333 MHz 4: 1199 MHz
Graphics: Card: Intel Core Processor Integrated Graphics Controller
Display Server: X.Org 1.18.4 driver: intel Resolution: 1366x768@60.03hz
GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 12.0.3

Update to workstation, very tricky, but is the culprit was the NVidia driver (see output of inxi). But also thanks again. I love Manjaro

System: Host: workstation Kernel: 4.7.10-1-MANJARO x86_64 (64 bit)
Desktop: Xfce 4.12.3 Distro: Manjaro Linux
Machine: System: ASUS product: All Series
Mobo: ASUSTeK model: B85M-E v: Rev X.0x
BIOS: American Megatrends v: 2202 date: 02/13/2015
CPU: Quad core Intel Core i5-4690 (-MCP-) cache: 6144 KB
clock speeds: max: 3900 MHz 1: 2736 MHz 2: 1503 MHz 3: 2723 MHz
4: 3428 MHz
Graphics: Card: NVIDIA G71GL [Quadro FX 1500]
Display Server: X.Org 1.18.4 driver: nouveau
Resolution: 1680x1050@59.95hz, 1680x1050@59.88hz
GLX Renderer: Gallium 0.4 on NV49 GLX Version: 2.1 Mesa 12.0.3

After trying all the combinations of CLI-install or GUI-install and KDE, Xfce or network and free or proprietary drivers: GUI-installation of Xfce and proprietary but as soon as you can (before rebooting or updating) revert to the nouveau video driver and uninstall the NVidia-30xx. Now you can reboot and everything work as it should. My guess is the upgrade bombed because the same NVidia driver. Probably I could revert to the KDE Desktop, but I'll give Xfce a try, it is so nimble.
I read the video driver caused a few headaches, could be the old card? but before it was working well with the NVidia driver.

Forum kindly sponsored by