[Stable Update] 2016-10-09 - Kernels, Manjaro Tools, Deepin, NM, LibreOffice, Steam

You are using an Arch based distro and you don't want to "learn about Linux troubleshooting"? Then maybe you should consider a non rolling Linux distro. I'm not being passive aggressive here, it is genuinely something you should consider.

Manjaro is a leading edge rolling Arch based distro, every now and then there will be a bump in the road. That is the trade off when you are using the most recent version of kernels, drivers, DEs, system components and apps. Every effort is made to catch issues before they hit Stable repos, but occasionally something will slip between the cracks.

Hopefully the Manjaro community can help get you back up and running soon.


might be a good idea to open a new thread then. more people from the community will have a chance to see it and get involved. you will be fine.

Petulance won't get your issue solved any faster.

If you want stability, install Debian stable.
If you want convenience, check out Linux Mint.
If you want to learn about Linux, install Arch.
If you want Arch with a reasonable amount of convenience and stability, install Manjaro.

Manjaro is Arch-based. Cutting edge software and frequent updates come with inherent risk to the end user. Manjaro will never be as stable as other slower, and more conservative, distributions.

As @badbodh said in another thread: Manjaro is "beginner-friendly, not beginner-proof."

I am really not trying to chide you here. But if you use Manjaro, these problems are absolutely, positively, going to happen at some point. Don't be surprised when they do.


20 posts were split to a new topic: Manjaro debates: How to avoid Stable updates breaking the system?

i've spent all day installing arch. very hard. the current kernel is now 4.7.6

I have to apologize for my last post, I came from a long flight and was deadly tired (never update a system when being sleepy... lesson learned..).

Anyway, I managed to recover my installation by using a LiveCD with Manjaro, chroot into my system and repaired the broken update by reinstalling the packets that got upgraded based on the pacman.log. I guess the issue was that I rebooted too fast after the XSession got lost and interrupted the installation at an critical point. Now I'm up-to-date and everything is working as expected. Updated another system by switching to the tty and everything worked like a charm directly.



This may help...

I've just done the update following the recommendations: TTY2, sudo pacman -Syu, all perfect. Just only get the black screen at the end, but after pressing Ctrl + Alt the TTY returned. Then I've rebooted and logged in my session as usual.

Thank to the Manjaro Team!!

Regards!! :slight_smile:

PD: Just FYI, my kernel is default 4.4, free Radeon drivers and only a few and necessary packages installed from AUR.

The same for me. Fortunately nothing worse. Gruss aus Zürich

No black screen, but intermittently the system will completely freeze forcing a hard reset. Lesson learned to not update immediately. Thanks for the effort though and good luck to you guys smoothing things out!

Hi! Update went fine:

  • updated from TTY without any other logged session.
  • haven't updated the 3 systemd packages mentioned by @philm at top of the thread. I'll wait for the next release of systemd.

Some suggestions for those stuck at a black screen after successfully booting grub:

Try to downgrade libsystemd, systemd and systemd-sysvcompat packages:

  • login through TTY as root (or use sudo if you don't)
  • ls /var/cache/pacman/pkg | grep systemd
  • note the filename of the previous version of the 3 packages mentioned above. On my system they are libsystemd-231-1-i686.pkg.tar.xz, systemd-231-1-i686.pkg.tar.xz and systemd-sysvcompat-231-1-i686.pkg.tar.xz (this might differ in your system).
  • # pacman -U /var/cache/pacman/pkg/libsystemd-231-1-i686.pkg.tar.xz /var/cache/pacman/pkg/systemd-231-1-i686.pkg.tar.xz /var/cache/pacman/pkg/systemd-sysvcompat-231-1-i686.pkg.tar.xz
  • # reboot now

If this doesn't work and you use proprietary drivers (especially nvidea ones, because they seem more problematic), try to do the same with those or switch to free drivers to see if the problem goes away.

If this still doesn't work try an older kernel (linux41, for example).

If I'm completely wrong and peeing off the pot, sorry! Just trying to help.

I use krusader-git in KDE and i3 and it doesn't seem to depend on qt4. I had to install some KDE packages on i3 for it work properly, including plasma-workspace and kuiserver5 (it works fine without it, but things like thumbnailing and networking need extra packages). However, I don't start KDE as I login (only kuiserver5), so I don't get the memory footprint. Krusader only uses kio slaves as it needs and then turns them off. It works much better that krusader 2.4.0.


screen went black during the update.

upgrade of lightfirefox-49.0-1 (from lightfirefox-48.0-1) was unstable. Had to move the entire browser window to see changes.

uninstalled lightfirefox-49.0-1

re-installed lightfirefox-48.0-1 which runs stable.

will monitor and report if see other issues.

1 Like

Bad update here
Screen went black during while updating systemd. The system went off a few seconds later. Now it's broken.
I've already tried $ sudo fsck /dev/sda -f and $ sudo fsck /dev/sda -y to try to solve the non-contiguos part (in a live midia). Now the command says that everything is "clean" but the system is still dead.

I don't know whatelse to do.

  • Try to boot with a different kernel and check /var/log/pacman.log which package didn't update as it should, reinstall it with
    sudo pacman -S --force
  • Or boot with a Manjaro install medium, chroot with mhwd-chroot, check pacman.log and reinstall the package with --force or re-run the update with pacman -Syyu --force.

Thanks for your help, the problem was in the kernel 4.7.x
It was missing a file according to the log file. I will remove it, update the system and than maybe reinstall it or stay in the kernel 4.4.

1 Like

Hi, this error happend only with the kernel 4.8, I have connected a Verbatim universal card reader.

scsi host9: runtime PM trying to activate child device host9 but parent (1-4:1.0) is not active

I also had a freeze ( kernel 4.8), but I could not find the reason for this.

1 Like

Successful update using the pacman tty method on KDE.

As a linux newb I got stuck after the update on how to get out of tty-- I used Ctrl + Alt + Del, which closed tty and rebooted, and that worked perfectly. :slight_smile:

I cannot more use steam after this update. I use steam-manjaro and my game is borderlands 2.

I removed both, redownloaded and reinstalled -> same

steam work, but not the game. What can I try ? The process starts, but nothing appears on the screen.

kernel 4.6

This was at last a great advice.

/etc/mkinitcpio.conf was correct and the 4.7.7 kernel was booting without errors, the 4.8.1 not (on my laptop). I tried sudo mkinitcpio -p linux48 again and now the 4.8.1 kernel is booting too without problems.

Seems, the update problem with systemd caused a missing execution of mkinitcpio for the 4.8 kernel. Now all my systems back on the road again ... :slight_smile:

Swapped to another virtual terminal (tty2) and performed the update there, rebooted and no problems to report. Thx.

1 Like

Forum kindly sponsored by