[Stable Update] 2016-10-09 - Kernels, Manjaro Tools, Deepin, NM, LibreOffice, Steam

I've added now an update recommendation also on our blog.

1 Like

"post a screenshot" lool. it only displays for 1 second and how to take a screenshot while locked out?

the screen I'm talking about appears after the Manjaro loading screen and before the user login screen.

I'll try to take a pic with my phone to show you.

Updated succesfully following the recommended tty2 procedure. The old one, not the enhanced version with the pre-update step. Went well, although I was a bit concerned after reading about the issues with the current update. Thanks to everyone involved.

Is this the same list of red warnings you see in

journalctl -b

followed by a couple page down keys?

not sure but I took a pic of the screen with my phone.

[quote="philm, post:1, topic:10663"]
IF WE BROKE YOUR SYSTEM WITH THIS - WELL WE ARE SORRY.
[/quote]Thanks for that ...
It is broken.
It broke during the upgrade with a kernel panic. (yes tty was being used; kernel was 4.8.1)
The system survived that so started the upgrade again. It completed(with systemd v.234).
Reboot and got a blank screen, completely blank/black - no cursor/pointer, nothing.
At tty2 I found that sddm and Xorg(as well a dbus for sddm) were all running.
...(hours of uninstall, reinstall, downgrade, upgrade, reboots ...)
There is some issue with QML, hence sddm won't (ever) display the login.

Tried lightdm but lightdm won't run as long as sddm is installed{*}. Of course the problem is not the DM so no point in removing SDDM even if I wanted to switch(& I do not).

The startkde won't start X (:confused:) ...etc.
...
I finally got to KDE with startx but plasma will not start because it, now, cannot use OpenGL 2 ...which is what it has been using until this update borked the GUI system.

I am fring tired and need a break ... and lunch.

The last couple updates were not good either, tho' I did not experience the broken system like so many did; guess I was just lucky. ...not this time, :frowning:.

Maybe instead of having updates on a timed schedule, they should be on a participation schedule which lasts (up to) two weeks. @philm, WDYT?

...

{*} installed really means sddm.service is enabled by/with systemd. When a [DM] is enabled a symlink is created: /etc/systemd/system/display-manager.service → /usr/lib/systemd/system/[DM].service.
..."installed" a lot easier and shorter, ;), albeit not accurate.

1 Like

[quote="Aditya, post:40, topic:10663"]
and has linux dumped the LTS concept?
[/quote]The next LTS is kernel 4.9. Greg K-H announced on Google+ as his blog is/was broken:
--- https://plus.google.com/+gregkroahhartman/posts/DjCWwSo7kqY\

But one should read this in the responses too:

"
The LTS kernel has nothing to do with the "normal" kernel cadence or release cycle or stability at all. It's all for those companies that somehow feel that sticking with a specific kernel version fits their business/product model.
"

IOW, LTS kernels have no more magic than any other kernel.

I'm still wondering about this question.

@neognomic: sorry to hear that you have some issues with your system. As I always test on regular basis if a vanila installation of Manjaro KDE still runs it was enough for me. At some point we have to push the update to stable branch. Manjaro KDE 16.10-rc1 seems to run just fine. We try to avoid these issues, but not all can be avoided ... nvidia-304xx is known to have some issues with release v304.132 producing black screens. Maybe that combination creates some issues on your end ...

@double-gulp: seems some issue with your encrypted swap-drive. Some similar got already posted due our reviews of this update. You may want to edit your grub.cfg on bootup to avoid mounting your swap. Check the resume= line within your boot entry and remove it temporally. How to edit it I already posted in regard of the plymouth disable.

3 Likes

Check out this guide, but verify if it apply for encrypted system!

says nothing about encrypted drives.

@double-gulp: Here is some guide for encrypted systems. Also it is recommended to disable the swap temporally so you might be able to boot. Which graphical driver do you use?

say i do get into my system. once there i have no idea what's broken or how to fix it.

i'm just going to use the liveCD to copy files from my computer to a usb drive and reinstall Manjaro completely.

but thanks for the help. still love Manjaro and won't be switching.

3 Likes

I second this. I use Spyder heavily for work (I tried the Qt5 version on AUR, but it was still not at all usable...). Please, do not remove Qt4 in the near future, still many apps depend on it (KDE or outside KDE).

Just updated a freshly installed Mate Desktop install from the latest stable ISO. Used TTY2 for the update and had no issues.

I think they can both be installed, but only one can/would be enabled in systemd

I switched to lightdm from sddm, and it fixed another problem I was having.
See: Switching to LightDM instead of SDDM

So if you think sddm might be at fault, just try lightdm for a bit. It
did solve my problem. And switching back to sddm is just as easy.

@double-gulp: sorry that we couldn't figure out what went wrong on your end. Good luck on installing Manjaro 16.10-rc1.

XFCE/Stable/Systemd/4.7(4.4 also installed)/Intel


Ctrl+Alt+f2

Login with username/password

sudo pacman -Syyu

Remove qtchooser? - Y

reboot -n

###No Problem.

I just followed the revised upgrade instructions, and all went well!

Wonderful! Thank you :wink:


System:    Host: manjaro1 Kernel: 4.4.24-1-MANJARO x86_64 (64 bit)
Desktop:   KDE Plasma 5.7.5 Distro: Manjaro Linu

` Machine: System: Hewlett-Packard product: HP Compaq 6200 Pro
Mobo: Hewlett-Packard model: 1497
UEFI: Hewlett-Packard v: J01 v02.06 date: 06/09/2011
CPU: Dual core Intel Core i3-2100 (-HT-MCP-) cache: 3072 KB
Graphics: Card: Intel 2nd Gen Core Processor Family Integrated
Graphics Controller

Hate to say it but the new systemd crashes calamares-dev on your 16.10 rci iso with a report about systemctrl and lightdm broken

Forum kindly sponsored by