[Stable Update] 2016-12-07 - Systemd, Kernels, Firefox, Thunderbird, Mesa, Python

Hi Community,

We have now Systemd v232, updated Firefox and Thunderbird, renewed most of our
edition settings, updated our python-stack, bumped most of our kernels and
released the latest Mesa point-release. Package changes can be found here.

Upstream packages are up till: Sat Dec 3 10:37:27 CET 2016

Report back your findings as usual ...


Update instruction

FOR SYSTEMD USERS HAVING STILL v231-1 INSTALLED, IT IS RECOMMENDED TO USE PACMAN, AS X-SESSION MIGHT GET LOST DUE THIS UPDATE. THEREFORE WE SUGGEST TO FOLLOW OUR UPDATE RECOMMENDATION. YOU CAN TRY IF FOLLOWING CMD MIGHT CRASH YOUR SYSTEM: sudo systemctl --system daemon-reexec

Check if your mirror has synced, then do the following steps to have a smooth update:

sudo pacman -Sy
sudo pacman -S archlinux-keyring
sudo pacman -Su

Troubleshoots

Information for Catalyst users

If you are using an AMD card with Catalyst it is STRONGLY RECOMMENDED to use pacman for this update!!! The new style how Catalyst works now, would be this:

  • Catalyst-Utils needs now three new packages: catalyst-video, catalyst-input and catalyst-server.
  • Catalyst-Video provides some needed drivers like Intel and Vesa, since we have some hybrid systems too
  • Catalyst-Input provides the needed input drivers
  • Catalyst-Server provides the compatible Xorg-Server

Without these packages it would be not possible to still provide Catalyst at all. So it is logical to remove conflicting packages on these AMD systems. It can be tested with a new dev-build. If there are still issues regarding Catalyst, open an issue or a new thread, so we can discuss it.

Disable random mac address for your WLAN

Use nmcli to set 802-11-wireless.mac-address-randomization to never on a per connection basis or set

[device]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf to disable the feature completely.

Issues with updating MATE

Some users have mate-menu installed from AUR. Please remove this package if you use the GTK2 version of MATE before trying to update. If you have a different issue with updating, please post.

LibreOffice and GTK3

LibreOffice might be broken on gtk-based Desktop Environments. Workaround would be to force a look to Libreoffice by editing /etc/profile.d/libreoffice*sh. We recommend to uncomment SAL_USE_VCLPLUGIN=gtk. Our KDE edition isn't affected by this issue.

GTK3

With this we updated Gnome and GTK to 3.22. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.22-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.22 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

We support now several different steam-clients:

  • steam-manjaro: is our definition how steam should work on Manjaro.
  • steam-native: is our definition how steam should be used with our native libraries

The clients by Manjaro are better tested and prefered for Manjaro Linux. However the upstream versions might also work for you.

Reference: Archlinux wiki


Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Current supported kernels

  • linux310 3.10.104
  • linux312 3.12.68
  • linux316 3.16.39
  • linux318 3.18.45
  • linux41 4.1.36
  • linux44 4.4.36
  • linux47 4.7.10 [EOL]
  • linux48 4.8.12
  • linux49 4.9rc7
  • linux-RT-LTS 4.4.32_rt43
  • linux-RT 4.8.6_rt5

Package Changes

  • stable community i686: 581 new and 571 removed package(s)
  • stable community x86_64: 581 new and 571 removed package(s)
  • stable core i686: 35 new and 31 removed package(s)
  • stable core x86_64: 35 new and 31 removed package(s)
  • stable extra i686: 451 new and 453 removed package(s)
  • stable extra x86_64: 451 new and 453 removed package(s)
  • stable multilib x86_64: 27 new and 23 removed package(s)
11 Likes

linux49-rc7
Plasma
steam
FF & TB
LOffice

every works perfectly fine!

4 Likes

Works perfect! Also openoffice seems fine and happy.

OS: Manjaro 16.10 Fringilla
Kernel: x86_64 Linux 4.8.12-1-MANJARO
Packages: 1118
Shell: bash 4.4.5
Resolution: 1920x1080
DE: GNOME 
WM: GNOME Shell
WM Theme: meines-frankenstein
GTK Theme: Arc-Darker [GTK2/3]
Icon Theme: Arc
Font: Cantarell 11
CPU: Intel Core i7-5600U @ 4x 3.2GHz [42.0°C]
GPU: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) 
RAM: 1031MiB / 11739MiB
1 Like

2 Likes

Any word on when the Nvidia 375.20 driver is planned on being pushed into stable?

1 Like

Worked fine in KDE using Octopi.

Dec 08 11:24:04 manjaro-msi systemd-coredump[1149]: Process 1086 (kactivitymanage) of user 1000 dumped core.

                                                    Stack trace of thread 1089:
                                                    #0  0x00007fb13c2b1449 n/a (n/a)
- Subject: Process 1086 (kactivitymanage) dumped core
- Defined-By: systemd
- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
- Documentation: man:core(5)
-
- Process 1086 (kactivitymanage) crashed and dumped core.
-
- This usually indicates a programming error in the crashing program and
- should be reported to its vendor as a bug.

KDE coredump at boot is not good, although the machine is successfully booting into the DE. What does kactivitymanage do?

Also, my /etc/resolv.conf was clobbered during this update meaning no address resolution, and I had to replace it from a backup. Did this update attempt to regenerate resolv.conf and fail in some way, possibly related to permissions on resolv.conf (or its symlink)?

So I guess my questions are :

  1. How and when is resolv.conf generated?

  2. What does kactivitymanage do and why does a faulty resolv.conf cause it to crash on boot?

EDIT: Replacing the resolv.conf file also fixed the kactivitymanage crash and core dump.

EDIT2: etc/resolv.conf is symlinked to usr/lib/systemd/resolv.conf. So I guess the systemd update replaced resolv.conf. Only problem was it contained a single non DNS server IP address. Should it have been regenerated in some way to be useful?

$ ll /etc/resolv.conf
lrwxrwxrwx 1 root root 30 Oct  8 22:58 /etc/resolv.conf -> ../usr/lib/systemd/resolv.conf
$ ll /usr/lib/systemd/resolv.conf
-rw-r--r-- 1 root root 101 Dec  8 12:16 /usr/lib/systemd/resolv.conf
$ lsattr /usr/lib/systemd/resolv.conf
--------------e---- /usr/lib/systemd/resolv.conf

Any reason why the latest chromium browser didn't make it into this round of updates?

2 Likes

Worked fine on netbook version, using GUI updater.

Works on 4.4 kernel hosting virtualbox.

Works perfect.

Thank you all.

System:    Host: manjaro Kernel: 4.4.33-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.8.4
           Distro: Manjaro Linux
Machine:   Device: desktop System: ASUS product: All Series
           Mobo: ASUSTeK model: Z97-E/USB 3.1 v: Rev X.0x
           UEFI [Legacy]: American Megatrends v: 0701 date: 03/16/2016
CPU:       Quad core Intel Core i7-4790K (-HT-MCP-) cache: 8192 KB 
           clock speeds: max: 4400 MHz 1: 4200 MHz 2: 4199 MHz 3: 4199 MHz 4: 4200 MHz 5: 4200 MHz 6: 4199 MHz
           7: 4200 MHz 8: 4200 MHz
Graphics:  Card: NVIDIA GF119 [GeForce GT 610]
           Display Server: X.Org 1.18.4 driver: nouveau Resolution: 1440x900@59.89hz
           GLX Renderer: Gallium 0.4 on NVD9 GLX Version: 3.0 Mesa 13.0.2
Audio:     Card-1 Intel 9 Series Family HD Audio Controller driver: snd_hda_intel
           Card-2 NVIDIA GF119 HDMI Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.33-1-MANJARO
Network:   Card: Intel Ethernet Connection (2) I218-V driver: e1000e

How do I know from Octopi which mirror I am using?

New to the family. This is my first big stable upgrade. Installed Manjaro with Cinnamon 16.10.3. Running fine without any performance issues. Good job dev team.:clap:

Only thing I'm getting annoyed by is that when I rename something in Manjaro Cinnamon, the "name" doesn't get highlighted like most other distros out there, it only gets bold. It was a bit disconcerting to say the least. I've since switched to arc theme and in arc everything is back to normal. Can devs please look into it?

Here's another small issue I found. Don't know if it's fixed in the new stable update. Will update the linked thread if it's solved.

Thank you Manjaro!

Best way for me is to look in /etc/pacman.d/mirrorlist, which is generated by pacman-mirrors. Pacman will use the first mirror (ie Server=xxxxx) in this file.

Sometimes if my fastest local mirror is taking forever to sync, I'll check for other mirrors that have already synced, manually edit /etc/pacman.d/mirrorlist to put a synced mirror first, then do a system upgrade. Just make sure this mirror is not really slow, or create a VPN connection to a server near this mirror if you really cannot wait.

When done I'll then run sudo pacman-mirrors -g to regenerate mirrorlist.

2 Likes

Might be best to post this in the Cinnamon forum instead of here.

With Cinnamon being a community edition, I don't think it is officially supported by Manjaro devs, but the people that put together the community editions are pretty good.

Sorry, my bad. I thought this "renaming" bug was a theme related issue and since vertex maia is kind of official-ish(?) theme of Manjaro I thought the theme needed some fixing. Also, I am using arc theme now and the problem doesn't occur here. But if it's a problem at cinnamon's end then I'll of course take your advice and bug report it to upstream.

you wouldn't want that :stuck_out_tongue:
It causes a lot of problems and especially on Plasma Users

for more info

Sorry, I was unclear.

I meant to raise any Manjaro Cinnamon issues you may have in the Manjaro Cinnamon sub-forum, where the community that put this together will see it and be able to respond. Buried in an update thread I don't think the people that can answer your question will necessarily see it.

Whether its an upstream problem or localised Manjaro Cinnamon config issue, those that maintain it are best able to help determine.

I don't know why but I personally think manjaro is more newbie friendly than ubuntu or any other debian based distros. It's super easy to install programs and it's just as stable as an LTS distro. I really thank the manjaro community & team for making this distro as good as it is now.

4 Likes

Awesome update! Thank You!
I had an issue, but was brought upon by my own stupidity.haha

Forum kindly sponsored by