[Stable Update] 2016-12-15 - Linux v4.9.0, Haskell, Steam, X-Apps, Flash

Hi Community,

we finally released kernel v4.9.0, updated our haskell-stack, fixed some issues in our steam client and renewed some of the x-apps. We also updated Flash to v24 series, which includes many security fixes. All in all it should be a smooth update. Tell us otherwise. We are currently also in preparing to up our Xorg-Stack to Xorg-Server 1.19 series. Stay tuned on that matter ...

Upstream packages are current till Tue Dec 13 08:22:29 CET 2016

Report back your findings as usual ...


Update instruction

FOR SYSTEMD USERS HAVING STILL v231-1 INSTALLED, IT IS RECOMMENDED TO USE PACMAN, AS X-SESSION MIGHT GET LOST DUE THIS UPDATE. THEREFORE WE SUGGEST TO FOLLOW OUR UPDATE RECOMMENDATION. YOU CAN TRY IF FOLLOWING CMD MIGHT CRASH YOUR SYSTEM: sudo systemctl --system daemon-reexec

Check if your mirror has synced, then do the following steps to have a smooth update:

sudo pacman -Sy
sudo pacman -S archlinux-keyring
sudo pacman -Su

Troubleshoots

Information for Catalyst users

If you are using an AMD card with Catalyst it is STRONGLY RECOMMENDED to use pacman for this update!!! The new style how Catalyst works now, would be this:

  • Catalyst-Utils needs now three new packages: catalyst-video, catalyst-input and catalyst-server.
  • Catalyst-Video provides some needed drivers like Intel and Vesa, since we have some hybrid systems too
  • Catalyst-Input provides the needed input drivers
  • Catalyst-Server provides the compatible Xorg-Server

Without these packages it would be not possible to still provide Catalyst at all. So it is logical to remove conflicting packages on these AMD systems. It can be tested with a new dev-build. If there are still issues regarding Catalyst, open an issue or a new thread, so we can discuss it.

Disable random mac address for your WLAN

Use nmcli to set 802-11-wireless.mac-address-randomization to never on a per connection basis or set

[device]
wifi.scan-rand-mac-address=no

in /etc/NetworkManager/NetworkManager.conf to disable the feature completely.

Issues with updating MATE

Some users have mate-menu installed from AUR. Please remove this package if you use the GTK2 version of MATE before trying to update. If you have a different issue with updating, please post.

LibreOffice and GTK3

LibreOffice might be broken on gtk-based Desktop Environments. Workaround would be to force a look to Libreoffice by editing /etc/profile.d/libreoffice*sh. We recommend to uncomment SAL_USE_VCLPLUGIN=gtk. Our KDE edition isn't affected by this issue.

GTK3

With this we updated Gnome and GTK to 3.22. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.22-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.22 compatible, is Vertex-Maia

You can install it with:

sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia

QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.

ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

We support now several different steam-clients:

  • steam-manjaro: is our definition how steam should work on Manjaro.
  • steam-native: is our definition how steam should be used with our native libraries

The clients by Manjaro are better tested and prefered for Manjaro Linux. However the upstream versions might also work for you.

Reference: Archlinux wiki


Did you experience any issue with this update?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Current supported kernels

  • linux310 3.10.104
  • linux312 3.12.68
  • linux316 3.16.39
  • linux318 3.18.45
  • linux41 4.1.36
  • linux44 4.4.38
  • linux48 4.8.14
  • linux49 4.9.0
  • linux-RT-LTS 4.4.32_rt43
  • linux-RT 4.8.11_rt7

Package changes

  • stable community i686: 124 new and 123 removed package(s)
  • stable community x86_64: 125 new and 124 removed package(s)
  • stable core i686: 4 new and 4 removed package(s)
  • stable core x86_64: 4 new and 4 removed package(s)
  • stable extra i686: 27 new and 24 removed package(s)
  • stable extra x86_64: 27 new and 24 removed package(s)
  • stable multilib x86_64: 2 new and 1 removed package(s)

:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                               eudev                3.2-4              3.2.1-1
                            libeudev                3.2-4              3.2.1-1
                                 pix              1.2.0-1              1.2.1-1
                       steam-manjaro           1.0.0.54-1           1.0.0.54-2
              tintin-alteraeon2016.04.20+272.04e96c4-12016.04.20+273.f61a6fb-1
                                 xed              1.2.1-1              1.2.2-1
                             xplayer              1.2.1-1              1.2.2-1
                             xreader              1.2.1-2              1.2.2-1
                             xviewer              1.2.1-1              1.2.2-1


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
 aarch64-linux-gnu-linux-api-headers                4.8-1                4.9-1
                             awstats                7.5-2                7.6-1
                               cargo             0.14.0-2             0.14.0-3
                               cgrep             6.6.16-7             6.6.16-8
                              cython             0.25.1-2             0.25.2-1
                             cython2             0.25.1-2             0.25.2-1
                               darcs             2.12.4-3             2.12.4-4
                 deepin-file-manager            1:1.3.3-1            1:1.3.3-2
                 deepin-image-viewer              1.1.3-1              1.1.3-2
                        deepin-movie           1:2.2.10-2           1:2.2.10-4
                        deepin-music     2.3.0.20150814-2              2.3.2-1
                     deepin-terminal              2.1.5-1              2.1.5-2
                      ecryptfs-utils                108-2                111-1
                              eslint             3.12.0-1             3.12.1-1
                           filezilla           3.22.2.2-1           3.23.0.2-1
                             ghc-mod            5.6.0.0-6            5.6.0.0-7
                           git-annex         6.20161210-1         6.20161210-4
                             goagent     3.2.3.20150617-1                    -
                haskell-authenticate           1.3.3.2-21           1.3.3.2-24
                         haskell-aws             0.14.1-4             0.14.1-7
              haskell-binary-conduit            1.2.4.1-3            1.2.4.1-4
                  haskell-cheapskate           0.1.0.5-26           0.1.0.5-27
                     haskell-conduit              1.2.8-2              1.2.8-3
         haskell-conduit-combinators            1.0.8.3-2            1.0.8.3-3
               haskell-conduit-extra             1.1.15-1             1.1.15-2
                  haskell-connection              0.2.6-4              0.2.6-5
          haskell-cryptohash-conduit             0.1.1-43             0.1.1-44
                         haskell-dav             1.3.1-22             1.3.1-25
                         haskell-dns             2.0.10-1             2.0.10-2
                      haskell-either            4.4.1.1-8            4.4.1.1-9
                   haskell-esqueleto             2.4.3-45             2.4.3-46
                     haskell-ghc-mod            5.6.0.0-6            5.6.0.0-7
                      haskell-hakyll            4.9.1.0-6            4.9.1.0-9
                       haskell-hasql          0.19.15.2-2          0.19.15.2-3
                  haskell-hasql-pool              0.4.1-2              0.4.1-3
                    haskell-hopenpgp              2.5.5-8              2.5.5-9
                       haskell-hpack             0.15.0-6             0.15.0-7
             haskell-http-client-tls              0.3.3-6              0.3.3-7
                haskell-http-conduit              2.2.3-6              2.2.3-8
                      haskell-mmorph              1.0.6-2              1.0.9-1
               haskell-monad-journal              0.7.2-8              0.7.2-9
                haskell-monad-logger             0.3.20-2             0.3.20-3
             haskell-optparse-simple             0.0.3-29             0.0.3-30
                      haskell-pandoc               1.18-6               1.18-8
             haskell-pandoc-citeproc           0.10.2.2-8          0.10.2.2-11
             haskell-pandoc-crossref            0.2.4.1-4            0.2.4.1-6
                  haskell-persistent               2.6-12               2.6-13
           haskell-persistent-sqlite               2.6-12               2.6-13
         haskell-persistent-template           2.5.1.6-13           2.5.1.6-14
                       haskell-pipes              4.2.0-1              4.2.0-2
                  haskell-pipes-http             1.0.4-11             1.0.4-13
            haskell-project-template             0.2.0-36             0.2.0-37
                   haskell-resourcet              1.1.8-1              1.1.8-2
                       haskell-sandi              0.4.0-5              0.4.0-6
                       haskell-stack             1.2.0-24             1.2.0-26
                       haskell-store            0.2.1.2-8            0.2.1.2-9
           haskell-tagstream-conduit           0.5.5.3-43           0.5.5.3-45
                         haskell-tls             1.3.8-13             1.3.8-14
              haskell-wai-app-static            3.1.6.1-8            3.1.6.1-9
                   haskell-wai-extra             3.0.19-1             3.0.19-2
                    haskell-warp-tls             3.2.2-18             3.2.2-19
                        haskell-x509              1.6.4-1              1.6.5-1
                  haskell-x509-store              1.6.2-1              1.6.2-2
                 haskell-x509-system              1.6.4-1              1.6.4-2
             haskell-x509-validation              1.6.5-1              1.6.5-2
                 haskell-xml-conduit            1.4.0.1-4            1.4.0.2-1
                  haskell-xml-hamlet           0.4.0.12-5           0.4.0.12-7
                        haskell-yaml             0.8.20-1             0.8.20-2
                       haskell-yesod            1.4.3.1-9           1.4.3.1-12
                  haskell-yesod-auth          1.4.13.5-19          1.4.13.5-22
                  haskell-yesod-core             1.4.26-6             1.4.26-7
               haskell-yesod-default             1.2.0-77             1.2.0-78
                  haskell-yesod-form              1.4.9-8              1.4.9-9
            haskell-yesod-persistent           1.4.0.6-18           1.4.0.6-19
                haskell-yesod-static            1.5.1.1-6            1.5.1.1-7
                             hexchat             2.12.3-1             2.12.4-1
                              hoogle              5.0.6-2              5.0.6-3
                      hopenpgp-tools            0.19.4-10            0.19.4-12
                               idris               0.99-2               0.99-3
                             jenkins               2.35-1               2.36-1
                        libfilezilla              0.8.0-1              0.9.0-1
                            lollypop            0.9.220-1            0.9.223-1
            mate-notification-daemon             1.16.0-1             1.16.1-1
                          maxima-ecl             5.38.1-2             5.39.0-1
                               mlite             0.2.21-2             0.2.22-1
                     mysql-workbench              6.3.8-3              6.3.8-4
                           oniguruma              6.1.2-1              6.1.3-1
                            openshot              2.1.0-3              2.1.0-4
               owncloud-app-contacts          2:1.4.0.0-1            2:1.5.1-1
                               oxide             1.10.3-2                    -
                              pandoc               1.18-6               1.18-8
                     pandoc-citeproc           0.10.2.2-8          0.10.2.2-11
                     pandoc-crossref            0.2.4.1-4            0.2.4.1-6
                  perl-authen-radius               0.24-2               0.26-1
                               plank             0.11.2-1             0.11.3-1
                             postgis              2.3.0-2              2.3.1-1
                       python-celery              4.0.0-1              4.0.1-1
         python-cryptography-vectors                1.6-1                1.7-1
                    python-fonttools              3.2.2-1              3.3.0-1
                        python-ioflo              1.6.5-1              1.6.6-1
                         python-pyro               4.51-1               4.52-1
                          python-pyx               0.14-2             0.14.1-1
                   python-xlsxwriter              0.9.3-1              0.9.4-1
                      python2-celery              4.0.0-1              4.0.1-1
        python2-cryptography-vectors                1.6-1                1.7-1
                   python2-fonttools              3.2.2-1              3.3.0-1
                        python2-fuse              0.2.1-5              0.2.1-6
                       python2-ioflo              1.6.5-1              1.6.6-1
                        python2-pyro               4.51-1               4.52-1
                  python2-xlsxwriter              0.9.3-1              0.9.4-1
                               stack             1.2.0-24             1.2.0-26
                     stylish-haskell            0.6.5.0-1            0.6.5.0-2
                            vimpager               2.06-1               2.06-3
            xfce4-whiskermenu-plugin              1.6.1-1              1.6.2-1
                         deepin-help                    -             15.3.1-1
                       deepin-manual                    -              1.0.5-1
                          python-dae                    -              1.0.1-2


:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                              espeak1.49.0.r58.g8320581-11.49.0.r68.gb7a42e1-1
                               eudev                3.2-4              3.2.1-1
                            libeudev                3.2-4              3.2.1-1
                                 pix              1.2.0-1              1.2.1-1
              tintin-alteraeon2016.04.20+272.04e96c4-12016.04.20+273.f61a6fb-1
                                 xed              1.2.1-1              1.2.2-1
                             xplayer              1.2.1-1              1.2.2-1
                             xreader              1.2.1-2              1.2.2-1
                             xviewer              1.2.1-1              1.2.2-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
 aarch64-linux-gnu-linux-api-headers                4.8-1                4.9-1
                             awstats                7.5-2                7.6-1
                               cargo             0.14.0-2             0.14.0-3
                               cgrep             6.6.16-7             6.6.16-8
                              cython             0.25.1-2             0.25.2-1
                             cython2             0.25.1-2             0.25.2-1
                               darcs             2.12.4-3             2.12.4-4
                 deepin-file-manager            1:1.3.3-1            1:1.3.3-2
                 deepin-image-viewer              1.1.3-1              1.1.3-2
                        deepin-movie           1:2.2.10-2           1:2.2.10-4
                        deepin-music     2.3.0.20150814-2              2.3.2-1
                     deepin-terminal              2.1.5-1              2.1.5-2
                      ecryptfs-utils                108-2                111-1
                              eslint             3.12.0-1             3.12.1-1
                           filezilla           3.22.2.2-1           3.23.0.2-1
                             ghc-mod            5.6.0.0-6            5.6.0.0-7
                           git-annex         6.20161210-1         6.20161210-4
                             goagent     3.2.3.20150617-1                    -
                haskell-authenticate           1.3.3.2-21           1.3.3.2-24
                         haskell-aws             0.14.1-4             0.14.1-7
              haskell-binary-conduit            1.2.4.1-3            1.2.4.1-4
                  haskell-cheapskate           0.1.0.5-26           0.1.0.5-27
                     haskell-conduit              1.2.8-2              1.2.8-3
         haskell-conduit-combinators            1.0.8.3-2            1.0.8.3-3
               haskell-conduit-extra             1.1.15-1             1.1.15-2
                  haskell-connection              0.2.6-4              0.2.6-5
          haskell-cryptohash-conduit             0.1.1-43             0.1.1-44
                         haskell-dav             1.3.1-22             1.3.1-25
                         haskell-dns             2.0.10-1             2.0.10-2
                      haskell-either            4.4.1.1-8            4.4.1.1-9
                   haskell-esqueleto             2.4.3-45             2.4.3-46
                     haskell-ghc-mod            5.6.0.0-6            5.6.0.0-7
                      haskell-hakyll            4.9.1.0-6            4.9.1.0-9
                       haskell-hasql          0.19.15.2-2          0.19.15.2-3
                  haskell-hasql-pool              0.4.1-2              0.4.1-3
                    haskell-hopenpgp              2.5.5-8              2.5.5-9
                       haskell-hpack             0.15.0-6             0.15.0-7
             haskell-http-client-tls              0.3.3-6              0.3.3-7
                haskell-http-conduit              2.2.3-6              2.2.3-8
                      haskell-mmorph              1.0.6-2              1.0.9-1
               haskell-monad-journal              0.7.2-8              0.7.2-9
                haskell-monad-logger             0.3.20-2             0.3.20-3
             haskell-optparse-simple             0.0.3-29             0.0.3-30
                      haskell-pandoc               1.18-6               1.18-8
             haskell-pandoc-citeproc           0.10.2.2-8          0.10.2.2-11
             haskell-pandoc-crossref            0.2.4.1-4            0.2.4.1-6
                  haskell-persistent               2.6-12               2.6-13
           haskell-persistent-sqlite               2.6-12               2.6-13
         haskell-persistent-template           2.5.1.6-13           2.5.1.6-14
                       haskell-pipes              4.2.0-1              4.2.0-2
                  haskell-pipes-http             1.0.4-11             1.0.4-13
            haskell-project-template             0.2.0-36             0.2.0-37
                   haskell-resourcet              1.1.8-1              1.1.8-2
                       haskell-sandi              0.4.0-5              0.4.0-6
                       haskell-stack             1.2.0-24             1.2.0-26
                       haskell-store            0.2.1.2-8            0.2.1.2-9
           haskell-tagstream-conduit           0.5.5.3-43           0.5.5.3-45
                         haskell-tls             1.3.8-13             1.3.8-14
              haskell-wai-app-static            3.1.6.1-8            3.1.6.1-9
                   haskell-wai-extra             3.0.19-1             3.0.19-2
                    haskell-warp-tls             3.2.2-18             3.2.2-19
                        haskell-x509              1.6.4-1              1.6.5-1
                  haskell-x509-store              1.6.2-1              1.6.2-2
                 haskell-x509-system              1.6.4-1              1.6.4-2
             haskell-x509-validation              1.6.5-1              1.6.5-2
                 haskell-xml-conduit            1.4.0.1-4            1.4.0.2-1
                  haskell-xml-hamlet           0.4.0.12-5           0.4.0.12-7
                        haskell-yaml             0.8.20-1             0.8.20-2
                       haskell-yesod            1.4.3.1-9           1.4.3.1-12
                  haskell-yesod-auth          1.4.13.5-19          1.4.13.5-22
                  haskell-yesod-core             1.4.26-6             1.4.26-7
               haskell-yesod-default             1.2.0-77             1.2.0-78
                  haskell-yesod-form              1.4.9-8              1.4.9-9
            haskell-yesod-persistent           1.4.0.6-18           1.4.0.6-19
                haskell-yesod-static            1.5.1.1-6            1.5.1.1-7
                             hexchat             2.12.3-1             2.12.4-1
                              hoogle              5.0.6-2              5.0.6-3
                      hopenpgp-tools            0.19.4-10            0.19.4-12
                               idris               0.99-2               0.99-3
                             jenkins               2.35-1               2.36-1
                        libfilezilla              0.8.0-1              0.9.0-1
                            lollypop            0.9.220-1            0.9.223-1
            mate-notification-daemon             1.16.0-1             1.16.1-1
                          maxima-ecl             5.38.1-2             5.39.0-1
                               mlite             0.2.21-2             0.2.22-1
                     mysql-workbench              6.3.8-3              6.3.8-4
                           oniguruma              6.1.2-1              6.1.3-1
                            openshot              2.1.0-3              2.1.0-4
               owncloud-app-contacts          2:1.4.0.0-1            2:1.5.1-1
                               oxide             1.10.3-2                    -
                              pandoc               1.18-6               1.18-8
                     pandoc-citeproc           0.10.2.2-8          0.10.2.2-11
                     pandoc-crossref            0.2.4.1-4            0.2.4.1-6
                  perl-authen-radius               0.24-2               0.26-1
                               plank             0.11.2-1             0.11.3-1
                               ponyc              0.9.0-1             0.10.0-1
                             postgis              2.3.0-2              2.3.1-1
                       python-celery              4.0.0-1              4.0.1-1
         python-cryptography-vectors                1.6-1                1.7-1
                    python-fonttools              3.2.2-1              3.3.0-1
                        python-ioflo              1.6.5-1              1.6.6-1
                         python-pyro               4.51-1               4.52-1
                          python-pyx               0.14-2             0.14.1-1
                   python-xlsxwriter              0.9.3-1              0.9.4-1
                      python2-celery              4.0.0-1              4.0.1-1
        python2-cryptography-vectors                1.6-1                1.7-1
                   python2-fonttools              3.2.2-1              3.3.0-1
                        python2-fuse              0.2.1-5              0.2.1-6
                       python2-ioflo              1.6.5-1              1.6.6-1
                        python2-pyro               4.51-1               4.52-1
                  python2-xlsxwriter              0.9.3-1              0.9.4-1
                               stack             1.2.0-24             1.2.0-26
                     stylish-haskell            0.6.5.0-1            0.6.5.0-2
                            vimpager               2.06-1               2.06-3
            xfce4-whiskermenu-plugin              1.6.1-1              1.6.2-1
                         deepin-help                    -             15.3.1-1
                       deepin-manual                    -              1.0.5-1
                          python-dae                    -              1.0.1-2


:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                             linux49             4.9rc8-2              4.9.0-0
                     linux49-headers             4.9rc8-2              4.9.0-0


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                                 icu               58.1-2               58.2-1
                               links               2.13-1               2.14-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                             linux49             4.9rc8-1              4.9.0-0
                     linux49-headers             4.9rc8-1              4.9.0-0


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                                 icu               58.1-2               58.2-1
                               links               2.13-1               2.14-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                   linux49-acpi_call           1.1.0-0.11           1.1.0-0.12
                    linux49-bbswitch             0.8-0.11             0.8-0.12
                 linux49-broadcom-wl    6.30.223.248-0.11    6.30.223.248-0.12
                    linux49-catalyst   1:15.201.1151-0.11   1:15.201.1151-0.12
                 linux49-ndiswrapper            1.59-0.11            1.59-0.12
                      linux49-nvidia        1:370.28-0.11        1:370.28-0.12
                linux49-nvidia-304xx       1:304.131-0.11       1:304.131-0.12
                linux49-nvidia-340xx          340.98-0.11          340.98-0.12
                    linux49-nvidiabl            0.88-0.11            0.88-0.12
                       linux49-r8168        8.040.00-0.11        8.040.00-0.12
                   linux49-rt3562sta      2.4.1.1_r3-0.11      2.4.1.1_r3-0.12
                         linux49-spl         0.6.5.8-0.11         0.6.5.8-0.12
                    linux49-tp_smapi            0.41-0.11            0.41-0.12
                 linux49-vhba-module        20140629-0.11        20140629-0.12
    linux49-virtualbox-guest-modules          5.1.10-0.11          5.1.10-0.12
     linux49-virtualbox-host-modules          5.1.10-0.11          5.1.10-0.12
                         linux49-zfs         0.6.5.8-0.11         0.6.5.8-0.12
                   manjaro-tools-iso             0.13.8-4             0.13.8-5
                 sonar-mate-settings           20161206-1           20161212-1
                         flashplugin                    -         24.0.0.186-1


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                           ffmpeg2.8              2.8.8-1              2.8.9-1
                                fuse              2.9.7-1                    -
                           openjpeg2              2.1.2-1              2.1.2-2
                             udisks2              2.1.7-1              2.1.8-1
                        user-manager              5.8.4-1              5.8.4-2
                         fuse-common                    -              3.0.0-1
                               fuse2                    -              2.9.7-3
                               fuse3                    -              3.0.0-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                   linux49-acpi_call           1.1.0-0.10           1.1.0-0.12
                    linux49-bbswitch             0.8-0.10             0.8-0.12
                 linux49-broadcom-wl    6.30.223.248-0.10    6.30.223.248-0.12
                    linux49-catalyst   1:15.201.1151-0.10   1:15.201.1151-0.12
                 linux49-ndiswrapper            1.59-0.10            1.59-0.12
                      linux49-nvidia        1:370.28-0.11        1:370.28-0.12
                linux49-nvidia-304xx       1:304.131-0.10       1:304.131-0.12
                linux49-nvidia-340xx          340.98-0.10          340.98-0.12
                    linux49-nvidiabl            0.88-0.10            0.88-0.12
                       linux49-r8168        8.040.00-0.10        8.040.00-0.12
                   linux49-rt3562sta      2.4.1.1_r3-0.10      2.4.1.1_r3-0.12
                         linux49-spl         0.6.5.8-0.10         0.6.5.8-0.12
                    linux49-tp_smapi            0.41-0.10            0.41-0.12
                 linux49-vhba-module        20140629-0.10        20140629-0.12
    linux49-virtualbox-guest-modules          5.1.10-0.10          5.1.10-0.12
     linux49-virtualbox-host-modules          5.1.10-0.10          5.1.10-0.12
                         linux49-zfs         0.6.5.8-0.10         0.6.5.8-0.12
                   manjaro-tools-iso             0.13.8-4             0.13.8-5
                 sonar-mate-settings           20161206-1           20161212-1
                         flashplugin                    -         24.0.0.186-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                           ffmpeg2.8              2.8.8-1              2.8.9-1
                                fuse              2.9.7-1                    -
                           openjpeg2              2.1.2-1              2.1.2-2
                             udisks2              2.1.7-1              2.1.8-1
                        user-manager              5.8.4-1              5.8.4-2
                         fuse-common                    -              3.0.0-1
                               fuse2                    -              2.9.7-3
                               fuse3                    -              3.0.0-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2016-12-12           2016-12-15
-------------------------------------------------------------------------------
                       steam-manjaro           1.0.0.54-1           1.0.0.54-2
                   lib32-flashplugin                    -         24.0.0.186-1

8 Likes

Will 4.9 become the new default kernel (it is a LTS kernel I believe)?

3 Likes

Switch to 4.9 went smooth btw, same as the switch from fuse to fuse2 and the other updates. No problems so far. Thanks for this awesome distro!

1 Like

Update went smoothly but when I try out the 4.9 kernel I get an exception error (seems to boot okay anyway?). From journal:

Dec 16 10:46:40 private kernel: ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
Dec 16 10:46:40 private kernel: ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-227)
Dec 16 10:46:40 private kernel: ACPI Exception: AE_NOT_FOUND, (SSDT:xh_rvp10) while loading table (20160831/tbxfload-228)
Dec 16 10:46:40 private kernel: ACPI Error: 1 table load failures, 7 successful (20160831/tbxfload-246)

If relevant my inxi . Beyond knowing it is a kernel message I am lost. :grin:

No issues, but I'm not using the 4.9 kernel yet. Maybe on the next point release.

1 Like

No issues either. Running Kernel 4.9 and happy the Steam Controller works again!

Update went fine without any issue. Not switching to 4.9 though. Maybe after a couple of point releases.:relaxed:

2 Likes

The update went fine.

Is this fixed https://scarybeastsecurity.blogspot.in/2016/12/redux-compromising-linux-using-snes.html

No issues. Using the 4.9 Kernel on Dell XPS13 9350 Skylake. KDE edition. All smooth. Thanks !

Okay my search-fu is better this afternoon. This issue is already noted upstream* and is apparently a non-issue except for the message which probably should be only a debug message. See here. I am happy and will reboot next time with 4.9 kernel.

By someone quite well known. :grinning:

I've done the update, installed packages qt5-styleplugins and qt5ct (and configured them as in the instruction). After the reboot all of my icons from the menu disappeared. I use default themes. I use plasma 5.8.4, Qt 5.7 and now 4.9 kernel (but on 4.4 it is the same).

When you're on plasma, you dont have to do this ... go back to the standard

like as the instruction said. all this is not needed on plasma. it's only on other DE (GTK)

Ok - sorry for this misunderstanding. Probably lack of morning coffee... Everything is fine now.

Very small update for me. Only these packages:

ecryptfs-utils-111-1
ffmpeg2.8-2.8.9-1
flashplugin-24.0.0.186-1
icu-58.2-1
openjpeg2-2.1.2-2
udisks2-2.1.8-1
user-manager-5.8.4-2

Is this normal?
I'm on Plasma.

Update works fine, but with kernel 0.9 I have a problem with shutdown. It stopps with the messages into the picture.
Could somebody explain me, how I can fix it, please

I

System: Host: Laptop Kernel: 4.8.14-1-MANJARO x86_64 (64 bit gcc: 6.2.1) Desktop: KDE Plasma 5.8.4 (Qt 5.7.0)
Distro: Manjaro Linux
Machine: Device: laptop System: LENOVO product: 766511G v: ThinkPad T61
Mobo: LENOVO model: 766511G BIOS: LENOVO v: 7LETC1WW (2.21 ) date: 07/01/2008
Battery BAT0: charge: 18.2 Wh 51.3% condition: 35.5/56.2 Wh (63%)
model: Panasonic 42T5264 status: Discharging
CPU: Dual core Intel Core2 Duo T7100 (-MCP-) cache: 2048 KB
flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 7184
clock speeds: max: 1801 MHz 1: 1200 MHz 2: 1200 MHz
Graphics: Card: NVIDIA G86M [Quadro NVS 140M] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 driver: nouveau Resolution: 1440x900@60.06hz
GLX Renderer: Gallium 0.4 on NV86 GLX Version: 3.0 Mesa 13.0.2 Direct Rendering: Yes
Audio: Card Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.8.14-1-MANJARO
Network: Card-1: Intel 82566MM Gigabit Network Connection driver: e1000e v: 3.2.6-k port: 1840 bus-ID: 00:19.0
IF: enp0s25 state: down mac: 00:21:86:5c:7d:c5
Card-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
driver: iwl4965 v: in-tree: bus-ID: 03:00.0
IF: wls3 state: up mac: 00:21:5c:4e:c3:0b
Drives: HDD Total Size: 240.1GB (13.3% used)
ID-1: /dev/sda model: SanDisk_SDSSDHII size: 240.1GB
Partition: ID-1: / size: 212G used: 22G (11%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 8.98GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 49.0C mobo: 41.0C
Fan Speeds (in rpm): cpu: 0
Info: Processes: 169 Uptime: 9 min Memory: 1166.3/3891.1MB Init: systemd Gcc sys: 6.2.1
Client: Shell (bash 4.4.51) inxi: 2.3

thank you very much
regards
caho

1 Like

Thanks for the update, all work fine apparently... Although at the boot I get this error and I can't find clear information about it:

[    0.495261] .... node  #0, CPUs:      #1
[    0.605246]  #2<3>[    0.605920] [Firmware Bug]: CPU2: APIC id mismatch. Firmware: 12 CPUID: 2
[    0.715230]  #3<3>[    0.715899] [Firmware Bug]: CPU3: APIC id mismatch. Firmware: 13 CPUID: 3
[    0.825212]  #4<3>[    0.825885] [Firmware Bug]: CPU4: APIC id mismatch. Firmware: 14 CPUID: 4
[    0.935197]  #5<3>[    0.935867] [Firmware Bug]: CPU5: APIC id mismatch. Firmware: 15 CPUID: 5
[    1.045181]  #6<3>[    1.045853] [Firmware Bug]: CPU6: APIC id mismatch. Firmware: 16 CPUID: 6
[    1.155165]  #7<3>[    1.155834] [Firmware Bug]: CPU7: APIC id mismatch. Firmware: 17 CPUID: 7
[    1.240532] x86: Booted up 1 node, 8 CPUs

Only happend with kernel 4.9, my processor is a AMD FX8350

1 Like

All good. No problems with Kernel 4.9
Great thanks to the Team!

Quad core Intel Core i5-4570
Kernel: 4.9.0-0-MANJARO x86_64
Cedar [Radeon HD 7350/8350 / R5 220]
Display Server: X.Org 1.18.4 driver: radeon
Desktop: Xfce 4.12.3 (Gtk 2.24.31)

Wow!! You guys sure stay busy!! Thank you!!

The new flashplugin-24 does not seem to work with hal-flash 0.3.3-1 - problem: logging in to web sites offering protected content affiliated with my cable provider is no longer successful.

Had to downgrade flashplugin back to 11.2 in order to access content until this is fixed.

Forum kindly sponsored by