[Stable Update] 2017-04-15 - Kernels, Thunderbird, Firefox, Libreoffice

Thank you @kb41 that solved my issue... :grin:

thank you @kb41 that solved my issue :grin: :penguin:

2 Likes

Update on 12 Systems without Problems.

DK3

1 Like

Hi @kb41

I use open-rc and your answer solve my problem: after the update i can't shutdown the system, now it's work correctly.

I need to run this commands for update work.

  • Before update:

sudo pacman -Rdd light-locker-consolekit
sudo pacman -S networkmanager

  • Update

sudo pacman -Syu

Answer "yes" to all questions about add/remove packages

  • After update:

sudo rc-update add elogind default
pacdiff

5 Likes

same here, maybe I'm a bit tired but I only saw Lightfirefox and no standard firefox update...

Taking the default options is a non starter:

sudo pacman -Syyuu
:: Synchronising package databases...
core                               138.1 KiB   609K/s 00:00 [################################] 100%
extra                             1783.6 KiB  2036K/s 00:01 [################################] 100%
community                            4.1 MiB  1924K/s 00:02 [################################] 100%
multilib                           181.6 KiB  2.04M/s 00:00 [################################] 100%
:: Starting full system upgrade...
:: Replace pm-utils with community/elogind? [Y/n] 
resolving dependencies...
looking for conflicting packages...
:: elogind and systemd-sysvcompat are in conflict. Remove systemd-sysvcompat? [y/N] y
:: dbus-elogind and dbus are in conflict (libdbus). Remove dbus? [y/N] y
:: polkit-elogind and polkit are in conflict. Remove polkit? [y/N] y
:: libeudev and libsystemd are in conflict (libudev.so). Remove libsystemd? [y/N] y
:: eudev and systemd are in conflict (udev). Remove systemd? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: device-mapper: requires systemd
:: lvm2: requires systemd
:: accountsservice: removing systemd breaks dependency 'systemd'
:: bluez-utils: removing systemd breaks dependency 'systemd'
:: ceph: removing libsystemd breaks dependency 'libsystemd'
:: colord: removing systemd breaks dependency 'systemd'
:: crda: removing systemd breaks dependency 'systemd'
:: cups: removing systemd breaks dependency 'systemd'
:: dhcpcd: removing libsystemd breaks dependency 'libsystemd'
:: entangle: removing libsystemd breaks dependency 'libsystemd'
:: lib32-systemd: removing systemd breaks dependency 'systemd'
:: libatasmart: removing libsystemd breaks dependency 'libsystemd'
:: libgudev: removing libsystemd breaks dependency 'libsystemd'
:: libinput: removing systemd breaks dependency 'systemd'
:: libmbim: removing systemd breaks dependency 'systemd'
:: libpulse: removing systemd breaks dependency 'systemd'
:: libusb: removing systemd breaks dependency 'systemd'
:: libwacom: removing systemd breaks dependency 'systemd'
:: mariadb: removing libsystemd breaks dependency 'libsystemd'
:: media-player-info: removing systemd breaks dependency 'systemd'
:: mkinitcpio: removing systemd breaks dependency 'systemd'
:: modemmanager: removing systemd breaks dependency 'systemd'
:: netctl: removing systemd breaks dependency 'systemd'
:: pcmciautils: removing systemd breaks dependency 'systemd'
:: plymouth: removing systemd breaks dependency 'systemd'
:: procps-ng: removing libsystemd breaks dependency 'libsystemd'
:: qtwebkit: removing systemd breaks dependency 'systemd'
:: rpcbind: removing libsystemd breaks dependency 'libsystemd'
:: rtkit: removing systemd breaks dependency 'systemd'
:: subversion: removing systemd breaks dependency 'systemd'
:: syslog-ng: removing systemd breaks dependency 'systemd'
:: udisks: removing systemd breaks dependency 'systemd'
:: udisks2: removing systemd breaks dependency 'systemd'
:: upower: removing systemd breaks dependency 'systemd'
:: util-linux: removing libsystemd breaks dependency 'libsystemd'
:: xdg-user-dirs: removing systemd breaks dependency 'systemd'
:: xf86-input-evdev: removing libsystemd breaks dependency 'libsystemd'
:: xf86-input-wacom: removing libsystemd breaks dependency 'libsystemd'
:: xf86-video-ati: removing libsystemd breaks dependency 'libsystemd'

It does update if I refuse the replacement of pm-utils, but not otherwise. I first tried the update yesterday, then left it till just now in case the mirror had not updated properly.

2 Likes

Happy Birthday @philm
Everything OK with the update!

System: Host: ULIAK-2017 Kernel: 4.10.10-1-MANJARO x86_64 (64 bit) Desktop: KDE Plasma 5.9.4
Distro: Manjaro Linux
Machine: Device: laptop System: ASUSTeK product: X551CA v: 1.0
Mobo: ASUSTeK model: X551CA v: 1.0 UEFI: American Megatrends v: X551CA.211 date: 06/04/2014
Battery BAT0: charge: 14.9 Wh 95.1% condition: 15.7/37.4 Wh (42%)
CPU: Dual core Intel Core i3-3217U (-HT-MCP-) cache: 3072 KB
clock speeds: max: 1800 MHz 1: 799 MHz 2: 799 MHz 3: 800 MHz 4: 799 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
Display Server: X.Org 1.19.3 driver: intel Resolution: 1366x768@59.99hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 17.0.3
Audio: Card Intel 7 Series/C216 Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.10.10-1-MANJARO
Network: Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
IF: wlp2s0 state: up mac: 40:f0:2f:9f:1a:04
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
IF: enp3s0f2 state: down mac: e0:3f:49:30:11:ea
Drives: HDD Total Size: 500.1GB (22.4% used)
ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
ID-2: /dev/mmcblk0 model: N/A size: 31.1GB
Partition: ID-1: / size: 15G used: 9.9G (72%) fs: ext4 dev: /dev/sda3
ID-2: /home size: 428G used: 88G (22%) fs: ext4 dev: /dev/sda4
ID-3: /var size: 9.8G used: 1.3G (14%) fs: ext4 dev: /dev/sda5
ID-4: swap-1 size: 6.44GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 62.0C mobo: N/A
Fan Speeds (in rpm): cpu: 2400
Info: Processes: 192 Uptime: 12 min Memory: 1520.6/3842.2MB Client: Shell (bash) inxi: 2.3.8

I update my physical machine with VMware installed and now the VMware don't start, the process to update modules don't work. I try in terminal with sudo and root but nothing.

I looking for in the everything.log and appear a message of segfault for any time that i exec vmware-modconfg:

Apr 16 16:13:21 manjaro kernel: vmware-modconfi[2973]: segfault at 3680 ip 0000000000003680 sp 00007ffe2e917c08 error 14 in appLoader[55abde0fe000+ad000]

I use lats kernel 4.10, also test kernels 4.9 and 4.4 with the same result.

Are you using Open-rc?

Don't think so:

james@xena:~/Documents$ pacman -Qs openrc
local/manjaro-system 20170406-5 (base)
    Manjaro Linux System - Update script
james@xena:~/Documents$

Good evening guys,

I noticed some weird bug since last update. Nitrogen does not list any new images added to any of my wallpaper folders at all. I tried various fixes, created a new folder and tried adding there the images, running it as root, even moving the images directly to /usr/share/backgrounds but no change at all.

Does anybody else have the same problem? (everything was running 100% smoothly before the update)

I'm using Manjaro i3-community edition.

EDIT: Nevermind, I removed the package and re-installed it and everything runs smoothly now.

kernel 4.10.10 seems to have problem with bluetooth after wakeup from sleep. It doesn't even try to redetect bluetooth adapters after rfkill block bluetooth followed by rfkill unblock bluetooth. I don't even see the familiar USB device disconnected message after rfkill block bluetooth (mine is connected via USB internally).

If you use XFCE ,KDE or something similar, remove pm-utils first. After that, you can upgrade your system.

1 Like

Thanks,
I guess that is one drawback of rolling releases -- a slow accumulation of debris. I don't think this box has been fully re-installed since it was converted to Manjaro only a few weeks after the first public release.

update went well with the exception of one thing;
when i rebooted my laptop, i noticed the login screen showed up on the wrong monitor. i use my 32 inch tv screen as my default screen via hdmi. after researching i found this:


the last entry in this thread fixed it. i used nvidia x server settings generated config file to copy a new nvidia.config file in /etc/X11/mhwd.d. i don't know if this was the proper way of doing it nor do i know why it happened, but the login screen now appears on the 32 inch which is what i want. i rebooted 2 more times to make sure it wasn't a coincidence and login screen shows up on my chosen default monitor.
i worry however what will happen if i unplug the hdmi and use the laptop screen only...so im not sure if this was the right fix. but it works for now

2 Likes

Hi everybody,

I noted some visual artefacts in Thunderbird.

There are some thick grey lines around the recipient lines and the resize handle looks a bit strange due to wrong colors. I remember we had this effect some weeks ago but it was fixed with a later update again.

Do I need to do anything? Used theme is Greybird (AUR).

Thanks!

A late "Happy Birthday" to you @philm from me too!

I get similar "Could not satisfy dependencies" errors about systemd on an old Samsung NF-310 netbook running Manjaro.XFCE, even after removing all orphaned packages.
Indeed pm-utils 1.4.1-7 is still installed, but as a dependency of samsung-tools 2.3.1-1. This samsung-tools package makes all the proprietary hardware (extra keys, fan control, ...) functional.

Any chance to run the update and keep samsung-tools?

kde plasma / xps9550 / smooth update

The IgnorePkg option in pacman.conf could you consider to use. With that option ignore elogind, since elogind replaces pm-utils. But this is more a dirty hack than a solution.

I would uninstall the Samsung stuff do the update try to reinstall Samsung if it doesn't work raise a bug with the maintainer.

Forum kindly sponsored by