[Stable Update] 2017-04-25 - Firefox, KDE Apps, Haskell, Virtualbox

Hi community,

we mostly updated Firefox, KDE Apps, Haskell, Python and VirtualBox.

Please give us feedback as usual and report any issues you may see with this update.

kind regards,
Philip Müller and the Development Team

Current supported Kernels

  • linux310 3.10.105
  • linux312 3.12.73
  • linux316 3.16.42
  • linux318 3.18.50
  • linux41 4.1.39
  • linux44 4.4.63
  • linux48 4.8.17 [EOL]
  • linux49 4.9.24
  • linux410 4.10.12
  • linux-RT-LTS 4.4.60_rt73
  • linux-RT 4.9.20_rt16

Package Changes (Mon Apr 24 07:49:35 CEST 2017)

  • stable community i686: 351 new and 340 removed package(s)
  • stable community x86_64: 352 new and 341 removed package(s)
  • stable core i686: 5 new and 5 removed package(s)
  • stable core x86_64: 5 new and 5 removed package(s)
  • stable extra i686: 490 new and 489 removed package(s)
  • stable extra x86_64: 490 new and 489 removed package(s)
  • stable multilib x86_64: 9 new and 8 removed package(s)

A detailed package list can be found here.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:



KDE, smooth update, thanks.


Small issue.

libtorrent-rasterbar update caused issues with qBittorrent, downgrade fixes.

Either libtorrent-rasterbar is buggy or qBittorrent needs to be re-built.

Cinnamon. Smooth update as usual. Merci Manjaro Team :slight_smile:

All good and fixed the broken video from last update - linux49 breaks nvidia

thanks again

All good on Manjaro Cinnamon here! Thanks guys.

No issues at all on 2 machines, KDE edition. Could be a "placebo effect" but I even feel my Plasma is smoother than before !! :slight_smile: All good.

1 Like

No issues on all machines. Thanks to the manjaro-team.


Can no longer order torrents in qBittorrent after this update, anyone else getting this?

Looks like KDE improved Akonadi. It performed an OAuth2 generation for my Gmail account that I had previously added to KMail via the less secure 'App-Password'.

But now, Akonadi only requested email permissions; it did not request access to calendar or contacts. Isn't that strange? Isn't Akonadi the 'server' for Kontact, (of which Kmail is just a part) which deals with all those functions?

XFCE stable. Done, without any error or warning.

libtorrent-rasterbar            1:1.1.1-6            1:1.1.3-2

This has caused issues with qBittorrent, which I think needs to be re-build with the new dependency.

EDIT : downgrading libtorrent-rasterbar fixes these issues.

I use Manjaro OpenRC Xfce 16.06 x86_64

Edit: downgrade udisks2 (2.1.8-1 -> 2.6.4-1) solved the issue.

After update an reboot, i found this issues:

  • tere are two system folders in desktop and Thunar
  • USB memory doesn't automount, lsblk output:

sda 8:0 0 111,8G 0 disk
└─sda1 8:1 0 111,8G 0 part /
sdb 8:16 1 14,4G 0 disk
└─sdb1 8:17 1 14,4G 0 part
sr0 11:0 1 1024M 0 rom

Packages updated:

[2017-04-25 15:49] [ALPM] upgraded icu (58.2-1 -> 58.2-2)
[2017-04-25 15:49] [ALPM] upgraded libxml2 (2.9.4+12+ge905f081-5 -> 2.9.4+16+g07418011-1)
[2017-04-25 15:49] [ALPM] upgraded llvm-libs (3.9.1-2 -> 4.0.0-1)
[2017-04-25 15:49] [ALPM] upgraded mesa (17.0.4-1 -> 17.0.4-2)
[2017-04-25 15:49] [ALPM] upgraded libtiff (4.0.7-2 -> 4.0.7-3)
[2017-04-25 15:49] [ALPM] upgraded firefox (52.0.2-1.1 -> 53.0-1)
[2017-04-25 15:49] [ALPM] upgraded firefox-i18n-en-us (52.0.2-1 -> 53.0-1)
[2017-04-25 15:49] [ALPM] upgraded firefox-i18n-es-es (52.0.2-1 -> 53.0-1)
[2017-04-25 15:49] [ALPM] upgraded gpgme (1.9.0-1 -> 1.9.0-2)
[2017-04-25 15:49] [ALPM] upgraded pcre2 (10.22-2 -> 10.23-1)
[2017-04-25 15:49] [ALPM] upgraded perl-extutils-pkgconfig (1.15-1 -> 1.16-1)
[2017-04-25 15:49] [ALPM] upgraded perl-image-exiftool (10.40-1 -> 10.50-1)
[2017-04-25 15:49] [ALPM] upgraded tslib (1.8-1 -> 1.9-1)
[2017-04-25 15:49] [ALPM] upgraded udisks2 (2.1.8-1 -> 2.6.4-1)
[2017-04-25 15:49] [ALPM] upgraded xfce4-whiskermenu-plugin (1.7.2-1 -> 1.7.2-2)

inxi -Fx
System:    Host: Astro Kernel: 4.10.12-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Manjaro Linux
Machine:   Device: desktop Mobo: ASRock model: N68C-GS FX
           BIOS: American Megatrends v: P1.40 date: 10/31/2012
CPU:       Dual core AMD Athlon 64 X2 6000+ (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 4020
           clock speeds: max: 3000 MHz 1: 1000 MHz 2: 1000 MHz
Graphics:  Card: NVIDIA C61 [GeForce 7025 / nForce 630a] bus-ID: 00:0d.0
           Display Server: X.Org 1.19.3 driver: nvidia
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce 7025 / nForce 630a/integrated/SSE2
           GLX Version: 2.1.2 NVIDIA 304.134 Direct Rendering: Yes
Audio:     Card NVIDIA MCP61 High Definition Audio
           driver: snd_hda_intel bus-ID: 00:05.0
           Sound: Advanced Linux Sound Architecture v: k4.10.12-1-MANJARO
Network:   Card: NVIDIA MCP61 Ethernet
           driver: forcedeth port: e080 bus-ID: 00:07.0
           IF: enp0s7 state: up speed: 1000 Mbps duplex: full
           mac: bc:5f:f4:9a:95:4a
Drives:    HDD Total Size: 151.5GB (25.5% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 120.0GB
           ID-2: /dev/sdb model: Name n/a size: 31.5GB
Partition: ID-1: / size: 110G used: 36G (35%) fs: ext4 dev: /dev/sda1
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 130 Uptime: 12 min Memory: 1029.5/3703.6MB
           Init: SysVinit rc: OpenRC runlevel: default Gcc sys: 6.3.1
           Client: Shell (bash 4.4.121) inxi: 2.3.8

€: apparently wrong thread.

Update went good!

Two successful updates on KDE Editions (T61 and HP). And it is nice not to see the dialog box that there is a newer version of Virtual Box available to download.

Both times, I had to upgrade (sudo pacman -Syyu) in the konsole.
Is there an option for the Octopi Notifer to sync with every reboot?

Plus, a successful upgrade from Octopi in LXQt.

Silken. :slight_smile:

ALL installed browsers' UI were (partially) broken as a result of the 04-23 updates. I did not post it in that 04-23 thread hoping that the updates for the rest of the KDE apps would resolve the issues.
GTK themes are (partially) broken on KDE or, perhaps, the application of those themes to applications that use GTK for UI.
Javascript/Webkit/whatever does not work properly. Some widgets disappeared completely being replaced with text, others just do not work.
Browsers include Chromium, Chrome(AUR), Cliqz(AUR), Firefox from Mozilla ...

I installed Opera and the opera-ffmpeg-codecs(which are now in AUR) and it does not exhibit the issues(not so far).
( In the example, the "Search in Amazon Video" is S2B a drop-down button to choose what department for the search. )



Google-Chrome is the same.

I just installed Otter(yesterday), since it is a QT5 based UI. It too is broken:

So the issue is not just the problem with applying GTK3 to the browsers UI.

Only newly installed(yesterday) Opera is correct:

There are other javascript, Webkit and/or GTK issues on this KDE install. The example is just one issue.

The system had no such issues before the 04-23 updates.
NB: Updates were done after a reboot to tty.

I have tried to fix it but cannot, yet, find what it is that causes it.

OS: Manjaro 17.0 Gellivara~Stable; Kernel: 4.10.12-1-MANJARO x86_64 (or 4.9.24-1-MANJARO x86_6);
CPU(s)~2 Quad core Intel Xeon X5687s (-HT-MCP-SMP-); Mem~2901.0/24104.9MB; NUMA~2 nodes; Network~2x Intel 82576 (igb); HDD~4961.0GB(17.9% used); GPU~GeForce GTX 1060 6GB; Resolution~3840x2160; GLX~4.5.0 NVIDIA; GP106 ~375.39; DE~KDE 5.32.0 / Plasma 5.9.4 (Qt 5.8.0); WM~KWin; *.

Had a thrill with this update. My power went out while Pamac was syncing, laptop on battery reported 12 packages to update. Of course the router was down. So I did nothing, just waited for the power to come back on. Everything rebooted. Pamac continued, finished and reported 15 packages to update.
From terminal sudo pacman -Syu. All's good and all's done. :joy:


This one also went extremely smooth. Happy.

Forum kindly sponsored by