[Stable Update] 2017-05-12 - Kernels, KDE, KDE Apps, Gnome, Browsers

Since the update, dolphin keeps crashing constantly and is unusable. When I start it in a terminal, this is the output I get:

kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find "stash"
Cannot creat accessible child interface for object: PlacesView(0x1fa2a00) index: 13
kf5.kio.core: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf\nError loading services.\n"
kf5.kio.core: KSambaShare: Could not find smb.conf!
kf5.kio.core: We got some errors while running 'net usershare info'
kf5.kio.core: "Can't load /etc/samba/smb.conf - run testparm to debug it\n"

The same thing happens when I use octopi as well, although I don't get the same output from the terminal. I am unable to even search for packages. As soon as I start typing a package name, octopi crashes.

I'm usually very confident of saying yes to all package removal due to conflict during upgrades, but not this time:

warning: removing 'dbus' from target list because it conflicts with 'dbus-elogind'
:: elogind and systemd-sysvcompat are in conflict. Remove systemd-sysvcompat? [y/N] y
:: dbus-elogind and dbus are in conflict (libdbus). Remove dbus? [y/N] y
:: polkit-elogind and polkit are in conflict. Remove polkit? [y/N] y
:: libeudev and libsystemd are in conflict (libudev.so). Remove libsystemd? [y/N]

once my eye catches libsystemd removal, I'm in doubt. Is it safe?

EDIT:
No, it is not safe. Browsing the forum I found this which solves the problem. Bye2 pm-utils...

1 Like

No, I cleaned it with -Sc not -Scc so nothing was downloaded. I just cleaned it because I had older packages there and those would create conflicts. I just had to download VBox host modules because these weren't installed when I cleaned the cache.

1 Like

i just update
and when restart
i got this error
amdgpu: [ powerplay ] VBIOS did not find boot engine clock value in dependency table. Using Memory DPM level 0!
what is it and how can solve it ..!

Are you sure you need to solve it?
Does your system boot properly, with no video issues?
There is quite a bit of stuff in Google about this that suggests the message still happens but the problem is solved.

You might try kernel 4.10 if you aren't already using that.

I am newbie on manjaro (6 months old) and happen to follow steps detailed below during update. Thought it might be worth sharing.

  1. Save and close all application.
  2. Logout to sddm
  3. Press Ctrl + alt + F2
  4. login on tty2
  5. Run nmtui (Ncurses based network manager gui to connect to Lan / Wifi.)
  6. Run sudo pacman-mirros -f 5
  7. Run sudo pacman -Syyuw (First only download all packages to manage breaking change during package installation)
  8. Run sudo pacman -Syu
  9. Done with update, Run systemctl reboot

I never use force or assume "yes" to conflicts. whenever in doubt prefer searching for solution on manjaro forum

3 Likes

After reading the thread I'm scared to update. Yeh I think I'll sit this one out lol

1 Like

well, at this stage, you knwo more than I did when 6 months old, but...I never left the GUI...I was of Fedora8...and everything was done graphically...
Sen in hindsight...dangerous if the GUI breaks :slight_smile:

For most users the update went fine. :wink:
It can only become problematic when you have exotic hardware, or interrupt the update process.
It's really best to do sudo pacman -Syyu in a console. - That's what I do and I never had a problem with an update so far.

2 Likes

281 packages upgraded without pain (XFCE4, Intel GPU driver, kernel 4.9) !
Thanks to the Manjaro team for this excellent job !

I was able to remove gstreamer with the following command:

pacman -Rsc $(pacman -Qqs gstreamer0.10)

Then proceed with:

pacman -Syyu

Also, I find "pacman-mirrors --geoip" generates a nice mirror list of servers in my country.

As for Manjaro not being user friendly, that is not my experience at all. The forum is fairly active, useful, and generally helpful. For in-depth information, there is no better source than the upstream "Arch" wiki.

1 Like

Hi,
same issue, same solution. Thank you Leandro.
After this update Thunar opens only with a long delay - again. I fix it with the proposition of Lumi: http://www.manjaro-forum.de/index.php/topic,590.msg3911.html#msg3911
Not for the first time. I have to fix it after every big update. :worried:
BUT ... Thank you for the great work, Manjaro team.

yes i want to solve it
when i using cinnamon it didn't appear
after switching ti KDE
it's appear when i boot
and i try 4.10 and 4.11
and nothing changed

We are currently testing new Cinnamon packages in our unstable branch.

Total Download Size:   1005.86 MiB
Total Installed Size:  4331.98 MiB
Net Upgrade Size:       213.08 MiB

With 349 packages, this one was a real whopper. Went blazingly fast and smooth!

Thank you Manjaro team! :heart:

2 Likes

Thanks much

Here is what I did after looking it up Arch_Removing_Packages

####Always a good idea to use clonezilla live USB to take a system image to an external drive before a major upgrade like this imho.

####Also a good time to look at /etc/pacman.d/mirrorlist Arch_wiki To enable mirrors, edit /etc/pacman.d/mirrorlist and locate your geographic region. Uncomment mirrors you would like to use.

$ sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: gstreamer0.10-good-plugins: installing libsoup (2.58.1-1) breaks dependency 'libsoup-gnome'
$ sudo pacman -Rs gstreamer0.10-good-plugins
checking dependencies...

Packages (2) gstreamer0.10-good-0.10.31-27 gstreamer0.10-good-plugins-0.10.31-27

Total Removed Size: 5.09 MiB

:: Do you want to remove these packages? [Y/n] y
:: Running pre-transaction hooks...
(1/1) Uninstalling GConf schemas...
:: Processing package changes...
(1/2) removing gstreamer0.10-good-plugins [##########################################] 100%
(2/2) removing gstreamer0.10-good [##########################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
$ sudo pacman -Syyuu

#and then go make some tea. :smile:

1 Like

Hello, just now tried update, everything seemed to be going fine [225 of 253 upgrades completed] then:

error: problem occurred while upgrading palemoon-bin
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.

any ideas? thanks

Oh I have exotic hardware alright as I found out during my latest escapades in another thread.

My installation has survived a good few updates without issue so far. It's just reading the forum a few things seem to be happening/breaking with this one.

But I'll give it a go once I've made a few bootable usb sticks with different oses, just incase. I'm probably making a big deal out of nothing as usual lol

1 Like

Yea, you'll be fine you know the ropes.

1 Like

Uninstall palemoon-bin first, do the update and reinstall it. Else you might have some harddrive space issue. Please check.

@all: the next update review cycle just started ...

Forum kindly sponsored by