[Stable Update] 2017-05-12 - Kernels, KDE, KDE Apps, Gnome, Browsers

The version numbers in Manjaro are mostly related to the install media, and much less to the state of your updates. As such the version number on your system is updated more irregularly.

In short, there is no such thing as an update from 17.0.1 to 17.0.2, but only an update to Manjaro.

1 Like

good job
but why this error happened
when i switched from cinnamon to KDE

amdgpu: [ powerplay ] VBIOS did not find boot engine clock value in dependency table. Using Memory DPM level 0!

Updated from [Stable Update] 2017-04-25 to this update with

sudo pacman -Syyu

without problems :slight_smile:

One system (desktop) is Manjaro 17.0 MATE, and other system (Laptop) is Manjaro XFCE 17.0.1.

1 Like

The update of my two computers has been flawlessly, both with Xfce desktop. Since it is a huge update I've used the TTY to do it.

Regards. :slight_smile:

I upgraded 2 KDE machines and haven't found such issues. But I'd try downgrading NM to see if the problem got solved.

1 Like

Great tips.
Also, after step 5.,
you should add this
sudo pacman-mirros -f 5
and then all other steps.

This command will add five fastest and up-to-date mirrors to mirror list. :slight_smile:
You can change number 5 to any other number.

It went smooth. No issues reported. Keep it up! :slight_smile:

Those are generally good practices, but I don't see the need to first download the packages if you'll install them right after. Also, if you already synced mirrors on step 6 you don't need to do it again on step 7. steps 6 and 7 could be sudo pacman -Syyu as it has the same effect.

snake2903's tip is also a good one.

After running pacman -Syyu I had problems with gstreamer, but I uninstalled it as recomended. Then, I couldn't log in because NetworkManager had some issues. However, it was zenity the package that was broken. I deleted the cached package and I reinstalled it. I could log in finally.

Now, almost everything works as intended, BUT some programs (e.g. Evolution and gnome-control-center) don't work. They show Bus error (core dumped) when I run them on the terminal.

Anyway to fix it?

Thanks!

Just found an issue with my LXQt.
Definitely it's xdg-open thing appeared after update.

So my Trojita email client stopped opening attached files (like *.pdf, *.jpg etc.) directly. It's output is:

/usr/bin/xdg-open: line 922: pcmanfm: command not found

Even so, looks like mime type is configured. And I can open those file types over pcmanfm. And

xdg-mime query filetype some.pdf

returns:

application/pdf

So, in other words I'm still able to open such files via pcmanfm directly according to its file expression (as before). But Trojita has just stopped doing so.

Did you fix your problem? If not, you should open new topic and someone may be able to help you. In a new topic post all the errors you get and any info that could be helpful to figure it out what may be the problem.

You should also try to choose and run different kernel at grub screen and see if this help.

Can you log into TTY? If so can you update system from there?
If not, did you try to chroot into your system from live media an try to update you system that way?

In case you don't know how to chroot, you can try to follow these steps:

Everything is fine here
Dell inpiron 1545
Intel Graphics
Core2Duo T6500
Kernel 4.10.15

Following update last month caused update issues since symlinks for mesa package were removed before applying update and if update fails for any unforeseen reason then user wud end up with broken system hence downloading all packages first and then applying update will ensure deleted symlinks are restored with complete update and lesser chance of broken system.

You did the smart thing - waiting a little bit and reading the forum first, congrats, too many beginners rush with the updates. :slight_smile:

But you do have to update. Waiting this one out means, next update will pile more updates on top of this one and longer you wait, better chances you get that there something may go wrong. It is the nature of rolling distro.

Make a backup. If you have spare HDD, use clonezilla and just save whole disk before the update: (that way you can revert and return your system back to before the update if anything goes wrong, and you are not able to fix it)

And since you read this forum, you know you need to run update from the console. (good general practice anyway)

1 Like

Included ur suggestion as step 6. Thanks this wud help user update mirrorlist and install packages even if first mirror in the existing old mirrorlist is not yet synced up with new packages.

Finally I updated and don't see any problems. Even xfce4-mixer works after removing gstreamer good plugins. Thanx Manjaro team for your work!

some users lost IP connection on upgrade

the new version NetworkManager (V1.8) is not working for all ,
any clue on this matter ?

LXQt users!
can you check your output of

xdg-open $HOME

?
Perhaps you'll get "command not found"

I can confirm this observation: I also had a similar problem (Manjaro KDE) after installing the last "stable" update today. The system hang during startup (due to a problem with sddm) for all my installed kernels.Installing openssl-1.0-compat as you suggested fixed the problem. Thanks for the info.

Hello thanks philm, my disc was full! Emptied pacman cache and was able to update with a few GB to spare. However, now I am stuck at the Manjaro screen with the 5 point loading indicators. I shut down several times and cannot get past this screen. Any ideas? thanks

Forum kindly sponsored by