[Stable Update] 2017-11-12 - Kernels, Plasma5, Deepin, Cinnamon, END OF LIFE for 32bit support

Hi community,

this is the LAST i686 UPDATE we had synced from Archlinux. Since 2017-11-08 Arch doesn't update their 32bit architecture anymore. However, via Archlinux32 you can still run an archbased Linux. Last poll we did about continuing Manjaro resulted in a drop of this architecture for good.

Having that out, what changed for you?

We added Plasma v5.11.3, Cinnamon 3.6.2, more packages of Deepin, worked on our kernels and had added the latest long-lived Nvidia driver. Arch upstream updates are synced for both architectures till 8th of November. Remember, we only continue with our 64bit architecture from now on. Please adopt to another distribution, if needed on 32bit supported systems, as you may not get any updates on that architecture from us.

Please report back and give us feedback for given changes made to our repositories.

Current supported Kernels

  • linux316 3.16.49
  • linux318 3.18.80 [EOL]
  • linux41 4.1.44
  • linux44 4.4.97
  • linux49 4.9.61
  • linux412 4.12.14 [EOL]
  • linux413 4.13.12
  • linux414 4.14-rc8 (x86_64)
  • linux-RT-LTS 4.9.47_rt37 (x86_64)
  • linux-RT 4.11.12_rt16 (x86_64)

Package Updates (Wed Nov 8 21:19:31 CET 2017)

  • stable community i686: 225 new and 211 removed package(s)
  • stable community x86_64: 232 new and 216 removed package(s)
  • stable core i686: 16 new and 16 removed package(s)
  • stable core x86_64: 18 new and 18 removed package(s)
  • stable extra i686: 159 new and 159 removed package(s)
  • stable extra x86_64: 177 new and 177 removed package(s)
  • stable multilib x86_64: 9 new and 9 removed package(s)

A detailed list of package changes you may find here.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post. Please edit as necessary.

17.0.6 is EOL? What?

EOL means "end of life". Essentially, this means Phil is preparing for 17.1 and no more work will be done on the 17.0.* series installers.

vagrant-substrate has gone

It's now part of the vagrant package (Replaces: vagrant-substrate); let it go.

and now vagrant doesn't run at all...

Exec error: fork/exec /opt/vagrant/embedded/bin/ruby: no such file or directory.

There's a bug in the package: https://bugs.archlinux.org/task/56313?project=5&cat[0]=33&string=vagrant

Workaround options:

  1. Downgrade:
    sudo pacman -S downgrade
    sudo downgrade vagrant vagrant-substrate
  2. Put in place a temporary link:
     sudo mkdir -p /opt/vagrant/embedded/bin
     sudo ln -T $(which ruby) /opt/vagrant/embedded/bin/ruby
    Be sure to remember to undo these changes next time the vagrant package is updated...

If you get the following error:

Error: error setting certificate verify locations:
   CAfile: /opt/vagrant/embedded/cacert.pem
   CApath: none

a workaround is to execute (ref: https://github.com/hashicorp/vagrant/issues/5001):

sudo cp /etc/ssl/certs/ca-certificates.crt /opt/vagrant/embedded/cacert.pem

Note: also remember to undo this modification at the next update.

Mirrors are out of sync! Why?

Currently only four mirrors are capable to handle Manjaro-64 and Manjaro-32:

This is due the work we are doing to keep Manjaro 32bit still alive.


Anyone still running a Manjaro-based 32-bit system might have a look over here: Introducing: manjaro32.org. But ssshhh, it's a secret. :kissing_smiling_eyes:


i have made the update ,
and check libinput version 1.9.1-1 ,
so no more trouble keys with HP laptop ?

fine well done guys, then I wonder why Arch upstream was synced 4 days ago and not more recently?

No issues updating on 2 machines with command line. KDE edition.

The update worked smoothly, good job!

However I still have that weird bug with MTP devices that was introduced in one of the last updates. I was not able to track it down yet. I have described it here, problem is that the device icons are added but not removed for MTP devices:

I have mouse lag issue with kernel 3.13.12 on Gnome Wayland.
More info: it works fine on only Xorg with kernel 4.13.12 , but with kernels 4.4.97, 4.9.61 it works fine on both Wayland and Xorg..

Edit: On previous Stable update I had no issue with both libinput versions 1.8.4 and 1.9.1.

Edit 2: I've done more tests. Downgrading libinput to version 1.8.4 didn't solve the problem. Seem like this kernel 4.13.12 issue. Who noticed this problem?

[libinput] Git-Bisect - Keyboard and Touchpad not accessable

so far, for me, looks like the update went smooth. no issues noticed at this time. running manjaro-gnome 64 bit

Do you use Gnome wayland?

if you are asking me, no i do not. i use xorg session. no use using wayland when i use nvidia graphic drivers for which wayland does not support

1 Like

The update went fine, but I was surprised to see that the GRUB update listed Manjaro Linux as "Manjaro Linux 17.0.6-EOL" (I am using the 64-bit version).

Would you consider renaming this?

: - )

v17.0.6 is marked as EOL. If you look at unstable you may see that that branch is already tagged as v17.1-pre2.

1 Like

No issues here on KDE, many many thanks once again to the developers and maintainers of this fabulous distribution :slight_smile:

Actually Wayland works with nvidia drivers now, but no support for opengl xwayland from nvidia. I can't see benefit from running it, when games don't work ;p

@tefter i think we are using semantics here; what you are saying makes about as much sense as keeping cigarette smoking legal, but outlawing any place to smoke. at the end of the day, its the same thing really. if there isn't any place to legally smoke, it doesn't matter if smoking is legal or not. and if openGL xwayland has no support from nvidia....to me, wayland doesn't support it...the end result is the same.

It's not the same. Wayland opengl games work...

Smooth update on Mate here.

Went well KDE as a VirturalBox host. No issues.

Forum kindly sponsored by