[Stable Update] 2018-01-19 - Kernels, KDE Apps & Framework, Browsers, Virtualbox, Systemd, Mesa

Hi community,

Upstream worked again on the Spectre and Meltdown matter and added Retpoline patches (v4.4, v4.9, v4.14, v4.15). Our GCC compiler is still in need for those patches aswell. We also updated Systemd to the lastest available version, added some needed fixes to Pamac, added KDE Framework v5.42, plus the usual Haskell and Python upgrades.

Matti worked to improve Manjaro-Architect installer, I updated Snap, we added KDE Apps v17.12.1, renewed Mesa and released Wine v3.0-rc6. As usual we have the regular upstream updates.

Stefano worked again on our Adapta Theme and the Grub-Live-Theme. We had the libcdio v2.0 rebuild and added some more WebDAD packages.

Codruț worked on the vertex-maia-icons, we had another systemd update plus the usual haskell and python rebuilds.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.

Current supported Kernels

  • linux316 3.16.52
  • linux318 3.18.92 [EOL]
  • linux41 4.1.48
  • linux44 4.4.112
  • linux49 4.9.77
  • linux412 4.12.14 [EOL]
  • linux413 4.13.16 [EOL]
  • linux414 4.14.14
  • linux415 4.15-rc8
  • linux-RT-LTS 4.9.76_rt61
  • linux-RT 4.11.12_rt16

Package Updates (Thu Jan 18 20:03:14 CET 2018)

  • stable community x86_64: 607 new and 597 removed package(s)
  • stable core x86_64: 19 new and 19 removed package(s)
  • stable extra x86_64: 463 new and 466 removed package(s)
  • stable multilib x86_64: 8 new and 13 removed package(s)

Further details can be found here.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary

My rtl8723be wifi card stopped working

You may need to specify (or switch) the antenna selection via the ant_sel driver option, e.g.:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

If you already have an driver options file try switching the option between 0, 1, and 2.

Network connection is unreliable, not working, or not connecting

Occasionally, Network Manager updates change the underlying settings structure (schemas). This can change or break existing settings without you knowing about it.

This can be fixed by removing the existing connection settings, and then re-adding the connection. You may also need to reboot. If this does not work, move to the next point.

networkmanager 1.10.2-1 does not get an IP address

For some configurations, Network Manager tries to use its internal DHCP client which appears to be incompatible with some wireless access points. This shows up as a timeout during the connection attempt.

To switch back to the previous behaviour of 1.10.0, run the following from a terminal:

echo -e "[main]\ndhcp=dhclient" | sudo tee /etc/NetworkManager/conf.d/dhclient.conf

The creates a file which sets Network Manager to use the stand-alone dhclient program, as it did before. If this still doesn't work (e.g. after a reboot), there's the option of downgrading (see the next point).

networkmanager 1.10.3dev+38+g78ef57197-1 does not auto-connect to WLAN (KDE)

If you find that your WLAN does not auto connect even if the entry is ticked to do so, you can downgrade the Network Manager package. Before doing so, please check the points above.

It's possible to downgrade to the working build:

sudo pacman -U https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.10.0-1-x86_64.pkg.tar.xz

You'll also need to temporarily ignore the package in /etc/pacman.conf

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = networkmanager
#IgnoreGroup =

Don't forget to reverse this ignore setting as and when a networkmanager fix is announced and released to stable.

Also, have a look at Network Manager MegaThread .

Cannot update nautilus-admin

error: failed to prepare transaction (could not satisfy dependencies)
:: nautilus-admin: installing python2-nautilus (1.2.1-2) breaks dependency 'python-nautilus'

Remove nautilus-admin and python2-nautilus by

sudo pacman -Rs nautilus-admin

and then install nautilus-admin again.

  • tint2 stop working in 1 of my 2 laptops; I do not know why, just downgrade to tint2 15.3-1.
  • in my another laptop, tint2 16.1 show unusual high CPU usage (more than google-chrome); so, I downgraded it back to tint2 15.3
1 Like

Smooth upgrade with Plasma.

Got this:
error: failed to commit transaction (conflicting files)
snapd: /snap exists in filesystem
snapd: /usr/share/dbus-1/services/io.snapcraft.Launcher.service exists in filesystem
Errors occurred, no packages were upgraded.

I had to remove snapd to upgrade.

After the update, when suspending the system Gnome shell (Xorg) crashes then turns off the screen. When I turn on the desktop is not locked up as usual and I can use the computer without the need of a password.

Any other file I can provide to help?

EDIT: Fixed by uninstalling the Arc menu extension.


you must REBOOT after UPDATE not RESUME !

Thanks, but rebooted twice already same result.

I was told on a group to run
grep . /sys/devices/system/cpu/vulnerabilities/*
to test for the Meltdown & Spectre fix but it returned No such file or directory. Am I misunderstanding that Manjaro Stable update has applied this?

Our effort and all the needed information about the new security risk can be found here. You may install spectre-meltdown-checker


Ran 2 tests & same result. Simple question is it activated for STABLE branch? If so what should I do? Checked the link & so much info is confusing.

EDIT - the update announce wasn't working until I ran the update via the terminal (last updated a couple of days ago) & 89 updates were there. All done & command works now to show patch in place. Yes I should have spotted the update was 19th - my bad :roll_eyes:

Running KDE desktop on kernel 4.14.14-1. Smooth update after rebooting.

However, same niggle as the last time, albeit nothing drastic as such: Octopi Notifier is still not functioning, it only flashes red after synchronizing directly through Octopi itself.

Thanks for the update Manjaro Team - you guys have been pushing hard since December!

On my installation the 2018-01-07 update wasn't shown by Octopi Notifier, but this update was.

1 Like

No issues noticed. 3x XFCE systems kernels 4.14 on all. :+1:

Super smooth on my end, same ol same ol :smiley:

Octopi is working for me now, although it's still not notifying me of AUR only updates. Pamac however, has still not notified me of today's update.

1 Like

Smooth update xfce 4.14. Ongoing congratulations to Manjaro team. :clap:

(Very much like the new power icon on the panel. :smiley:)

Updated xfce 4.14 kernel. Perfect. :ok_hand:

Greg Kroah-Hartman mentioned that command in his blog post, but I don't think it works on all distros.

There is alternate command,

grep -q "cpu_insecure\|cpu_meltdown\|kaiser" /proc/cpuinfo && echo "patched :)" \ || echo "unpatched :("

But even this will give the wrong result on an older kernel. The best thing to do right now is to check posts on every distro's blog/forum. @philm mentioned the link in his post above. spectreattack.com does provide some useful info as well.

All seemed to work smoothly for me, but like Frenchy, I didn't get a 'red' Octopi until I did a sync (so thanks for that tip lol). I was kind of waiting for it to show up until I saw Frenchy's notification. Seems fine after the reboot.

1 Like

It worked great AFTER the update & restart.

Forum kindly sponsored by