[Stable Update] 2018-01-29 - Kernels, Mesa, Xorg-Server, Browsers, MSM, MHWD, GCC

Hi community,

with this we updated most of our Kernels, Mesa, Firefox, GCC. We also worked on our Adapta theme, downgraded the Intel microcode as needed puls reworked our Firmwares a little in regard of iwlwifi.

As usual we have some Haskell and Python rebuilds/updates. Bernhard and I worked on the Real-Time Kernels and updated them both to v4.14 series. We use now meta-pkgs to define them for you. Some work went into our Steam-Client and we managed to get more extra-modules compiled for our v4.15 kernel series.

It seems that our french community had some issues changing wallpapers within our XFCE edition. This is now addressed and fixed with our v17.1.3 ISOs by default. For installed systems we recommend to use /usr/share/backgrounds/xfce as default folder. The new package will automatically create the needed symlinks for wallpapers added to /usr/share/backgrounds from now on.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.

Current supported Kernels

  • linux316 3.16.52
  • linux318 3.18.92 [EOL]
  • linux41 4.1.48
  • linux44 4.4.113
  • linux49 4.9.78
  • linux412 4.12.14 [EOL]
  • linux413 4.13.16 [EOL]
  • linux414 4.14.15
  • linux415 4.15.0
  • linux-RT-LTS 4.14.15_rt12
  • linux-RT 4.14.15_rt12

Package Updates (Mon Jan 29 09:50:51 CET 2018)

  • stable community x86_64: 873 new and 827 removed package(s)
  • stable core x86_64: 46 new and 46 removed package(s)
  • stable extra x86_64: 331 new and 409 removed package(s)
  • stable multilib x86_64: 16 new and 14 removed package(s)

A detailed list of all changes can be found here.

Bonus update:

Firefox 58.0.1 and Thunderbird 52.6.0 are also now available.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.

Some modules don't load with kernel v4.14.15

This kernel version doesn't yet have the full "retpoline" patches added so some modules might not load. You can force them to load via sudo modprobe --force-vermagic <your-module-to-load> until it is properly fixed by upstream.

The other solution is to switch to kernel 4.15 until all patches have been backported to earlier kernels:

sudo mhwd-kernel -i linux415

I have kernel 4.14.15-1.1 and things don't work

Revert to 4.14.15-1:

sudo pacman-mirrors -f 3
sudo pacman -Syyuu

Display managers segfault/crash/don't run

xorg-server is missing a (new) dependency on libbsd; until the package is corrected run:

sudo pacman -S libbsd

GNOME shell crashes

It's probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it's when inserting USB drives, disable "Places Status Indicator".

Font-Shadow issue within XFCE

Switch to another theme (e.g. Arc Maia), or execute the following cmd to fix the issue:

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool -s false

This fixes the issue properly. (Can follow the links from Ask-Ubuntu #801478 to what exists for the xfce documentation.)

After the command is run the entry <property name="center-text" type="bool" value="false"/> is created under "desktop-icons" in /home/[user]/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.

Firefox 58 won't open

Please check this thread:

I don't see any updates

That's because your mirror is out of date. Run:

sudo pacman-mirrors -f 3
sudo pacman -Syyu

I get a black screen on boot or something doesn't work

That's probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.

An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.

An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).


Is 17.1.3 ISO available for download? I see only 17.1.2.

@philm 17.1.3 ISO's gonna be up tonight?

I received the following error message during update of kernel 4.14 and 4.15:

-> Running build hook: [keymap]
==> ERROR: Hook 'plymouth' cannot be found

==> WARNING: errors were encountered during the build. The image may not be complete.

I receive error while loading modules:

29.01.2018 20:25	kernel	vboxdrv: version magic '4.14.15-1-MANJARO SMP preempt mod_unload modversions retpoline ' should be '4.14.15-1-MANJARO SMP preempt mod_unload modversions '
29.01.2018 20:25	kernel	8812au: version magic '4.14.15-1-MANJARO SMP preempt mod_unload modversions retpoline ' should be '4.14.15-1-MANJARO SMP preempt mod_unload modversions '

The second module is essential for my wi-fi to work. Everything was fine before the update

Es wird langsam :smiley:

Seems you have an AUR package here. Did you recompile it against the new kernel? Else you may disable this feature by adding noretpoline to your kernel boot cmd.

It depends. XFCE for sure ...


Yes, I did, but it didn't help.

Is it a module compiled on your end or not? Maybe a recompile might help. Else disable the retpoline feature of the kernel.

I install it from AUR, it worked before like a charm:

Building rtl8812au-dkms-git...
Cloning into 'rtl8812au-dkms-git'...
remote: Counting objects: 50, done.        
remote: Compressing objects: 100% (49/49), done.        
remote: Total 50 (delta 16), reused 15 (delta 1)        
Unpacking objects: 100% (50/50), done.
==> Making package: rtl8812au-dkms-git 5.2.20.r9.gaca1e06-1 (pon, 29 sty 2018, 21:02:40 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning rtl8812au-driver-5.2.20 git repo...
Cloning into bare repository '/tmp/pamac-build-adrian/rtl8812au-dkms-git/rtl8812au-driver-5.2.20'...
remote: Counting objects: 610, done.        
remote: Compressing objects: 100% (383/383), done.        
remote: Total 610 (delta 220), reused 610 (delta 220), pack-reused 0        
Receiving objects: 100% (610/610), 2.57 MiB | 618.00 KiB/s, done.
Resolving deltas: 100% (220/220), done.
  -> Found dkms.conf
==> Validating source files with sha256sums...
    rtl8812au-driver-5.2.20 ... Skipped
    dkms.conf ... Passed
==> Extracting sources...
  -> Creating working copy of rtl8812au-driver-5.2.20 git repo...
Cloning into 'rtl8812au-driver-5.2.20'...
==> Starting pkgver()...
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issue...
==> Creating package "rtl8812au-dkms-git"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: rtl8812au-dkms-git 5.2.20.r9.gaca1e06-1 (pon, 29 sty 2018, 21:02:48 CET)
==> Cleaning up...

Warning: rtl8812au-dkms-git-5.2.20.r9.gaca1e06-1 is up to date -- reinstalling
Resolving dependencies...
Checking inter-conflicts...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Running pre-transaction hooks...
Remove DKMS modules
==> dkms remove rtl8812au/5.2.20.r9.gaca1e06 -k 4.14.15-1-MANJARO
Reinstalling rtl8812au-dkms-git (5.2.20.r9.gaca1e06-1)...
Running post-transaction hooks...
Install DKMS modules
==> dkms install rtl8812au/5.2.20.r9.gaca1e06 -k 4.14.15-1-MANJARO
Arming ConditionNeedsUpdate...
Transaction successfully finished.

You may load it with modprobe --force-vermagic 8812au if nothing else helps. Also try with v4.15 series. Not all needed retpoline patches are yet in v4.14 series ...

I have same problem with kernel modules from VMware workstation as @grzadr ... however recompiling modules using DKMS did not help:

~ >>> sudo dkms install vmware-workstation/14.1.1_7528167                                                                                                 

Creating symlink /var/lib/dkms/vmware-workstation/14.1.1_7528167/source ->

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j6 KERNELRELEASE=4.14.15-1-MANJARO KVERSION=4.14.15-1-MANJARO SRCDIR=/usr/src/vmware-workstation-14.1.1_7528167.....
cleaning build area...
Kernel cleanup unnecessary for this kernel.  Skipping...

DKMS: build completed.

Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /usr/lib/modules/4.14.15-1-MANJARO/kernel/drivers/misc/

Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /usr/lib/modules/4.14.15-1-MANJARO/kernel/drivers/net/


DKMS: install completed.

~ >>> sudo modprobe -a vmmon vmnet                                                                                                                        
modprobe: ERROR: could not insert 'vmmon': Exec format error
modprobe: ERROR: could not insert 'vmnet': Exec format error
~ >>>

is the only solution to disable retpoline or do I have something wrong on my side?

... use this with your module loading or try v4.15 kernel series.

1 Like

Kernel 4.15 works, no error loading modules @spaceback

After the update the names of my desktop icons, when short enough not to fill a complete line, are offset to the left. Selecting one shows the correct position for the text in the shadow.


Downgrading gtk-engine-murrine to 0.98.2-2.2 fixes the problem.

(Running XFCE 4.14 with the Nvidia non-free drivers.)

p.s. I also get an artefact on the desktop - when moving the icon the left hand side of the 'T' remains in place and is missing from the new placement of the icon (I can't show it as using xfce-screenshooter clears that part of the glitch).


ah, --force-vermagic works as workaround for now (I unfortunately need VMware workstation for work), I will try 4.15 kernel later... thanks...

thanks for report, will try 4.15 series tomorrow... :slight_smile:

@oberon: what was the reason we had an overlay package and what might be needed for the XFCE "optical" problem? @grinner seems I saw it but I skipped it in my QM for v17.1.3.

Forum kindly sponsored by