[Stable Update] 2018-02-17 - Kernels, KDE, MATE, Firefox, LibreOffice, Mesa, Systemd

Hi community,

it took us a while to prepare this update-pack. Mostly it is due my busy work life at the moment. However managed to squeze the best new open source software for you into this one. For all newcomers to Manjaro, please install Manjaro from our fresh v17.1.5 install ISOs.

  • Plasma got updated to v5.12.1 LTS
  • Updated KDE Framework to v5.43
  • Added KDE Apps v17.12.2
  • We updated most of our kernels and rebuild all against the new GCC v7.3.0 release
  • Ryzen CPUs should now be fully protected when AGESA v1.1.0.1 or higher got applied to your BIOS (also disable PSP)
  • Latest Systemd added
  • Latest Browsers
  • Lates Nvidia Drivers
  • Fixed some issue with Bluetooth headsets in bluez
  • Had some Haskell and Python updates/rebuilds
  • LibreOffice updated to v5.4.5 and v6.0.1
  • Fixed issue with WLAN drivers in our v4.15 kernel series
  • Updated MATE to v1.20
  • Worked again on our Adapta theme
  • Plus the latest upstream updates as usual

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.

Current supported Kernels

  • linux316 3.16.54
  • linux318 3.18.94 [EOL]
  • linux41 4.1.49
  • linux44 4.4.115
  • linux49 4.9.81
  • linux414 4.14.19
  • linux415 4.15.3
  • linux-RT-LTS 4.14.18_rt15
  • linux-RT 4.14.18_rt15

Package Updates (Thu Feb 15 05:31:34 CET 2018)

  • stable community x86_64: 1020 new and 943 removed package(s)
  • stable core x86_64: 44 new and 45 removed package(s)
  • stable extra x86_64: 991 new and 1037 removed package(s)
  • stable multilib x86_64: 27 new and 27 removed package(s)

A detailed list of all package changes can be found here.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:



Known issues and solutions

This is a wiki post; please edit as necessary.

xorgproto, libxfont, can't remove... what?

Refresh your mirrors and try the update again. This package conflict should be resolved.

Otherwise, say Yes to replace all the "proto" packages with xorgproto. If it wants to remove any packages, STOP, and run

sudo pacman-mirrors -f 3
sudo pacman -Syyu

KDE Global Menu on all my windows

Check System Settings -> Application Style -> Window Decorations -> Buttons.

Make sure global menu widget is removed from the Titlebar, for some reason it was added in 5.12 when the global menu setting option was removed.

KDE remove green separator line between Titlebar and Window

System Settings>Application Style>Window Decorations>Breeze>Settings Icon
Turn off “Draw separator …”

On KDE my external drives don't get automounted when I plugged them in

As a workaround put into the KDE/Plasma autostart the program udiskie (just plain like that), after you had installed it. A re-login may be needed to get it active. As alternative start it manually for your current session.

My system won't boot anymore after this update

Most likely you are using a freetype2 package from the AUR. Due the harfbuzz update, your system is broken. So either install the official supported freetype2 package from our repositories or downgrade to harfbuzz v1.7.4: sudo pacman -U https://archive.archlinux.org/packages/h/harfbuzz/harfbuzz-1.7.4-1-x86_64.pkg.tar.xz

You might try also try Freetype2-ultimate5 — fonts like in Infinality's ultimate5 which is a maintained package.

I get "error: command failed to execute correctly" during a GRUB update

Run sudo update-grub once more to ensure the command has worked correctly.

GNOME shell crashes

It's probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it's when inserting USB drives, disable "Places Status Indicator".

Font-Shadow issue within XFCE

Switch to another theme (e.g. Arc Maia), or execute the following cmd to fix the issue:

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool -s false

This fixes the issue properly. (Can follow the links from Ask-Ubuntu #801478 to what exists for the xfce documentation.)

After the command is run the entry <property name="center-text" type="bool" value="false"/> is created under "desktop-icons" in /home/[user]/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.

Firefox 58 won't open

Please check this thread:

I don't see any updates

That's because your mirror is out of date. It can take several hours before a mirror get updated. If you want updates right now, run these commands :

sudo pacman-mirrors -f 3
sudo pacman -Syyu

You can always check the state of every mirrors here.

I get a black screen on boot or something doesn't work

That's probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.

An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.

An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).


After this update, my xfce panel shifts a few pixels left or right every second or so depending on the clock width - I display time with seconds and use Cantarell font.
This is due to the update of cantarell-fonts to 0.100 (2018-02-08).
Changing the font to Noto Sans UI fixes it but do you have any other fix in mind while keeping Cantarell?

9 posts were split to a new topic: Drive automount broken in KDE

Big update, but all works fine :slight_smile: Thank you very much :blush:


there is still 17.1.4

6 posts were merged into an existing topic: Performance regression with NVIDIA 390.25

Seems I also have lost the controls for Decrease - Increase screen brightness. As far as I have check now, all the rest is working so I have only those 2 issues : automount removable disks and screen brightness controls. (KDE edition)



Thanks for the quick info, yes... seems I have catch the same train....:innocent:

All seems ok.
I had to uninstall and reinstall AUR waterfox-kde-bin
Error was:
XPCOMGlueLoad error for file /opt/waterfox/libxul.so:
libvpx.so.4: cannot open shared object file: No such file or directory

The Manjaro Team Rocks

I was not able to fulfill the dependencies:

Update Not Installed

1 Like

i have a little trouble after login on Xfce
the DE dot not appears i have to switch on Ctrl+Alt+F7

also this check too on script MHWD , may be downgrade nvidia drivers ?

local/lib32-libvdpau 1.1.1-2
    Nvidia VDPAU library
local/lib32-nvidia-utils 1:390.25-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.1.1+3+ga21bf7a-1
    Nvidia VDPAU library
local/linux414-nvidia 1:390.25-3 (linux414-extramodules)
    NVIDIA drivers for linux.
local/linux415-nvidia 1:390.25-5 (linux415-extramodules)
    NVIDIA drivers for linux.
local/linux49-nvidia 1:390.25-2 (linux49-extramodules)
    NVIDIA drivers for linux.
local/mhwd-nvidia 1:384.111-2
    MHWD module-ids for nvidia 384.111
1 Like

Install 4.14 or 4.15 and remove 4.12 and 4.13 kernels, they are EOL and not supported anymore.


Did you reboot?

Yes, of course.... even twice trying 2 different Kernel. Same.

A post was split to a new topic: Fonts on freshly installed system look worse than upgraded system


can you try and logoff then login cession ?

can you check

sudo pacman -Qs libvpx

local/lib32-libvpx1.3 1.3.0-1
    VP8 and VP9 codec
local/libvpx 1.7.0-1
    VP8 and VP9 codec
local/libvpx1.3 1.3.0-1
    VP8 and VP9 codec

Strange, for me automount and brightness work fine in KDE.

Forum kindly sponsored by