[Stable Update] 2018-02-20 - Kernels, Mesa, KDE fixes, Driver fixes

Hi community,

this is more or less a fix-up update for our last stable update we did on the 17th

  • We fixed the automount issue in KDE
  • We fixed the powerbutton issue in KDE
  • We updated some of our kernels
  • We worked on the mouse jittering issue for synaptics driver
  • We updated Mesa to fix some graphical issues.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.

Current supported Kernels

  • linux316 3.16.54
  • linux318 3.18.95 [EOL]
  • linux41 4.1.49
  • linux44 4.4.116
  • linux49 4.9.82
  • linux414 4.14.20
  • linux415 4.15.4
  • linux-RT-LTS 4.14.18_rt15
  • linux-RT 4.14.18_rt15

Package Updates (Thu Feb 15 05:31:34 CET 2018)

  • stable community x86_64: 1 new and 3 removed package(s)
  • stable core x86_64: 10 new and 10 removed package(s)
  • stable extra x86_64: 94 new and 92 removed package(s)
  • stable multilib x86_64: 5 new and 5 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE            2018-02-17          2018-02-20
         manjaro-bspwm-mate-settings           20180219-6                    -
              manjaro-bspwm-settings           20180219-4           20180206-1
      manjaro-bspwm-settings-minimal           20180219-4                    -

:: Different overlay package(s) in repository core x86_64

                             PACKAGE            2018-02-17          2018-02-20
                            linux318            3.18.94-1            3.18.95-1
                    linux318-headers            3.18.94-1            3.18.95-1
                            linux414            4.14.19-1            4.14.20-2
                    linux414-headers            4.14.19-1            4.14.20-2
                            linux415             4.15.3-2             4.15.4-2
                    linux415-headers             4.15.3-2             4.15.4-2
                             linux44            4.4.115-1            4.4.116-1
                     linux44-headers            4.4.115-1            4.4.116-1
                             linux49             4.9.81-1             4.9.82-1
                     linux49-headers             4.9.81-1             4.9.82-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE            2018-02-17          2018-02-20
                   libva-mesa-driver             17.3.4-0             17.3.5-0
                  linux318-acpi_call             1.1.0-48             1.1.0-49
                   linux318-bbswitch               0.8-48               0.8-49
                   linux318-catalyst     1:15.201.1151-38     1:15.201.1151-39
                linux318-ndiswrapper              1.61-24              1.61-25
                     linux318-nvidia           1:390.25-1           1:390.25-2
               linux318-nvidia-304xx         1:304.137-13         1:304.137-14
               linux318-nvidia-340xx            340.106-3            340.106-4
                   linux318-nvidiabl              0.88-38              0.88-39
      linux318-open-vm-tools-modules      2:2013.09.16-48      2:2013.09.16-49
                      linux318-r8168           8.045.08-3           8.045.08-4
                        linux318-spl              0.7.5-3              0.7.5-4
                   linux318-tp_smapi              0.41-48              0.41-49
                linux318-vhba-module          20161009-24          20161009-25
   linux318-virtualbox-guest-modules              5.2.6-3              5.2.6-4
    linux318-virtualbox-host-modules              5.2.6-3              5.2.6-4
                        linux318-zfs              0.7.5-3              0.7.5-4
                  linux414-acpi_call             1.1.0-17             1.1.0-18
                   linux414-bbswitch               0.8-17               0.8-18
                   linux414-catalyst     1:15.201.1151-17     1:15.201.1151-18
                linux414-ndiswrapper              1.61-17              1.61-18
                     linux414-nvidia           1:390.25-3           1:390.25-4
               linux414-nvidia-304xx         1:304.137-17         1:304.137-18
               linux414-nvidia-340xx            340.106-5            340.106-6
                   linux414-nvidiabl              0.88-17              0.88-18
                      linux414-r8168           8.045.08-5           8.045.08-6
                        linux414-spl              0.7.5-7              0.7.5-8
                   linux414-tp_smapi              0.41-17              0.41-18
                linux414-vhba-module          20161009-17          20161009-18
   linux414-virtualbox-guest-modules              5.2.6-5              5.2.6-6
    linux414-virtualbox-host-modules              5.2.6-5              5.2.6-6
                        linux414-zfs              0.7.5-7              0.7.5-8
                  linux415-acpi_call              1.1.0-4              1.1.0-5
                   linux415-bbswitch                0.8-4                0.8-5
                   linux415-catalyst      1:15.201.1151-4      1:15.201.1151-5
                linux415-ndiswrapper               1.61-4               1.61-5
                     linux415-nvidia           1:390.25-5           1:390.25-6
               linux415-nvidia-304xx          1:304.137-4          1:304.137-5
               linux415-nvidia-340xx            340.106-4            340.106-5
                   linux415-nvidiabl               0.88-4               0.88-5
                      linux415-r8168           8.045.08-4           8.045.08-5
                        linux415-spl              0.7.5-4              0.7.5-5
                   linux415-tp_smapi               0.41-4               0.41-5
                linux415-vhba-module           20161009-4           20161009-5
   linux415-virtualbox-guest-modules              5.2.6-4              5.2.6-5
    linux415-virtualbox-host-modules              5.2.6-4              5.2.6-5
                        linux415-zfs              0.7.5-4              0.7.5-5
                   linux44-acpi_call             1.1.0-82             1.1.0-83
                    linux44-bbswitch               0.8-82               0.8-83
                    linux44-catalyst     1:15.201.1151-82     1:15.201.1151-83
                 linux44-ndiswrapper              1.61-50              1.61-51
                      linux44-nvidia           1:390.25-1           1:390.25-2
                linux44-nvidia-304xx         1:304.137-17         1:304.137-18
                linux44-nvidia-340xx            340.106-4            340.106-5
                    linux44-nvidiabl              0.88-82              0.88-83
       linux44-open-vm-tools-modules      2:2013.09.16-82      2:2013.09.16-83
                       linux44-r8168           8.045.08-4           8.045.08-5
                         linux44-spl              0.7.5-6              0.7.5-7
                    linux44-tp_smapi              0.41-82              0.41-83
                 linux44-vhba-module          20161009-50          20161009-51
    linux44-virtualbox-guest-modules              5.2.6-3              5.2.6-4
     linux44-virtualbox-host-modules              5.2.6-3              5.2.6-4
                         linux44-zfs              0.7.5-6              0.7.5-7
                   linux49-acpi_call             1.1.0-63             1.1.0-64
                    linux49-bbswitch               0.8-63               0.8-64
                    linux49-catalyst     1:15.201.1151-63     1:15.201.1151-64
                 linux49-ndiswrapper              1.61-61              1.61-62
                      linux49-nvidia           1:390.25-2           1:390.25-3
                linux49-nvidia-304xx         1:304.137-22         1:304.137-23
                linux49-nvidia-340xx            340.106-3            340.106-4
                    linux49-nvidiabl              0.88-63              0.88-64
                       linux49-r8168           8.045.08-3           8.045.08-4
                         linux49-spl              0.7.5-5              0.7.5-6
                    linux49-tp_smapi              0.41-63              0.41-64
                 linux49-vhba-module          20161009-61          20161009-62
    linux49-virtualbox-guest-modules              5.2.6-3              5.2.6-4
     linux49-virtualbox-host-modules              5.2.6-3              5.2.6-4
                         linux49-zfs              0.7.5-5              0.7.5-6
                                mesa             17.3.4-0             17.3.5-0
                          mesa-vdpau             17.3.4-0             17.3.5-0
                         opencl-mesa             17.3.4-0             17.3.5-0
                        vulkan-intel             17.3.4-0             17.3.5-0
                       vulkan-radeon             17.3.4-0             17.3.5-0
                          powerdevil                    -           5.12.1-1.1
                               solid                    -           5.43.0-1.1

:: Different overlay package(s) in repository multilib x86_64

                             PACKAGE            2018-02-17          2018-02-20
             lib32-libva-mesa-driver             17.3.4-0             17.3.5-0
                          lib32-mesa             17.3.4-0             17.3.5-0
                    lib32-mesa-vdpau             17.3.4-0             17.3.5-0
                  lib32-vulkan-intel             17.3.4-0             17.3.5-0
                 lib32-vulkan-radeon             17.3.4-0             17.3.5-0

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:



Known issues and solutions

This is a wiki post; please edit as necessary.

Black screen with Linux415 and Nvidia drivers

If you can't boot to your graphical user interface you may want to blacklist nvidiafb and rivafb. This will be automatically fixed in a later update:

sudo echo "blacklist nvidiafb" >> /etc/modprobe.d/mhwd-gpu.conf
sudo echo "blacklist rivafb" >> /etc/modprobe.d/mhwd-gpu.conf

My mouse is jittering like hell!

Seems the new libinput update created some issues with some touchpads. If our new kernel updates don't solve the issue for you, you may think about downgrading libinput instead, until upstream found a proper solution for you:

sudo pacman -U https://archive.archlinux.org/packages/l/libinput/libinput-1.9.4-1-x86_64.pkg.tar.xz

xorgproto, libxfont, can't remove... what?

Refresh your mirrors and try the update again. This package conflict should be resolved.

Otherwise, say Yes to replace all the "proto" packages with xorgproto. If it wants to remove any packages, STOP, and run

sudo pacman-mirrors -f 3
sudo pacman -Syyu

KDE Global Menu on all my windows

Check System Settings -> Application Style -> Window Decorations -> Buttons.

Make sure global menu widget is removed from the Titlebar, for some reason it was added in 5.12 when the global menu setting option was removed.

KDE remove green separator line between Titlebar and Window

System Settings>Application Style>Window Decorations>Breeze>Settings Icon
Turn off “Draw separator …”

On KDE my external drives don't get automounted when I plugged them in

As a workaround put into the KDE/Plasma autostart the program udiskie (just plain like that), after you had installed it. A re-login may be needed to get it active. As alternative start it manually for your current session.

My system won't boot anymore after this update

Most likely you are using a freetype2 package from the AUR. Due the harfbuzz update, your system is broken. So either install the official supported freetype2 package from our repositories or downgrade to harfbuzz v1.7.4: sudo pacman -U https://archive.archlinux.org/packages/h/harfbuzz/harfbuzz-1.7.4-1-x86_64.pkg.tar.xz

You might try also try Freetype2-ultimate5 — fonts like in Infinality's ultimate5 which is a maintained package.

I get "error: command failed to execute correctly" during a GRUB update

Run sudo update-grub once more to ensure the command has worked correctly.

GNOME shell crashes

It's probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it's when inserting USB drives, disable "Places Status Indicator".

Font-Shadow issue within XFCE

Switch to another theme (e.g. Arc Maia), or execute the following cmd to fix the issue:

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool -s false

This fixes the issue properly. (Can follow the links from Ask-Ubuntu #801478 to what exists for the xfce documentation.)

After the command is run the entry <property name="center-text" type="bool" value="false"/> is created under "desktop-icons" in /home/[user]/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.

Firefox 58 won't open

Please check this thread:

I don't see any updates

That's because your mirror is out of date. It can take several hours before a mirror get updated. If you want updates right now, run these commands :

sudo pacman-mirrors -f 3
sudo pacman -Syyu

You can always check the state of every mirrors here.

I get a black screen on boot or something doesn't work

That's probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.

An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.

An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).


Thanks for automount issue. :sunglasses:

Thanks for update, everything is OK :slight_smile:

All good on KDE. Latest bugs (No automount and Brightness) are fixed. Thanks !

My computer freezes after login in, i used KDE with deepin as de, it also freezes on plasma, i just updated. What should i do?

Either the mouse gets stuck or only the mouse works, what can i do, please help i only have this computer

Thanks for the update. :grinning: Everything works perfectly.:sunglasses:

I dont have any of the issues mentioned above, sometimes it logs in, but it freezes if i open anything, then i power off, reboot and that program will work, but if a new option emerges it freezes again. Help

So far only with fallback initramfs works and then it freezes

Edit: My mistake, looks like my btrfs has gone FUBAR, had to reinstall Manjaro, thankfully Manjaro-Architect comes to the rescue.

Was there some changes to SATA drivers? 4.14.20 hangs on
[ 1.286697] ata3: softreset failed (device not ready)
[ 1.286791] ata6: softreset failed (device not ready)

4.14.19 is ok.

On my System with 4.14.20 is the xfs module available and working.

Kernel 4.14.10 is really old, are you sure you did a complete update and did a restart after the update?

kde automount problems are history, thanks a lot :slight_smile:

but - for some reason, autologin does not always work properly (since 2018-02-17). de/reactivating the autologin feature seemed to have fixed it, but on a restart (not even coldboot) i was prompted to enter my password again.

All good on XFCE and Deepin. Thanks again for the great work !

Manjaro KDE still not autoconnecting to WiFi network on start.

Try removing and adding it with nmtui from terminal. It worked on me in previous updates.

New error on boot after this update: nvidiafb: cannot request PCI regions

Did not affect system from booting. Everything working great, just wanted to report the error.

Kernel: 4.15.4-2-MANJARO x86_64 bits: 64 Desktop: Xfce 4.12.4
Card: NVIDIA GT216 [GeForce GT 220]
Display Server: X.Org 1.19.6 driver: nvidia Resolution: 1920x1080@60.00hz
OpenGL: renderer: GeForce GT 220/PCIe/SSE2 version: 3.3.0 NVIDIA 340.106

for Xfce & Nvidia drivers and Geforce 970
login without windows managers since version 390
i have to Ctrl+Alt+F2 ( 3 to 4 seconds to appears ) then Ctrl+Alt+F7 to get windows manager

i have also warning in log X11
every 60 seconds

[    42.862] (WW) NVIDIA(0): Suspend swap group failed.
[    42.863] (WW) NVIDIA(0): Resume swap group failed.
[    42.863] (WW) NVIDIA(0): Suspend swap group failed.
[    42.863] (WW) NVIDIA(0): Resume swap group failed.
[    42.863] (WW) NVIDIA(0): Suspend swap group failed.
[    42.863] (WW) NVIDIA(0): Resume swap group failed.
[    42.876] (WW) NVIDIA(0): Suspend swap group failed.
[    42.876] (WW) NVIDIA(0): Resume swap group failed.
[    42.876] (WW) NVIDIA(0): Suspend swap group failed.
[    42.876] (WW) NVIDIA(0): Resume swap group failed.
[   118.928] (WW) NVIDIA(0): Suspend swap group failed.
[   118.928] (WW) NVIDIA(0): Resume swap group failed.
[   118.928] (WW) NVIDIA(0): Suspend swap group failed.
[   118.929] (WW) NVIDIA(0): Resume swap group failed.
[   118.931] (WW) NVIDIA(0): Suspend swap group failed.
[   118.931] (WW) NVIDIA(0): Resume swap group failed.
[   118.931] (WW) NVIDIA(0): Suspend swap group failed.
[   118.931] (WW) NVIDIA(0): Resume swap group failed.
[   118.938] (WW) NVIDIA(0): Suspend swap group failed.
[   118.938] (WW) NVIDIA(0): Resume swap group failed.
[   118.938] (WW) NVIDIA(0): Suspend swap group failed.
[   118.938] (WW) NVIDIA(0): Resume swap group failed.
[   118.939] (WW) NVIDIA(0): Suspend swap group failed.
1 Like


KDE-PLASMA + onboard INTEL + INTEL CPU: all well, but autoconnecting to WiFi takes veeery long (3min)

KDE-PLASMA + NVIDIA + AMD CPU + BTRFS: this testing system went into emergency mode due to some /boot /swap issues

edit: did some tests

Everything goes well here it seems.
Plus, now Firefox seems to properly remember the session when it is open at power off, and brings it back upon launching it again.

... Or not.

KDE plasma 5.12.1
Kernel: 4.14.20-2-MANJARO x86_64
Device: laptop System: Apple product: MacBookPro9 2
Dual core Intel Core i5-3210M
Intel 3rd Gen Core processor Graphics Controller
Broadcom Limited NetXtreme BCM57765 Gigabit Ethernet PCIe
Broadcom Limited BCM4331 802.11a/b/g/n

Everything is working as expected except autoconnection to WiFi takes rather long.


Forum kindly sponsored by