[Stable Update] 2018-02-25 - Kernels, Plasma, Mesa, Systemd, QT5, Browsers

Hi community,

welcome to another stable update of Manjaro. Not only we have a fresh Plasma for you to have fun with, we also extended our kernels with v4.16 series. This brings new hardware support and a lot of new features. Also we worked on our graphical stack and updated some of our tools. For all newcomers to Manjaro, please install Manjaro from our fresh v17.1.6 install ISOs.

Here are the changes in more details:


  • We upgraded Plasma to v5.12.2
  • We upgraded QT to v5.10.1
  • We added Kernel v4.16 series
  • We upgraded mhwd to v0.6.2 and simplified opensource driver installation for nouveau and amdgpu
  • We updated Mesa and LibDRM
  • We addressed the issue with nvidiafb and linux415+ series
  • We updated Systemd
  • We added regular upstream updates like Haskell and Python

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.

Current supported Kernels

  • linux316 3.16.54
  • linux318 3.18.95 [EOL]
  • linux41 4.1.49
  • linux44 4.4.117
  • linux49 4.9.83
  • linux414 4.14.21
  • linux415 4.15.5
  • linux416 4.16-rc2
  • linux-RT-LTS 4.14.20_rt17
  • linux-RT 4.14.20_rt17

Package Updates (Fri Feb 23 21:51:08 CET 2018)

  • stable community x86_64: 862 new and 784 removed package(s)
  • stable core x86_64: 28 new and 26 removed package(s)
  • stable extra x86_64: 275 new and 262 removed package(s)
  • stable multilib x86_64: 13 new and 17 removed package(s)

A detailed list of package changes can be found here.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.

My mouse is jittering like hell!

Seems the new libinput update created some issues with some touchpads. If our new kernel updates don't solve the issue for you, you may think about downgrading libinput instead, until upstream found a proper solution for you:

sudo pacman -U https://archive.archlinux.org/packages/l/libinput/libinput-1.9.4-1-x86_64.pkg.tar.xz

xorgproto, libxfont, can't remove... what?

Refresh your mirrors and try the update again. This package conflict should be resolved.

Otherwise, say Yes to replace all the "proto" packages with xorgproto. If it wants to remove any packages, STOP, and run

sudo pacman-mirrors -f 3
sudo pacman -Syyu

KDE Global Menu on all my windows

Check System Settings -> Application Style -> Window Decorations -> Buttons.

Make sure global menu widget is removed from the Titlebar, for some reason it was added in 5.12 when the global menu setting option was removed.

KDE remove green separator line between Titlebar and Window

System Settings>Application Style>Window Decorations>Breeze>Settings Icon
Turn off “Draw separator …”

On KDE my external drives don't get automounted when I plugged them in

As a workaround put into the KDE/Plasma autostart the program udiskie (just plain like that), after you had installed it. A re-login may be needed to get it active. As alternative start it manually for your current session.

My system won't boot anymore after this update

Most likely you are using a freetype2 package from the AUR. Due the harfbuzz update, your system is broken. So either install the official supported freetype2 package from our repositories or downgrade to harfbuzz v1.7.4: sudo pacman -U https://archive.archlinux.org/packages/h/harfbuzz/harfbuzz-1.7.4-1-x86_64.pkg.tar.xz

You might try also try Freetype2-ultimate5 — fonts like in Infinality's ultimate5 which is a maintained package.

I get "error: command failed to execute correctly" during a GRUB update

Run sudo update-grub once more to ensure the command has worked correctly.

GNOME shell crashes

It's probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it's when inserting USB drives, disable "Places Status Indicator".

Font-Shadow issue within XFCE

Switch to another theme (e.g. Arc Maia), or execute the following cmd to fix the issue:

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool -s false

This fixes the issue properly. (Can follow the links from Ask-Ubuntu #801478 to what exists for the xfce documentation.)

After the command is run the entry <property name="center-text" type="bool" value="false"/> is created under "desktop-icons" in /home/[user]/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.

Firefox 58 won't open

Please check this thread:

I don't see any updates

That's because your mirror is out of date. It can take several hours before a mirror get updated. If you want updates right now, run these commands :

sudo pacman-mirrors -f 3
sudo pacman -Syyu

You can always check the state of every mirrors here.

I get a black screen on boot or something doesn't work

That's probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.

An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.

An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).

Manual intervention for Gnome,Budgie and Mate:

Because the default icons set has changed from arc-maia to papirus-maia, you need to install papirus-maia-icon-theme manually. Otherwise, fallback icons ( for example, adwaita ) might be used instead.

conflicting files: zita-resampler: /usr/lib/libzita-resampler.so.1 already exists in filesystem

Some users got this error when they tried to update their system. If you have this message, remove /usr/lib/libzita-resampler.so.1 manually before updating.


liquid smooth update here on KDE!

thanks for your hard work :kissing_heart:


another day in (Manjaro)Paradise :sunglasses:



I got this warning message before I updated. Is it anything to be worried about?

Not really.

It's just saying that mhwd will be updated before mesa for some reason. :slight_smile:

1 Like

upgrade done ,
always trouble after longin Xfce , Windows Manager doesn't appears with option metamodes + full Composition on , i have to do
Ctrl+Alt+F2 then Ctrl+Alt+F7

How do you start ForceFullComposition?

with nvidia-settings

I'm doing it with a bash-script starting 3 seconds after login. Worth a try?

i think this not really the solution

  • i have checked nvidia-smi , PM is caped
  • come from nvidia-settings , so if it doesn't appears on login , nvidia has changed something

Too bad, it was an attempt.

Still 17.1.5 ISOs linked.


please help me, after the update before this one, Manjaro won't boot anymore. I expected this update to fix it but no it didn't. I tried downgrading harfbuzz to v1.7.4-1, it didn't help. I have freetype2 from extra. I also tried freetype2-ultimate5 it didn't work either. There are no error messages.

Update without problems Manjaro Gnome. When restarting the theme of the icons was changed, but I put again the theme that comes by default with Manjaro

Thanks for Manjaro!!!

Powered by Google translator :sweat_smile:

well, they are there:

Just not certain they are the final ones yet. :slight_smile:
XFCE and KDE are there. Gnome not yet.

Smooth update on 2 KDE machines, with the terminal. Thanks !

I think that KDE files were mixed with XFCE files? @philm

This Error still exists after systemd package updated.

Manjaro Team, THANKS for your work! Smooth update, all OK!:clap:

Forum kindly sponsored by