[Stable Update] 2018-03-14 - Kernels, Browsers, KDE, Vulkan, Python, Haskell

Hi community,

welcome to another stable update of Manjaro. We added the latest KDE, renewed most of our kernels and some browsers plus added the latest Vulkan stack. Additionally we added regular upstream updates as usual.

Here is the list of changes in more details:

  • We updated some of our browsers
  • We updated some of our kernels
  • We added the latest KDE Plasma
  • We added the latest KDE Apps
  • We added the latest Vulkan support
  • we upgraded dbus.
  • We added regular upstream updates like Foomatic-DB, Haskell and Python

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.

Current supported Kernels

  • linux316 3.16.55
  • linux318 3.18.98 [EOL]
  • linux41 4.1.50
  • linux44 4.4.120
  • linux49 4.9.86
  • linux414 4.14.25
  • linux415 4.15.8
  • linux416 4.16-rc4
  • linux-RT-LTS 4.14.24_rt19
  • linux-RT 4.14.24_rt19

Package Updates (Sun Mar 11 09:15:16 CET 2018)

  • stable community x86_64: 649 new and 621 removed package(s)
  • stable core x86_64: 15 new and 15 removed package(s)
  • stable extra x86_64: 464 new and 462 removed package(s)
  • stable multilib x86_64: 11 new and 11 removed package(s)

A detailed list of all changes can be found here.

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:



Known issues and solutions

This is a wiki post; please edit as necessary.

My mouse is jittering like hell!

Seems the new libinput update created some issues with some touchpads. If our new kernel updates don't solve the issue for you, you may think about downgrading libinput instead, until upstream found a proper solution for you:

sudo pacman -U https://archive.archlinux.org/packages/l/libinput/libinput-1.9.4-1-x86_64.pkg.tar.xz

xorgproto, libxfont, can't remove... what?

Refresh your mirrors and try the update again. This package conflict should be resolved.

Otherwise, say Yes to replace all the "proto" packages with xorgproto. If it wants to remove any packages, STOP, and run

sudo pacman-mirrors -f 3
sudo pacman -Syyu

KDE Global Menu on all my windows

Check System Settings -> Application Style -> Window Decorations -> Buttons.

Make sure global menu widget is removed from the Titlebar, for some reason it was added in 5.12 when the global menu setting option was removed.

KDE remove green separator line between Titlebar and Window

System Settings>Application Style>Window Decorations>Breeze>Settings Icon
Turn off “Draw separator …”

On KDE my external drives don't get automounted when I plugged them in

As a workaround put into the KDE/Plasma autostart the program udiskie (just plain like that), after you had installed it. A re-login may be needed to get it active. As alternative start it manually for your current session.

My system won't boot anymore after this update

Most likely you are using a freetype2 package from the AUR. Due the harfbuzz update, your system is broken. So either install the official supported freetype2 package from our repositories or downgrade to harfbuzz v1.7.4: sudo pacman -U https://archive.archlinux.org/packages/h/harfbuzz/harfbuzz-1.7.4-1-x86_64.pkg.tar.xz

You might try also try Freetype2-ultimate5 — fonts like in Infinality's ultimate5 which is a maintained package.

I get "error: command failed to execute correctly" during a GRUB update

Run sudo update-grub once more to ensure the command has worked correctly.

GNOME shell crashes

It's probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it's when inserting USB drives, disable "Places Status Indicator".

Font-Shadow issue within XFCE

Switch to another theme (e.g. Arc Maia), or execute the following cmd to fix the issue:

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool -s false

This fixes the issue properly. (Can follow the links from Ask-Ubuntu #801478 to what exists for the xfce documentation.)

After the command is run the entry <property name="center-text" type="bool" value="false"/> is created under "desktop-icons" in /home/[user]/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.

Firefox 58 won't open

Please check this thread:

Firefox 59 displays only in English

To solve the issue please do the following:

sudo sed -i '/matchOS/a pref("intl.locale.requested","");' /usr/lib/firefox/browser/defaults/preferences/vendor.js

I don't see any updates

That's because your mirror is out of date. It can take several hours before a mirror get updated. If you want updates right now, run these commands :

sudo pacman-mirrors -f 3
sudo pacman -Syyu

You can always check the state of every mirrors here.

I get a black screen on boot or something doesn't work

That's probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.

An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.

An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).

Manual intervention for Gnome,Budgie and Mate:

Because the default icons set has changed from arc-maia to papirus-maia, you need to install papirus-maia-icon-theme manually. Otherwise, fallback icons ( for example, adwaita ) might be used instead.

conflicting files: zita-resampler: /usr/lib/libzita-resampler.so.1 already exists in filesystem

Some users got this error when they tried to update their system. If you have this message, remove /usr/lib/libzita-resampler.so.1 manually before updating.

No kernel 4.14.24-1-MANJARO headers. You must install them to use DKMS!

Install the missing linux414-headers package


Firefox 59 doesn't pick internationalization correctly. To fix this:

  • open about:config
  • add a new string entry named intl.locale.requested
  • leave the value empty to use system locale (if i18n package is installed), use the locale code explicitly if needed (like fr, es, etc.)



The german language pack doesn't work.
On https://bbs.archlinux.org/viewtopic.php?pid=1773834#p1773834 I found a workaround:

there is a workaround :

  • type "about:config" in the url bar
  • create a new key "intl.locale.requested", the value must be the language code (for example "fr" for french)
  • restart firefox

No issues noticed, XFCE edition. Have found no issue with Firefox language, but my system is set to English language.

or for firefox 59 international

sudo sed -i '/matchOS/a pref("intl.locale.requested","");' /usr/lib/firefox/browser/defaults/preferences/vendor.js

not use the locale code explicitly (like fr, es, etc.)

1 Like

No issues, updating KDE edition with the command line on 2 machines (But I don't use Firefox anymore :innocent:)

Thank you very much, another smooth update

KDE, kernel 4.14, mesa, radeon, Chromium.

Updated, only with the Firefox 59 language issue, which got fixed by the command in the wiki post. :slight_smile:

@philm i got a syntax error if i used your solution in "Firefox 59 displays only in English". I fix it by replacing the quotation marks:

sudo sed -i '/matchOS/a pref("intl.locale.requested","");' /usr/lib/firefox/browser/defaults/preferences/vendor.js

1 Like

Yes, I can confirm that works, and @poly don't miss the "s" of "defaults" :slight_smile:

1 Like

Oh, you are right, thanks :sweat_smile:

Thinkpad T60 Intel T5500
after a quick test: everthing works fine

1 Like

Updated, with the Firefox 59.0 language issue, fixed by the wiki !

I get this message during installation

No kernel 4.14.24-1-MANJARO headers. You must install them to use DKMS!

what does it mean?

you need linux414-headers installed would be my initial thoughts on the matter

1 Like

I am still waiting Manjaro 17.1.7😅

updates went fine on my machines, I also grabbed the updated intel-microcode from the link you kindly posted in the other thread @philm and that's also working fine to for my i3-3110m powered notebook.

No issues here on KDE besides the FF-Locale (intl.locale.requested) thing, thanks team! :smiley:

You can get the latest ISOs from here ...


Forum kindly sponsored by