[Stable Update] 2018-05-07 - Kernels, Mesa, Glibc, PHP, Nvidia, Plasma5, Firefox

Hi community,

welcome to another stable update of Manjaro. Mostly we worked the past days on our toolchain. Please read our Troubleshooting guide for more details.

Other changes are:

  • updating Pamac, which fixes an issue unable to close a mirrorlist generation and shows now a progressbar during updates checking
  • more JADE updates
  • updated Kernels
  • added BFQ scheduler to kernel series v4.16 and v4.17
  • most of our kernels got updated and include bluetooth and wifi fixes
  • latest PHP
  • added Mesa v18.0.2
  • added Plasma v5.12.5
  • updated qemu to v2.12.0
  • adjustments to our gnome-settings
  • updated Nvidia driver to v396.24. Users of Fermi cards should read our troubleshooting guide, as support for their cards got dropped by this driver!
  • added Nvidia 390xx legacy drivers
  • added needed changes for nvidia-390xx to mhwd
  • latest Firefox Development Edition is now at v61-beta2
  • updates to Vertex theme
  • updates to MS-Office-Online launcher
  • trizen as AUR helper added
  • fixes to Compiz
  • some more Cinnamon updates
  • users of Hyper may need to "downgrade" to the stable version, as we removed the epoch
  • usual upstream updates

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.

Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.108 [EOL]
  • linux41 4.1.51
  • linux44 4.4.131
  • linux49 4.9.98
  • linux414 4.14.39
  • linux415 4.15.18 [EOL]
  • linux416 4.16.7
  • linux417 4.17-rc3
  • linux414-rt 4.14.39_rt29
  • linux416-rt 4.16.7_rt1

Package Updates (Mon May 7 06:47:32 CEST 2018)

  • stable community x86_64: 824 new and 775 removed package(s)
  • stable core x86_64: 49 new and 46 removed package(s)
  • stable extra x86_64: 346 new and 333 removed package(s)
  • stable multilib x86_64: 32 new and 28 removed package(s)

A detailed list of changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


This is a wiki post; please edit as necessary.

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

Polkit break under plasma

After the change done in filsystem 2018.1-3 there is possible breakage with polkit policy files not applied as the PATH environment variable are not the same.

to correct this just edit the file


and remove the following lines in the [users] group

-# Default $PATH

It's also possible to have other weird problems in some scripts because of this


Everything's working well. Thanks for the update.

CPU: 6-Core AMD FX-6350 (-MCP-) speed: 3987 MHz Kernel: 4.16.7-1-MANJARO x86_64 Display: x11 server: X.Org 1.19.6 driver: ati,radeon unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz, 1280x1024~60Hz OpenGL: renderer: AMD PITCAIRN (DRM 2.50.0 / 4.16.7-1-MANJARO LLVM 6.0.0) v: 4.5 Mesa 18.0.2

18 posts were split to a new topic: Automatic migration from nvidia to nvidia-390xx

I have a problem:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Warning: could not fully load metadata for package js52-52.7.3-1

Failed to prepare transaction:
invalid or corrupted package


Relaunch updates. It will autofix it :slight_smile:


I had the same error updating with Pamac.
Then I updated with sudo pacman-mirrors -f 3 and sudo pacman -Syyu and everything went fine. Go figure?


error(?) description in new package openbox-themes-extra

pacman -Si openbox-themes-extra | grep ^Des
Description     : Openbox Themes by Cybercop <echo Y3liZXJjb3BfbW9udGFuYUBhYnYuYmc= | base64 -d>

ok is encode email :roll_eyes: it's legal to use bash here ?

As @swami suggests use the terminal .

sudo pacman-mirrors -f 3


sudo pacman-mirrors -g


sudo pacman -Syyu


2 same package cups-filters-driverless in repos ?

pacman -Ss cups-filters-driverless
extra/cups-filters-driverless 1.20.1-2
    OpenPrinting CUPS Filters
community/cups-filters-driverless 1.20.3-1
    OpenPrinting CUPS Filters

mirror.netzspielplatz.de after -Syyu

js52 conflict resolved here as well. Trouble free update. Thanks to the devs and maintainers.
Host: orphaned-inode Kernel: 4.14.39-1-MANJARO x86_64 bits: 64
Desktop: Xfce 4.12.4 Distro: Manjaro Linux 17.1.9 Hakoila
Type: Desktop Mobo: ASUSTeK model: TUF Z270 MARK 1 v: Rev 1.xx serial: N/A
UEFI [Legacy]: American Megatrends v: 1203 date: 12/25/2017
Topology: Quad Core model: Intel Core i7-7700 bits: 64 type: MT MCP
L2 cache: 8192 KiB
Speed: 4093 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4094 2: 4091
3: 4184 4: 4071 5: 4097 6: 4100 7: 4193 8: 4100
Card-1: NVIDIA GK208 [GeForce GT 730] driver: nvidia v: 396.24
Display: x11 server: X.Org 1.19.6 driver: nvidia
resolution: 1366x768~60Hz, 1366x768~60Hz, 1366x768~60Hz
OpenGL: renderer: GeForce GT 730/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24

No issues XFCE.

I would strongly suggest all newer users be careful when merging pacnew files, especially on some of the files like groups and shadow as you could potentially lock yourself out of your system.

I’d strongly recommend a tool like “meld” to view the old file and new sidebyside so you can safely merge the needed changed without “killing” your system.


These are all the pacnew files to examine.

/etc/fstab.pacnew **
/etc/group.pacnew **
/etc/gshadow.pacnew **
/etc/passwd.pacnew **
/etc/shadow.pacnew **

The ones marked ** should be merged with extreme caution by new users.


Sage advice! And meld is very good.
There are a bunch of pacnew files. I'm going to go at them in the morning.

I had a problem with my external monitor after switching to the Nvidia-390 drivers, as it overwrote my configuration, but I got it working again after reapplying my changes.

I run XFCE.
Haven't applied today's update yet.
What does your post mean for a relative n00b like me? I'm not sure what a pacnew file is, though I did see a samba one after the last update.
I don't wanna kill my sytem.

Have a good read of this...


If in doubt still, i'd suggest opening a new thread about it.

Last packager? Maybe i m not At pc.. I have ever put into extra.. Possible mistake..

Ok 101 packages for 700Mo updated on Xfce

for theses pacnew

SUPPRESS them or you you will broken your linux


Not true. I’ve merged ALL changes, even if the change was only a comment on three systems now and currently doing a fourth.

All working fine after the merge. You just have to be careful and know what you’re doing. Not replacing any of your existing settings.

1 Like

have you shutdown an reboot ?
have you checked in journal ?

Forum kindly sponsored by