[Stable Update] 2018-06-07 - Kernels, Systemd, Pamac, Octopi, Rebuilds

And the answer was given a few posts above


You can downgrade previous version of Linux Kernel. To do that you need Live USB and use chroot to downgrade a package on your Linux which is installed on your PC as a root.

After this update, nothing works for me. I can not start Manjaro and fix errors.
More details here: Boot failure. PC does not start

To the people who are having problem with their pip like me, I found this fix in the Arch forums. It fixed my problem, so I guess it's worth a try in your case.

The unfortunate thing is I did follow the answer given above (the one that said delete said conflicting files) but while it did allow the install to continue, pip just crashes on run. So this is the fix that did the trick for me (run at your own risk, but it did work in my case):

sudo rm -rf /usr/lib/python3.6/site-packages/pip /usr/lib/python3.6/site-packages/pkg_resources
sudo pacman -Syu python-setuptools python-pip

The Arch Forum topic in question is https://bbs.archlinux.org/viewtopic.php?id=237451

I wish you a good day :slight_smile:


All works fine here - thanks to the manjaro - team :grinning:

System:    Host: manjaro64 Kernel: 4.17.0-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.12.5 
           Distro: Manjaro Linux 17.1.10 Hakoila 
Machine:   Type: Desktop Mobo: MEDIONPC model: MS-7728 v: 2.0 serial: <filter> BIOS: American Megatrends 
           v: E7728MLN.208 date: 08/15/2011 
CPU:       Topology: Quad Core model: Intel Core i7-2600 bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 1597 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1596 2: 1596 3: 1597 4: 1596 5: 1596 
           6: 1596 7: 1596 8: 1596 
Graphics:  Card-1: NVIDIA GF116 [GeForce GT 545] driver: nvidia v: 390.59 
           Display: x11 server: X.Org 1.19.6 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GT 545/PCIe/SSE2 v: 4.6.0 NVIDIA 390.59 
Audio:     Card-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel 
           Card-2: NVIDIA GF116 High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.17.0-1-MANJARO 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    HDD Total Size: 465.77 GiB used: 15.38 GiB (3.3%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
Partition: ID-1: / size: 220.44 GiB used: 15.38 GiB (7.0%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A gpu: nvidia temp: 45 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 26% 
Info:      Processes: 239 Uptime: 2m Memory: 7.77 GiB used: 1.32 GiB (17.0%) Shell: bash inxi: 3.0.10 


There seems to be many reports of unbootable systems with "UUID not found" errors (though the fstab is correct) :

EDIT: Maybe a problem with kernel 4.9 update? @philm

More evidence...

1 Like

Everything went well, I am using Gnome and 4.16. As a few others noted, my total download size was double what it should have been. I forgot to screen shot the logs, but it looked like it downloaded and installed each package twice. Everything worked in the end, but I think there was more downloading/installing than requried for some reason.

skweresp, same issue on the user configured wallpapers, open the image and right click "Set as
Wallpaper" and the image comes up. You'll lose the log out screen, again right click and use the
listed command.

no issues on KDE - thanks again, team...you're awesome! :smiley:

1 Like

I am also having python pip issues. I installed pip to install sublime text. Don't know what to do next. Should I update or not.

Ok. I installed after trying orthocube post and it worked.

1 Like

I can see in a glance that only few had issues and nobody any serious one.
Then all these Not Booting issues were on Testing or Stable.
And why an experienced user even ask for help on standard kernel failures or booting?..

Just joking.. :grin:

Update pip, nodejs, npm, etc. via pacman instead of using their self-update functions. Before installing packages via the aforementioned managers, search the repos and the AUR . If you don't find what you're looking for, create a PKGBUILD and install it that way.


I guess @philm has already been onto this 4.9 kernel breakage

4.9.106-1 MANJARO x64

It hit a bunch of users.

my system didn't boot after the update using kernel 4.9
So i booted from an older kernel (4.4) which i fortunately still had installed. This worked fine. I then installed newer 4.14 kernel which also works.
If you had similar problems, starting an older kernel may be worth a try.

This was the first issue from updates i had since i use Manjaro (1.5 years) and i hope its the last one. I'm a relatively experienced Linux user, but if this happens to a beginner, he/she will be lost.


If the new grub update hit the stable branch and users recklessly merged the grub.pacnew file with their existing luks-specified grub config, they would indeed be in trouble. I asked this earlier but didn't get anything.

that's why i always keep some kernels installed ^^

1 Like

I was also no longer able to boot with the new 4.9 kernel.

Some reported that v4.9.106 has some issues like <module> likely not compiled with -mcmodel=kernel. That exact kernel has only gcc8 fixes in this release.

@willi li: You may chroot into your installed system and install linux414 to see if that helps you out.

Please stop using that and/or spreading it. -g is old.. the preferred method is -f
-f0 for all and say -f5 for 5 functioning mirrors.
Seems -g was eventually kept and fixed.. but still.
@linux-aarhus can you illuminate this better please?

1 Like

Everything works OK, thank you so much!

Forum kindly sponsored by