[Stable Update] 2018-06-07 - Kernels, Systemd, Pamac, Octopi, Rebuilds

I guess @philm has already been onto this 4.9 kernel breakage

4.9.106-1 MANJARO x64

It hit a bunch of users.

my system didn't boot after the update using kernel 4.9
So i booted from an older kernel (4.4) which i fortunately still had installed. This worked fine. I then installed newer 4.14 kernel which also works.
If you had similar problems, starting an older kernel may be worth a try.

This was the first issue from updates i had since i use Manjaro (1.5 years) and i hope its the last one. I'm a relatively experienced Linux user, but if this happens to a beginner, he/she will be lost.


If the new grub update hit the stable branch and users recklessly merged the grub.pacnew file with their existing luks-specified grub config, they would indeed be in trouble. I asked this earlier but didn't get anything.

that's why i always keep some kernels installed ^^

1 Like

I was also no longer able to boot with the new 4.9 kernel.

Some reported that v4.9.106 has some issues like <module> likely not compiled with -mcmodel=kernel. That exact kernel has only gcc8 fixes in this release.

@willi li: You may chroot into your installed system and install linux414 to see if that helps you out.

Please stop using that and/or spreading it. -g is old.. the preferred method is -f
-f0 for all and say -f5 for 5 functioning mirrors.
Seems -g was eventually kept and fixed.. but still.
@linux-aarhus can you illuminate this better please?

1 Like

Everything works OK, thank you so much!

It does something else now.

  -g, --geoip 

It is better to use sudo pacman-mirrors -f 3???
Always use the command with -g, I did not know what better with -f


pacman-mirrors --help

Yes - as it always was - which was problematic because it didnt face validity of mirror checks. I assume since it still exists that it was fixed. We had a long thread on bughunting about it some while back.
I just want verification that it is safe once again, as we even moved all the wiki to -f and so on.

Stop using pip to perform updates. Pacman is the only way you should be updating your system. If you use pip you are going to have problems. You are creating the issue yourself.

1 Like

I am not able to boot into the system after this update.

As others have reported earlier,

module 'scsi_mod' likely not compiled with -mcmodel=kernel

The same message appears for module usbcore as well.
Then it says
device 'UUID=..............................' not found. Skipping fsck.
You are now being dropped into an emergency shell.
sh: can't access ttu: job control turned off

How do get the system back?

Try the solution by @benob here, it worked for me:


1 Like

Thank you very much. @adamb
Downgraded the kernel
4.9.106-1 ---> 4.9.105-1
as per the instructions by @benob and I am able to login to the system.
Will wait till the issue is resolved.

Sublime Text is in the AUR. I recommend trizen AUR helper also.

Thanks for the clarification. I learned my lesson :slight_smile: I never knew I wasn't supposed to install things outside pacman, but thanks to the first and latest update problem I got (which fortunately, I was able to fix, I think), I'll never touch installs anywhere outside pacman and yaourt--thanks!

1 Like

Another non-booting system:

It seems we need people in testing who are running older kernels? :thinking:

Forum kindly sponsored by