[Stable Update] 2018-06-07 - Kernels, Systemd, Pamac, Octopi, Rebuilds

It is better to use sudo pacman-mirrors -f 3???
Always use the command with -g, I did not know what better with -f

Sorry

pacman-mirrors --help

Yes - as it always was - which was problematic because it didnt face validity of mirror checks. I assume since it still exists that it was fixed. We had a long thread on bughunting about it some while back.
I just want verification that it is safe once again, as we even moved all the wiki to -f and so on.

Stop using pip to perform updates. Pacman is the only way you should be updating your system. If you use pip you are going to have problems. You are creating the issue yourself.

1 Like

I am not able to boot into the system after this update.

As others have reported earlier,

module 'scsi_mod' likely not compiled with -mcmodel=kernel

The same message appears for module usbcore as well.
Then it says
device 'UUID=..............................' not found. Skipping fsck.
You are now being dropped into an emergency shell.
sh: can't access ttu: job control turned off
[rootfs]#

How do get the system back?

Try the solution by @benob here, it worked for me:

https://archived.forum.manjaro.org/t/system-not-booting-after-update-error-device-uuid-id-not-found-skipping-fsck-dropped-into-emergency-shell/49251/6

1 Like

Thank you very much. @adamb
Downgraded the kernel
4.9.106-1 ---> 4.9.105-1
as per the instructions by @benob and I am able to login to the system.
Will wait till the issue is resolved.

Sublime Text is in the AUR. I recommend trizen AUR helper also.

Thanks for the clarification. I learned my lesson :slight_smile: I never knew I wasn't supposed to install things outside pacman, but thanks to the first and latest update problem I got (which fortunately, I was able to fix, I think), I'll never touch installs anywhere outside pacman and yaourt--thanks!

1 Like

Another non-booting system:

It seems we need people in testing who are running older kernels? :thinking:

@philm
new kernel version for 4.9 , this will correct 106 ?
https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.107

Seems not. The issue might be in introduced gcc8 ports by v105. Seems a git-bisect is in order and informing Greg about it. It all points to an similar issue from the past. This might help ...


It can also be this. It should fix the similar issue for mips64, but might had added a regression to x64.

1 Like

I can try :slight_smile:

Default pacman-mirrors

No matter how you use pacman-mirrors it will use up-to-date mirrors in the mirror list.

-g/--geoip will use mirrors from the users country and if the country has no mirrors it will fallback to the default mirror pool - still only up-to-date mirrors.

Custom mirror pool

-c/--country and -i/--interactive creates a custom mirror pool

Time taken to probe mirrors

The probing of the mirror pool can take some time depending on the pool's actual size, which depends on 1) the mirror pool's size 2) the number of mirrors marked as up-to-date (status.json). As you will notice on the web repo page that number can vary a great deal depending on the mirrors sync schedule.

Limit the time taken

The probing of mirrors response brings us to -f/--fasttrack <number> where the number limits how many mirrors are probed. If no number is given then 0 is assumed which means the entire pool.

Override default

If a user wants to probe the mirror pool with no regard to the mirrors actual update status - this is possible using a -s/--no-status argument to completely ignore a mirrors up-to-date status. This of course cannot be combined with -f.

Conclusion

ONLY IF a user's country has no mirrors THEN -g/--geoip acts as -f/--fasttrack.

8 Likes

Updated yesterday, everything worked as normal, shutdown normally in the evening, booted today:
I'm getting a weird theme mix with adapta and papirus-icons.


Do you have XFCE with GTK2 or GTK3 packages. On my end I also have sometimes those theme mixes with GTK3 version of XFCE.

I have the gtk3 packages that came with a manjaro-architect install.

Edit:
I should probably also mention that changing themes in the theme manager doesn't do anything.

@anon67574254: please check your /var/pacman.log on which packages got updated. Sometimes it helps to log out and re-login to fix the theming. We are working on the issue.

1 Like

Logging out and back in indeed fixed it. Thank you!
Strangely, I tried rebooting before (kind of the first thing I always do...) and it did nothing.

Update on 12 Machines and 1 VB without Problems.

DK3

1 Like

Forum kindly sponsored by