[Stable Update] 2018-06-07 - Kernels, Systemd, Pamac, Octopi, Rebuilds

Keeping prior kernel versions around is a good idea so you can select them at boot time in cases like this.

There are 144 updates on my Gnome using 14.4 kernel LTS. Only several packages can updates using Pamac. So, it's not finished. Pamac notifier still checking. Then I ran update via Terminal, "sudo pacman -Syyu", so all packages downloaded and installed successful.

It is useful to set the "backup" kernels as ignorepkg in pacman.conf to have them in a known good state.

1 Like

@willi and @hoobastank, solution probably is given here (also mentioned here, different kernel than 4.9 may work):

Everything went fine, except sometimes I get this error on kernel 4.17 and I am unable to reboot. Weird.

IMG_20180609_103506

xps9550, KDE,linux44, update OK

Both 64-bit KDE installs updated without any issues. Now running 4.17 release builds on these two systems. Both behaving as expected. I'll update the desktop Inxi output in due course, none of the hardware has changed though.

After updating to kernel 4.17.0-1 LID0 doesn’t wake up laptop after suspend. In order to wake up the laptop I have to type any key or use the mouse.
After going back to kernel 4.14.48-1 the laptop wakes up when opening the lid.

Regards,
ulusu

Is it possible to download and install a package for version 396.24.02 of the linux414-nvidia driver? 396.24 has a tesselation bug that breaks some games (Fallout 4).

I managed to fix the issue we had with linux49. Fixed package is uploaded to our testing branch.

6 Likes

I finally undestand how to show "relevant" warnings :
so with -p4 I get :

$journalctl -b-1 -p4
.
.
.
iun 09 23:26:06 flow-pc plasmashell[826]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_00_1b.0.analog-stereo"
iun 09 23:26:06 flow-pc plasmashell[826]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_00_1b.0.analog-stereo.monitor"
iun 09 23:26:06 flow-pc plasmashell[826]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_00_1b.0.analog-stereo"
iun 09 23:26:06 flow-pc plasmashell[826]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_00_1b.0.analog-stereo.monitor"
iun 09 23:26:06 flow-pc plasmashell[826]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_00_1b.0.analog-stereo"
iun 09 23:26:06 flow-pc plasmashell[826]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_00_1b.0.analog-stereo.monitor"
iun 09 23:26:06 flow-pc kwin_x11[813]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 12882, resource id: 31457982, major code: 18 (ChangeProperty), minor code: 0
iun 09 23:26:06 flow-pc kwin_x11[813]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 12883, resource id: 31457294, major code: 15 (QueryTree), minor code: 0
iun 09 23:26:06 flow-pc kwin_x11[813]: QXcbConnection: XCB error: 3 (BadWindow), sequence: 12906, resource id: 31457330, major code: 15 (QueryTree), minor code: 0
iun 09 23:26:15 flow-pc ksmserver[784]: ksmserver: SmsDie timeout, client  "/bin/kwin_x11" ( 1093dcd277000152857547100000007840006 )
iun 09 23:26:15 flow-pc ksmserver[784]: ksmserver: SmsDie timeout, client  "/bin/doublecmd" ( 1093dcd277000152857547100000007840010 )
iun 09 23:26:15 flow-pc kwin_x11[813]: Cannot clear shadow from window without native surface!
iun 09 23:26:20 flow-pc ksmserver[784]: ksmserver: SmsDie WM timeout
iun 09 23:26:20 flow-pc sddm[579]: Authentication error: "Process crashed"
iun 09 23:26:20 flow-pc sddm[579]: Auth: sddm-helper crashed (exit code 15)
iun 09 23:26:20 flow-pc sddm[579]: Authentication error: "Process crashed"
iun 09 23:26:20 flow-pc sddm[579]: Auth: sddm-helper exited with 15
iun 09 23:26:20 flow-pc kactivitymanagerd[1031]: The X11 connection broke (error 1). Did the X11 server die?
iun 09 23:26:20 flow-pc kglobalaccel5[757]: The X11 connection broke (error 1). Did the X11 server die?
iun 09 23:26:20 flow-pc kscreen_backend_launcher[869]: The X11 connection broke (error 1). Did the X11 server die?
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc NetworkManager[473]: <warn>  [1528575980.6498] error requesting auth for org.freedesktop.NetworkManager.wifi.share.protected: Authorization check failed: Refusing activation, D-Bus is shutting down.
iun 09 23:26:20 flow-pc NetworkManager[473]: <warn>  [1528575980.6502] error requesting auth for org.freedesktop.NetworkManager.wifi.share.open: Authorization check failed: Refusing activation, D-Bus is shutting down.
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: QDBusAbstractAdaptor: Cannot relay signal KDEDModule::moduleDeleted(KDEDModule*): Pointers are not supported: KDEDModule*
iun 09 23:26:20 flow-pc kdeinit5[739]: The X11 connection broke: I/O error (code 1)
iun 09 23:26:20 flow-pc nmbd[573]: [2018/06/09 23:26:20.847696,  0] ../source3/nmbd/nmbd.c:58(terminate)
iun 09 23:26:20 flow-pc nmbd[573]:   Got SIGTERM: going down...
iun 09 23:26:21 flow-pc kernel: nouveau 0000:08:00.0: bus: MMIO write of ffff971f FAULT at 6013d4 [ IBUS ]
iun 09 23:26:21 flow-pc kernel: nouveau 0000:08:00.0: bus: MMIO read of 00000000 FAULT at 50405c [ IBUS ]
iun 09 23:26:22 flow-pc sddm[579]: Signal received: SIGTERM
iun 09 23:26:22 flow-pc sddm-helper[2329]: gkr-pam: no password is available for user
iun 09 23:26:23 flow-pc sddm[579]: QProcess: Destroyed while process ("/usr/lib/sddm/sddm-helper") is still running.
iun 09 23:26:24 flow-pc kernel: watchdog: watchdog0: watchdog did not stop!
iun 09 23:26:24 flow-pc kernel: systemd-shutdow: 38 output lines suppressed due to ratelimiting

can you point me in the right direction, or the next step ?

PS : I also updated to 4.17.0-1. The shutdown is now down to 20 is seconds...so it's a little better.

XFCE on 4.14.48-1 - Everything went great!

I'm not being critical of your suggestion, but on a rolling distro is this recommended. Partial updates are not supported after all.

If you are not using the kernel then it is completely fine. Just remember to also list virtualbox modules and other kernel addon packages you might be using.

1 Like

I am also having the same issues as many others with 'resume hibernation device not found' on my daughters computer. So far I haven't solved it as the computer no longer boots off a dvd. I'm just about to try a USB and follow others solutions.

followed the instructions and updated to the newest version. Everything's fine again.

Thank you!

After today's update I see only one wallpaper

After update I'm experiencing issues with suspend on both of my thinkpads (T520 and X230).

On kernel 4.17 and 4.14 laptops usually:

  • don't suspend
  • do it really slowly
  • don't suspend when lid is closed but do after it's opened
  • sometimes they suspend without any problem.

It's not a priority for me but I just wanted to know if someone else is experiencing similar problem.


Update Jun 23:
Weird, it stopped happening after couple days. Now it's OK.

me too...fixed it temporary with pulling then ac plug and then close the lid...then the symptoms are gone somehow...i am on unstable

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by