[Stable Update] 2018-07-22 - Kernels, KDE, Gnome, Deepin, Mesa, Browsers, PHP

Hi community,

Welcome to another stable update. So what do we have with this one?

  • Pamac got an enhanced cli mode
  • Mesa got updated to v18.1.4 which brings fixes for radeon and intel
  • we added the latest kernels
  • updated some of our themes
  • added some more patches and tweaks to GTK3-Classic
  • Virtualbox got updated to v5.2.16
  • we added the latest point-releases ([1][2]) of PulseAudio v12 series
  • KDE frameworks got updated to v5.48.0
  • KDE got updated with Plasma and Apps
  • added some more Cinnamon, Gnome and Deepin packages
  • Stefano managed to add our new plasma5-theme-adaptabreath theme for KDE
  • we worked mostly on our profile-settings and themes
  • we updated Palemoon and Firefox browsers
  • php got updated
  • python and haskell updates/rebuilds.

We hope with all these changes Manjaro to be more efficient for you all.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:


Our KDE fans may try our beta-build with the latest KDE v5.13 instead.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.115 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.141
  • linux49 4.9.113
  • linux414 4.14.56
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.7
  • linux418 4.18-rc5
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt10

Package Updates (Sat Jul 21 07:13:46 CEST 2018)

  • stable community x86_64: 883 new and 875 removed package(s)
  • stable core x86_64: 28 new and 28 removed package(s)
  • stable extra x86_64: 729 new and 774 removed package(s)
  • stable multilib x86_64: 28 new and 26 removed package(s)

A detailed list of all package changes may be reviewed here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."
If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


Fehler: Konnte Datei /var/lib/pacman/local/libutf8proc-2.1.1-2/files nicht öffnen: Datei oder Verzeichnis nicht gefunden
Warnung: Konnte die Metadaten für Paket libutf8proc-2.1.1-2 nicht vollständig laden

Vorgang konnte nicht erfolgreich vorbereitet werden:
Ungültiges oder beschädigtes Paket


1 Like

pacman -Suy --overwrite usr/lib/libutf8proc.so.2
without this file - update is successful

Hi, smooth update without problems.


but no update frum grub menu...
same old style
how can i fix this?


also with grub custumizer no change from grub menu

maybe this is not a problem from this update.

Redshift problem with accessing Geoclue2 service, preventing application to start


Minor snag:
First time I tried the update it said it couldn't find some dependencies to do the update(!?). When manually refreshing the repos it suddenly wanted to install two python libraries I hadn't had installed before. After that, it worked.

I don't recommend using it, and many will back me up on that. Have you installed one of the grub themes from the extra repo? For instance grub-theme-manjaro or grub-theme-manjaro-dev ...


Similar problem to Beardedgeek72 with "corrupted packet" or other errors while using pamac. When restarting pamac, it asked for 2 python libraries, then is now downloding the update... Strange !
[Edit] Update successfully finished :blush:

1 Like

Oh, one more thing. I know it's a community release, but on my i3wm version, when getting those errors in PAMAC, PAMAC suddenly wasn't floating anymore. It is now, again, after doing the updates but while doing them PAMAC suddenly was tiled for 5 minutes....

After the Stable Update 2018-07-22 all looks good :green_heart:

1 Like

Same for me, first pamac run shows errors refering to libutf8proc.so.2, after closing and restarting pamac and the update went smooth.

Is there anywhere you can see images of these?

There are numerous search tools that you are free to use. grub-customizer has caused quit a few problems. It is not in the Manjaro repositories for a reason.

Oh I believe you. My point is that it doesn't seem like the Manjaro Grub themes you mention are viewable anywhere "official".
Also, as for Grub Customizer: I used it with this installation because GRUB insisted on putting things in the wrong order:
Manjaro i3wm, Windows 10, Manjaro Gnome. I wanted Manjaro i3wm, Manjaro Gnome, Windows 10.
I have used it in the past and it screwed up my GRUB. This time I ONLY changed the menu list order and nothing else and it worked like a charm. Not saying you should endorse it, I'm just saying it seems to work fine as long as you don't start mucking about with anything advanced.

1 Like

I don't know. Here are a few screenshots from VBox:

  1. grub-theme-manjaro

  2. grub-theme-manjaro-dev

There are a few more in extra repo but i didn't test them all ... :slight_smile: Also can be modified if you like, or better cloned and modified, then edit the /etc/default/grub
and then manually sudo update-grub


problem solved:

Glad it worked for you.
Good luck.

Forum kindly sponsored by