[Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python


Most likely I recommend to use sudo pacman -Syyu from within a TTY and not in graphical mode, especially for Gnome. Therefore please initiate a CTRL+ALT+F3 and login with your user in given terminal view to upgrade your system.

Hi community,

Welcome to another stable update. So what do we have with this one?

  • renewed most of our kernels, incl. the L1TF fixes
  • we updated our Xorg-Server to 1.20.1
  • mesa got updated to 18.1.6
  • xf86-video-ati we used the latest git-snapshot to fix some graphical glitches
  • Nvidia 304xx driver is dropped now.
  • Virtualbox got updated to 5.2.18
  • we backported a fix for kscreenlocker reducing the 100% CPU usage
  • we reverted commit 6f130e8 in systemd, which improves network speed
  • we pushed our rebuilds for python 3.7 and perl 5.28.
  • LibreOffice is now at 6.0.6
  • we added the latest MATE packages
  • added some new Deepin packages
  • Stefano updated our Adapta Themes
  • we updated some of our Grub themes
  • we fixed an issue with gpodder
  • updated firefox and thunderbird
  • updated dbus
  • we updated firefox-dev and firefox-kde and jdk8 to their latest versions
  • flameshot got a fix for zh_TW locale loading
  • small fixes to pamac-cli
  • the usual python/haskell rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video (How to activate is described here):


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.119 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.150
  • linux49 4.9.122
  • linux414 4.14.65
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.17
  • linux418 4.18.3
  • linux419 4.19-rc0
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Sat Aug 18 06:46:56 CEST 2018)

  • stable community x86_64: 2965 new and 2912 removed package(s)
  • stable core x86_64: 65 new and 64 removed package(s)
  • stable extra x86_64: 1033 new and 1021 removed package(s)
  • stable multilib x86_64: 22 new and 25 removed package(s)

A list of all changes in details can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

Steam games do not start with primusrun on systems using bumblebee (laptops with hybrid graphics)

This is due to libglvnd being updated to v1.1.0. There are few options:

  • downgrade
  • use PRIME
  • launch Steam with bumblebee using this command: PRIMUS_libGLa=/usr/lib32/libGL.so.1 primusrun steam
  • or wait for the soon incoming nvidia-utils 1:396.54-1; nvidia-390xx-utils 390.77 update that fixes that issue entirely

Also make sure that xf86-input-mouse is not installed.

Items from previous update sets

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


Installing glibc (2.28-4) breaks the dependency "glibc=2.27" required by lib32-glibc

I tried updating at least some programs from the list, but I'm still getting this error in Pamac.

The wiki above has

Changes made to Glibc

but that doesn't seem to help in my case.


updated 230 packages for 1,1Go
i have this error during script install

(213/230) mise à jour de sip                                                                                       [####################################################################] 100%
erreur : la commande n’a pas pu être exécutée correctement

version sip & python-zip was orphans before
i remove with option -Rsn and install then

What is the output on your end for: pacman -Ss glibc | grep core

core/glibc 2.28-4 (base) [installed: 2.27-3]
core/lib32-glibc 2.28-4 [installed: 2.27-3]


No problem except Lightning (add-on thunderbird) which is not compatible with Thunderbird from now on.

@Madis: try with sudo pacman -Syu and if that doesn't work do:

sudo pacman -Sdd glibc lib32-glibc
sudo pacman -Syu

Had the same problem, for some reason updating with pacman rather than with pamac is now running, though I cannot tell why this would make a difference...

1 Like

Update size was 1.8GB on my system (!).
Same issue Madis had (and same pacman -Ss glibc | grep core output) using Pamac but installed without any issue using Octopi.

Will report back if any issues after reboot.

EDIT: All smooth and working well post reboot! :slight_smile:
EDIT 2: If you are using powerline-shell-git from the AUR, you'll need to rebuild it.
EDIT 3: If you are using Lutris from the AUR, you'll need to rebuild it.

So far works fine after a reboot, thanks. Adding the info to wiki.

Mono 5.14 corrupts keepass.

Sorry reinstall keepass and working .

I have problem with RTL2832U after this updates:

Found 1 device(s):
0: , ���|, SN: ����

Using device 0: Generic RTL2832U OEM
usb_open error -3
Please fix the device permissions, e.g. by installing the udev rules file rtl-sdr.rules
Failed to open rtlsdr device #0.

rtl-sdr.rules exist in /usr/lib/udev/rules.d/ but I can't use this as normal user, with sudo is ok.

Maybe this helps. Or this: sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/

It works, but it's strange because this file was created 2 years ago, only name of file is different:
rtl-sdr.rules vs 10-rtl-sdr.rules and worked all time fine till todays updates.

Lightning is now builtin into Thunderbird starting with Thunderbird 60.0.

1 Like

I don't see it... :thinking:

No problems here, i went with pacman on console
Thank you Manjaro Team!



The Calendar is now bundled with Thunderbird by default, although users are given the option of disabling the underlying Lightning extension on first upgrading.

1 Like

The update does not run through:

Conflicting files:
stfl: /usr/lib/libstfl.so.0 exists in filesystem

Does anyone have a fix for this? Should I delete that file?

1 Like

Forum kindly sponsored by