[Stable Update] 2018-08-25 - Kernels, KDE Apps & Framework, Flatpak 1.0, Nvidia, Cleanup

Hi community,

Welcome to another stable update. So what do we have with this one?

  • we updated most of our Kernels
  • we updated our Jade Desktop
  • we updated KDE Apps and KDE Framework
  • flatpak is now at 1.0
  • more qt4 packages got ditched
  • Gimp is now at 2.10.6
  • Ńvidia drivers got fixed in regard of an issue with libglvnd and updated to 396.54
  • we updated our Adapta-Themes
  • latest version of libssh
  • we added lutris to our repos
  • clipit should work again
  • we cleaned up some EOL kernels and unneeded kde-i18n packages
  • the usual upstream rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.119 [EOL]
  • linux44 4.4.151
  • linux49 4.9.123
  • linux414 4.14.66
  • linux417 4.17.18
  • linux418 4.18.4
  • linux419 4.19-rc0
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Fri Aug 24 16:48:16 CEST 2018)

  • stable community x86_64: 460 new and 441 removed package(s)
  • stable core x86_64: 28 new and 33 removed package(s)
  • stable extra x86_64: 518 new and 640 removed package(s)
  • stable multilib x86_64: 24 new and 24 removed package(s)

A complete list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

Items from previous update sets

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


Heh, my little used desktop showed the update, I checked the forum for a post about stable updates, but this post was not yet up. So I figured I'd missed the previous update on this desktop and updated. Then this announcement showed up.

Anyway, updated fine on my desktop, Cinnamon DE, kernel 4.14.

Thanks @philm. I was waiting this update eagerly! Mate? OK. Deepin? The same :slight_smile:

And also, thanks @oberon for deepin wallpapers bugfix :slight_smile:

I can go on holiday into my family and install them both a Manjaro Mate and a Manjaro Deepin :slight_smile:

1 Like

Good update on 3 systems, all XFCE linux44 & linux414.

Update so far so good.

pyqt4-common and python-pyqt4
move to AUR.

I have removed them now and have not noticed anything bad.

Thanks Team!

No notice from pamac, went into Terminal and ran update for mirrors and -Syyu without problems
Xfce with * linux418 4.18.4

No problems on KDE, several packages got moved to aur or abandoned, all could be removed cleanly.

@Ste74: May I ask about the pacnew for /etc/gdm/custom.conf
The only difference is that #WaylandEnable=false has been commented.
Does that mean users with prop. nvidia drivers don't have to use this anymore because there is a different way of handling that, or will I end in the TTY having to uncomment it again if I apply it?

Same results to report. pacman wasn't prompting about the new update even after refreshing mirror list and refreshing the database. Ran update from within terminal via pacman and so far so good. Thanks Manjaro Team!

Same here. Only my virtualbox test machine with deepin shouted about updates to be done with pamac.

If you have manjaro-gdm-check installed is expected because i have closed wayland with property nvidia drivers.. You can check if it work and in this case remove the manjaro-gdm-check..

1 Like

:thinking: Not sure it's that update, but GDM seems to not running anymore at TTY1 after login.

1 Like

I thought it's just me or my pc is doing some vodoo :rofl:
In my case it now runs on TTY2

TTY2 is where my session runs after login (wich is still at TTY1). Thats fine how it is. Just that GDM is now not there anymore after login, is confusing. :joy:

Running Manjaro KDE here. Had an issue during the update. I got a complaint about nvidia-utils and something about a dependency issue. I was running the 4.16 kernel. Removed the 4.16 kernel and retried the update running the 4.14 LTS kernel. Everything went smoothly after that.


XFCE, 4.14.66

Everything went smoothly! Thanks so much for your hard work.

Continuing [Stable Update] 2018-08-18 - Kernels, Xorg-Server, Mesa, Deepin, MATE, Perl, Python

The problem persists after this update. Downgrading systemd to build 239.0-1 solved it again. I'll take a look at the changes now.

All installed ok (Have not rebooted yet) but did get:

warning: directory permissions differ on /usr/local/man/
filesystem: 775 package: 755

Should i change to 755 or just leave it be?
Rebooted and works ok but still have with new updated Kernel (4.18) still showing "sd-unmount old root" error on shut down/restart.

I have always encountered the lines below during updates. I am not sure if I should answer 'yes' to these questions so I always answered 'no'. Could anyone provide me an overview and/or links that would help me decide?

Thanks in advance.

:: Replace gnome-themes-standard with extra/gnome-themes-extra? [Y/n] n
:: Replace haskell-mtl with community/ghc-libs? [Y/n] n
:: Replace haskell-parsec with community/ghc-libs? [Y/n] n
:: Replace haskell-stm with community/ghc-libs? [Y/n] n
:: Replace haskell-text with community/ghc-libs? [Y/n] n
:: Replace wxpython with community/python2-wxpython3? [Y/n] n

Forum kindly sponsored by