[Stable Update] 2018-08-31 - Kernels, Mesa, Qemu, Nvidia, Firefox, Python, Haskell

Hi community,

Welcome to another stable update. So what do we have with this one?

  • added the latest Nvidia driver 390.87
  • we fixed a regression with AUR in pamac v7.0-beta
  • we updated some of our kernels incl. v4.19-rc1
  • added a newer version of linux414-rt
  • linux44 and linux49 should boot now again (fixed issues with L1TF)
  • newer systemd snapshot
  • latest firefox-dev package
  • introducing of AMD-Ucode (install via pacman -S amd-ucode after upgrade)
  • we updated our adpata-themes
  • we updated our pamac to v7.0-beta
  • firefox-dev got updated to v63.0b1
  • amarok got dropped
  • few XFCE-GTK3 updates
  • the usual python and haskell rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.120 [EOL]
  • linux44 4.4.153
  • linux49 4.9.124
  • linux414 4.14.67
  • linux417 4.17.19 [EOL]
  • linux418 4.18.5
  • linux419 4.19-rc1
  • linux414-rt 4.14.63_rt40
  • linux416-rt 4.16.18_rt11

Package Updates (Fri Aug 31 07:36:42 CEST 2018)

  • stable community x86_64: 456 new and 448 removed package(s)
  • stable core x86_64: 21 new and 21 removed package(s)
  • stable extra x86_64: 140 new and 139 removed package(s)
  • stable multilib x86_64: 18 new and 17 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Steam-manjaro sets greater FD limits

With this release the steam-manjaro package adds two scripts to increase the FD limits, to let users using the new Steam Play functionality to enjoy the experience out of the box. Two files were added: /etc/systemd/system.conf.d/40-fd-limits.conf and /etc/systemd/user.conf.d/40-fd-limits.conf.
Check your new limits using:

ulimit -Hn

It should show 1048576.
More info about this change can be found here: https://archived.forum.manjaro.org/t/increase-fd-limits-to-let-steam-play-works-reliably/56270

Keyboard backlight controls stopped working

Upower 0.99.8 introduced a regression breaking keyboard backlight controls on some devices. See this post for a possible fix.

Items from previous update sets

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


just updated to kernel 4.18.5, and my system is running noticeably smoother and has become very responsive. I don't know whether it's the kde update or the kernel update, but, damn, this is smooth.

1 Like

I am noticing it too on 4.18.5 with kde. I have to say the lesser performance before this update only started after the previous update for me, so whatever it was, it was shortlived.

1 Like

I had no problems when updating. Everything went fine.
Best regards

This may be a stupid question. Is there a updated ISO as well? Asking if downloading for a fresh install...

1 Like

ISO's are not updated with every stable update. For new ISO's there is always an announcement when released.

1 Like

I shows this message

Rebuilding fontconfig cache.../usr/share/fonts/100dpi: failed to write cache
/usr/share/fonts/75dpi: failed to write cache
/usr/share/fonts/cyrillic: failed to write cache
/usr/share/fonts/encodings/large: failed to write cache
/usr/share/fonts/util: failed to write cache

Is something to worry about?

Always read the second post "Known issues and solutions" please...


Great update Manjaro Team!!!
No prob here on xfce

I can also confirm that using kernel 4.18.5 makes the system really really responsive!!!

Sorry my friend. I dont notice it. So i just ignorit and dont do anything?

Great update and another confirm on the kernel 4.18.5 makes system really responsive even on old girl like mine :slight_smile: Thank you to everyone as always and the Manjaro Team are on top of the list :slight_smile:

1 Like


On my XFCE machine after update keepass "Perform Auto-Type" very slow.

I downgrade


and keepass "Perform Auto-Type" works fast.

sudo pacman -Syu
[sudo] Passwort für micha:
:: Synchronisiere Paketdatenbanken...
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: manjaro-lxqt-basic-settings: Lokale Version (20170614-1) ist neuer als community (
Warnung: manjaro-lxqt-extra-settings: Lokale Version (20170614-1) ist neuer als community (

hilfe, ich komm hier nicht weiter, was ist da los ?

danke und grüße

New type of numbering.
Remove the old ones and install the new ones.
You might want to backup your changes/edits.

1 Like

After this update network manager resetting all my wifi settings after reboot or restart network manager -- password, band, dns etc.

  Host: mgundogdu-pc Kernel: 4.14.67-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.0 Desktop: N/A Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: UX410UQK v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: UX410UQK v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: UX410UQK.301 date: 12/12/2016 
  Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23240 
  Speed: 600 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 600 2: 600 
  3: 600 4: 600 
  Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel bus ID: 02:00 
  IF: wlp2s0 state: up mac: <filter> 

Edited: Sorry my bad. I was sleepy at night I couldn't understand my problem but I realized that my problem related wifi band settings. Work around a little this is a known 5 Ghz band issue. On linux some manufacturers won't support 5 Ghz band. Is there any way to set my wifi band to 5 Ghz instead 2.4 Ghz :confused:
Thanks in advance

use manjaro architect

Until now I had downgraded systemd to v239.0-2 to have Internet at home.

I finally could upgrade systemd and solved the "wifi connected no Internet" issue at home. Just the upgrade was not enough. I had to configure NetworkManager to use systemd-resolved and disable DNSSEC in the latter.

This issue doesn't appear in a wired connection and it started with the systemd v239.0-1 upgrade.

If someone has a similar issue, I could share the configuration.

The symptom of the issue:

You can ping to but you cannot resolve any domain name. IOW, ping works, but ping www.google.com doesn't work.

There's a nasty error / regression in this new version. I hope to goodness it's merely an unfortunate temporary oversight by Mozilla Devs, & not a permanent loss of function.

v63.0b1 has LOST the "Load this bookmark in the sidebar" Bookmark Properties setting...
...& consequently all my specially arranged BM Toolbar BMs that i need to open in the SB not the standard window, for my optimal workflow, now only open in the standard window. This is completely unacceptable to me, & so i had to Downgrade to firefox-developer-edition-62.0b20-1 to fix it. If this silliness is to become truly a permanent "feature" of FF-DE then i'll later have to downgrade simply to standard FF... but presumably over time that will also lose the setting. Gahhh.

1 Like

Forum kindly sponsored by