[Stable Update] 2018-08-31 - Kernels, Mesa, Qemu, Nvidia, Firefox, Python, Haskell

A standard update went OK here, many thanks :slight_smile:

P.S:

nobody has ported amarok on qt5 yet?

Upstream is still working on it. 2.9.0 was the last based on qt4. If you still like it, you may try amarok-git.

pamac install https://manjaro.moson.eu/pool/overlay/amarok-2.9.0.r245.g68a1f0ecdd-1-x86_64.pkg.tar.xz

deleting the new FD limit conf file did not help (after reboot):

sudo rm /etc/systemd/system.conf.d/40-fd-limits.conf

any other step required? Or is it maybe not related to this change?

You missed the /etc/systemd/user.conf.d/40-fd-limits.conf file. You also might need to reboot.

oops, you're right, will try again, thanks

sudo rm /etc/systemd/user.conf.d/40-fd-limits.conf

still no luck :thinking:

Well, then it might be a regression. Which kernel series worked last?

linux414-4.14.66-1-x86_64.pkg.tar.xz worked fine, I'll try to downgrade the kernel with firmware packages to see if it helps.

I remember few days ago testing the 4.18 series and it worked as well, so not sure what happened. Unfortunately I deleted the cached package for 4.18 so I'll be able to test only the 4.14 series.

Thanks for the suggestion.
After re-installing Manjaro and putting back my home directory I noticed the problem just after I restored the ~/.fonts directory. I emptied the ~/.fonts directory: problem solved.
It seems the fontconfig update possibly has a negative effect.

1 Like

I also have backlit keyboard problem after the update. Asus Vivobook, kernel series 4.18.x

Before the update mine was working fine, definitely due to this update.

Here is the compatibility announcement.

1 Like

Don't blame Linux after last Windows 10 update my backlight stopped working :joy: :joy:

1 Like

Confirm the issue with keyboard backlight.

OK after several hours of investigation the package upgrade causing this issue is upower, version 0.99.7 to 0.99.8. Looks like a regression.

Arch bug tracker: https://bugs.archlinux.org/task/59865?project=1&string=upower
Upstream issue: https://gitlab.freedesktop.org/upower/upower/issues/73

Workaround: downgrade upower or deselect the update for it
sudo pacman -U /var/cache/pacman/pkg/upower-0.99.7-1-x86_64.pkg.tar.xz

1 Like

PROBLEM: I am facing the same problem with four three laptops that run Manjaro KDE: after the latest stable upgrade the KDE battery indicator (located in the KDE panel) does not update the status when I plug and unplug the laptop. acpi -i returns the correct battery status (Discharging or Charging). I am NOT facing this problem with the laptop that runs Arch + KDE Plasma. Suggestions are welcome.

EDIT: The solution (thanks, @philm)

sudo pacman -U https://manjaro.moson.eu/pool/overlay/upower-0.99.8-1.1-x86_64.pkg.tar.xz

1 Like

Thank you. Terrible news for me.

Thank you too.

This act of FF Dev idiocy has rocked me, & makes me now need to reassess my recent decision to migrate to FF... Firefox browser

Why is this idiocy? Reading through the bug report it seems this was a pretty logical decision.

It is a feature you use so it must be annoying, but it is far from idiocy.

This type of functionality could be resurrected via a WebExtension, assuming someone with the requisite skills misses it enough to develop it.

Thx for finding the issue. For me reading the commits it was a no-brainer :wink: I reverted b0cdb7e. Please test if that fixes it:

pamac install https://manjaro.moson.eu/pool/overlay/upower-0.99.8-1.1-x86_64.pkg.tar.xz

4 Likes

KDE / Plasma doesn't seem to recognize that my laptop is plugged in / charging. Battery indicator doesn't change the to the charging symbol, and the powersaving settings for "on battery" remain applied when plugged in. Hardware recognizes power (ThinkPad power button light blinks when adapter is plugged in), and if I go into kinfo center it shows that the battery is charging.

Kernel 4.18 (which I was running before, but there was an update to the kernel)

EDIT:
Sep 02 00:32:06 pluto systemd-udevd[13514]: Process '/usr/bin/tlp auto' failed with exit code 4.

EDIT: Fix is in the post directly above mine... oops.

1 Like

After this upgrade font hinting got disabled for me on Plasma (if your text suddenly looks ugly, that's it). The solution is to change Hinting style under System Settings>Fonts to Full. (Set Use anti-aliasing to Enabled to enable this setting)

Forum kindly sponsored by