[Stable Update] 2018-10-08 - Kernels, Gnome 3.30, Cinnamon, Deepin, Pamac, SPL/ZFS

Hi community,

Welcome to another stable update. Since this update is huge we recommend to install it from within a terminal: pamac upgrade or sudo pacman -Syu

So what do we have with this one? Mostly we focused on the major Gnome, which got released earlier last month. The entire desktop now uses fewer system resources, which means you can run more apps at once without encountering performance issues.


Another main focus was on Pamac. We hope it will be the snappiest release we ever did. Now the CLI and UI feature the same functions, which makes your life maintaining your installation of Manjaro even more effectiv.

Else we worked on our new homepage layout pushed more things to our new hardware project, the #bladebook.

Here the brief overall changes with this update:

  • Gnome 3.30 got added to our repos
  • Cinnamon and Deepin got renewed with new features and fixes
  • we released Pamac v7.1.1
  • Pamac also gained functionality to edit PKGBUILDs from AUR packages (please test it via pamac-dev)
  • The Kernel got updated to v4.19-rc7
  • most of our other Kernels got also updated. The #bladebook gets fully supported with v4.18.8 and higher
  • Some fixes to SPL/ZFS
  • Further fixes to Pamac-Dev
  • NetworkManager is now at 1.14.0
  • LibreOffice got updated to 6.1.1
  • added the Hibernation option to the lockscreen of Plasma-Workspace
  • we have now the latest Nvidia 410.57 driver added
  • Wine is now at 3.17
  • Mesa got updated to 18.2.2
  • LLVM and CLANG got updated to 7.0
  • Firefox-Dev is now at 63.0b10
  • I managed to complete my work on the smooth bootup experience
  • upstream fixes incl. haskell and python packages

We hope with all these changes Manjaro to be more efficient for you all.

The Iconic Spitfire: Now Quad-Core!


Visit StationX now!

#rc-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a rc-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our rc-build with the latest KDE v5.13 instead. And our GNOME fans may try our rc-build with the latest GNOME v3.30.

Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.123 [EOL]
  • linux44 4.4.159
  • linux49 4.9.131
  • linux414 4.14.74
  • linux417 4.17.19 [EOL]
  • linux418 4.18.12
  • linux419 4.19-rc7
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Mon Oct 8 07:20:36 CEST 2018)

  • stable community x86_64: 1723 new and 1601 removed package(s)
  • stable core x86_64: 63 new and 61 removed package(s)
  • stable extra x86_64: 850 new and 953 removed package(s)
  • stable multilib x86_64: 67 new and 73 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

How to enable smooth-bootup

These steps are only needed when not using any Manjaro 18.0-beta-7 or higher install media.

  • install linux418 or linux419
  • install grub-quiet
  • reinstall grub to MBR (Attention: use the correct cmd for your system!)
    • EFI: sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
    • BIOS: sudo grub-install --recheck /dev/sd[X] (change [X] for your device letter. Check via lsblk -f)
  • reboot to see if all is still booting fine
  • check that you have loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 in /etc/default/grub under GRUB_CMDLINE_LINUX_DEFAULT or GRUB_CMDLINE_LINUX
  • sed -i -e 's|fsck||g' /etc/mkinitcpio.conf
  • sudo mkinitcpio -P
  • sudo update-grub
  • reboot your system

If you have issues please use this thread:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.

Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.

Items from previous update sets

AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

1 Like

I got the following message when performing the update with pamac 7.1.x:

Vorgang konnt nicht abgeschlossen werden
Vorgang nicht vorbereitet

Translated to English:

Failed to commit transaction
Transaction not prepared.

Besides that I can not find any problems or further hints.

What should I do? Is this a pamac bug?


Carla package got updated. I'm not sure if you missed it, but I posted on a testing update, that it would be a good idea to hold back the carla package on the older version (1.9.9-3), since the current one has a bug which could destroy parts of user projects.
@philm What about a downgrade of the carla package?

No Problems with the update - all works fine :grinning:

thanks to the manjaro-team.


System:    Host: hoflo Kernel: 4.19.0-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.13.5 
           Distro: Manjaro Linux 
Machine:   Type: Desktop System: LENOVO product: 7307A1G v: ThinkCentre M58e serial: <filter> 
           Mobo: LENOVO model: N/A serial: <filter> BIOS: LENOVO v: 5HKT43AUS date: 09/07/2009 
CPU:       Topology: Dual Core model: Intel Core2 Duo E8400 bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 1995 MHz min/max: 2003/3003 MHz Core speeds (MHz): 1: 1995 2: 1995 
Graphics:  Device-1: Intel 4 Series Integrated Graphics driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.1 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel G41 v: 2.1 Mesa 18.2.2 
Audio:     Device-1: Intel NM10/ICH7 Family High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.19.0-1-MANJARO 
Network:   Device-1: Marvell 88E8057 PCI-E Gigabit Ethernet driver: sky2 
           IF: ens33 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 232.89 GiB used: 15.00 GiB (6.4%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
Partition: ID-1: / size: 220.81 GiB used: 15.00 GiB (6.8%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.43 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 157 Uptime: 12m Memory: 3.82 GiB used: 1.06 GiB (27.9%) Shell: bash inxi: 3.0.26 

Got this after updating Cinnamon 4.14 (and one in VirtualBox):


But everything seems to be OK after that. Nice work!

EDIT: Root Filemanager stopped working. Tried "sudo nemo" and nothing happens.


Same issue here, 'Transaction cannot be prepared' message after what appears to be a successful update. No error messages in the logfile though.

Not a big issue but owncloud-client now warns that nextcloud server version is unsupported and there is no nextcloud-client package outside of AUR. Formerly the recommendation was to just use the owncloud-client package as the nextcloud package was just a visual rebrand.

nice and smooth update on my old laptop (Dell n5110)... now manjaro hello shows 18.0.0-rc ... i think we are very close to the prime day ... also i wonder if we can now try the grub-quite and i wish if someone shows us how to install it ... i'm running the 4.18.12 kernel

No problems here on xfce with 4.18.12
Great job Manjaro Team!!!

PLease, I search for you :smiley:

1 Like

thank you my friend ... but unfortunately i ended with error in grub 'grub_key_is_interrupted' ... any solution :sweat_smile:

1 Like

This thread

give this


you are not alone :slight_smile:

1 Like

Thank you very much for your great work. All went fine on this machine and the packard bell lm98
(cannot set in markdown ---weird--)

System:    Kernel: 4.18.12-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.13.5  
          Distro: Manjaro Linux  
CPU:       Quad Core: Intel Core i5-7500 type: MCP speed: 800 MHz min/max: 800/3800 MHz  
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X]  
          driver: amdgpu v: kernel  
          Display: x11 server: X.Org 1.20.1 driver: amdgpu,ati unloaded: modesetting  
          resolution: 1920x1080~60Hz, 1920x1080~60Hz  
          OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.26.0 4.18.12-1-MANJARO LLVM 7.0.0)  
          v: 4.5 Mesa 18.2.2  
Drives:    Local Storage: total: 954.81 GiB used: 83.18 GiB (8.7%)  
Info:      Processes: 211 Uptime: 3m Memory: 15.63 GiB used: 1.30 GiB (8.3%) Shell: bash inxi: 3.0.26

Try steps suggested in reply 18 . if this does not work read original post. For me both worked.

Had a couple of keys fail to sign. Easily fixed by running:

sudo rm -rf /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
1 Like


Since the update GNOME top bar missing when using magnifier. Therefore unable to see time, notifications, extensions on the top bar, and unable to shut down PC without terminal.

Can't use Super key either to access activities, with or without magnification on

Kindest Regards

Paul Ambler

EDIT: just noticed dialog boxes also not fully viable when magnifier is on.

I had the same message and used pamac. I have rebooted and everything seems ok. Wait and see I suppose.

I don't think this is how rolling distros work. Also, it would cause an exponential increase in package maintenance headaches. Downgrading packages on a case-by-case basis because of a bug also means each downgraded package has to be tested again in the future by the Manjaro team (with a particular bug in mind) when another update is pushed upstream. Since pretty much every package has a bug of some severity, doing this as policy would not be possible.

The only times I've seen it happen is driver packages that result in system breaking behavior.


Is currently not compatible with Gnome 3.30. However there is a version that will work for now

wget -c "https://github.com/andyholmes/gnome-shell-extension-gsconnect/files/2377746/gsconnect.andyholmes.github.io.zip"
unzip -o gsconnect.andyholmes.github.io.zip -d ~/.local/share/gnome-shell/extensions/gsconnect@andyholmes.github.io/

logout, login. (This only works if GSConnect was installed via browser, NOT via pacman/pamac))

Forum kindly sponsored by