[Stable Update] 2018-10-08 - Kernels, Gnome 3.30, Cinnamon, Deepin, Pamac, SPL/ZFS

‘Transaction cannot be prepared’ - error, but does not seem to affect anything.
Gnome 3.30 messed up several extensions like TOP Icons Plus, No Title Bar, and Global Menu. First 2 can be fixed following the recommendations from their gnome extensions page, the last and most important one I could not fix :frowning: . My custom theme got a bit screwed in Nautilus. So far everything else seems to be fine. I think Gnome 3.30 is the main culprit.

This is a known issue (which is promptly closed by the dev as it only happens in Arch and Manjaro).

You can also have a look at the arch linux forum thread which is linked inside the issue for more information. tldr:

The best way for me as I see it - using CLI when root is needed.


Everything went smooth!

Kernel: linux 414 & linux49.

I also got the "Transaction Not Prepared" notice but all seems to be working properly so far after I closed out the message window and rebooted. My headphone output stopped working but I think it is a hardware issue and not an OS problem as it's a 9-and-a-half year old Lenovo laptop and was having audio issues just before the update.

Update on 12 Machines and 1 VB without Problems.


1 Like

Hello, folks!

I has a problem with dnsmasq. This problem appeared after the upgrade.

$ dnsmasq -k --enable-dbus --user=dnsmasq --pid-file

dnsmasq: failed to create listening socket for Permission denied

$ sudo dnsmasq -k --enable-dbus --user=dnsmasq --pid-file
[1]    10029 segmentation fault  sudo dnsmasq -k --enable-dbus --user=dnsmasq --pid-file


Oct 08 17:29:52 - dnsmasq[9536]: failed to create listening socket for Permission denied
Oct 08 17:29:52 - dnsmasq[9536]: FAILED to start up
Oct 08 17:31:45 - dnsmasq[10020]: started, version 2.79 cachesize 1000
Oct 08 17:31:45 - dnsmasq[10020]: compile time options: IPv6 GNU-getopt DBus i18n IDN2 DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify
Oct 08 17:31:45 - dnsmasq[10020]: DBus support enabled: connected to system bus
Oct 08 17:31:45 - dnsmasq-dhcp[10020]: IPv6 router advertisement enabled
Oct 08 17:31:45 - dnsmasq[10020]: using local addresses only for domain
Oct 08 17:31:45 - audit[10020]: ANOM_ABEND auid=1000 uid=991 gid=991 ses=3 pid=10020 comm="dnsmasq" exe="/usr/bin/dnsmasq" sig=11 res=1
Oct 08 17:31:45 - kernel: dnsmasq[10020]: segfault at 0 ip 000055a564a62f9a sp 00007ffeeeec4c00 error 4 in dnsmasq[55a564a47000+45000]
Oct 08 17:31:45 - kernel: Code: 01 00 00 48 8d 0d 62 9d 02 00 48 89 4c 24 08 f6 42 05 20 0f 85 f7 01 00 00 a8 08 0f 84 1f 02 00 00 49 8b 46 58 ba 05 00 00 00 <80> 38 00 0f 84 8d 02 00 00 48 8d 35 d6 00 03 00 31 ff ff 15 16 be 
Oct 08 17:31:45 - kernel: audit: type=1701 audit(1539009105.789:171): auid=1000 uid=991 gid=991 ses=3 pid=10020 comm="dnsmasq" exe="/usr/bin/dnsmasq" sig=11 res=1

Any thoughts ?

I notice that pamac this time attempts to start a full system upgrade for a second time after the system finishes upgrading. Since no transactions are prepared for this second full system upgrade, it fails in error. I suspect this is either a pamac bug, or a bug in the upgrade process. I presume it is safe to ignore.

After the update, everytime I launch an application everything freezes for a couple of seconds before the app is launched.

1 Like

This update broke my suspension. When I close my laptop it will not suspend. It's getting a blackscreen and I have to do a hard shutdown to get back control.


There is something wrong with tray…

Well, they did this with the ffmpeg package for example some time ago.
And since the older carla package works perfect, they could use this until new Carla release. No more packages have to be maintained, it is still compatible with all of it's dependecies.

Just wanted to inform, because I think this is an important thing, because it could destroy what users made without their knownledge. (happend to me until I downgraded, luckily I had a backup)

I'm running KDE and 4.19rc7. During the update process using pacman I got a black screen with this error message.


I did as the error requested and got back to the desktop and the upgrade finished without errors. But I kept getting:

And when i clicked on it.


Neither Shutdown nor cntrl-alt-del worked so I did cntrl-alt-F2 to get to a terminal and issued $shutdown now. It worked and when I rebooted everything appears to be running as it should with the updated system.

Two great updates so far.
Deepin and Xfce with no warnings or problems.

I noticed that system sounds doesn't work anymore.
Playing youtube videos with sound works fine.

Using Manjaro with Cinnamon Desktop

I can't reproduce that. Are you able to play them manually from the Sound Settings?

No, that also doen't work.

why no beta9 for gnome?

Warning: filesystem: directory permissions differ in / root / file system: 770 package: 750

I am confused. Today I was presented with 261 updated packages, which I suppose is because of this topic. The release package itself is named "manjaro-release-18.0.0rc-1". All the posts here refer to beta or RC, yet this is marked as stable update. And I am using the stable release channel.

What's up? I dunno if I should update or not.

Forum kindly sponsored by