[Stable Update] 2018-10-19 - Kernels, KDE, Xorg, VB, PHP, Mesa, Nvidia, Pamac

Hi community,

Welcome to another stable update. Since this update is huge we recommend to install it from within a terminal: pamac upgrade or sudo pacman -Syu

So what do we have with this one?

We mostly focused on the K desktop environment. In Plasma there's a new Display Configuration widget for screen management which is useful for presentations. The Audio Volume widget now has a built in speaker test feature moved from Phonon settings. The Network widget now works for SSH VPN tunnels again. For the window manager copy-paste between GTK and non-GTK apps on Wayland got fixed. Additonally many bugs got fixed: Blurred backgrounds behind desktop context menus are no longer visually corrupted and
it's no longer possible to accidentally drag-and-drop task manager buttons into app windows.


Then we worked on our boot experience and fixed grub-boot-success for grub-quiet. The menu should now stay hidden as it should. Please report any edge cases you may still have with it.

Calamares gained the functionality to define how we may use swap.

Other changes in brief overview:

  • We updated most of our kernels (linux419 uses now BFQ v9 as default scheduler)
  • We added KDE Plasma 5.14.1, Apps 18.08.2 and Framework 5.51.0
  • Xorg-Server is now at 1.20.2
  • Mesa is now at 18.2.3
  • Virtualbox has a new version
  • Nvidia drivers are now at the new long-lived 410 series
  • glibc and mkinitcpio got some fixes added. For the later you may take a look at this if you boot from USB
  • Deepin and Gnome got some packages updated
  • We fixed grub-boot-success for grub-quiet
  • We worked on our themes
  • We updated Firefox-Dev to v64 series
  • PHP is now at 7.2.11 and JDK8 at 8.u192
  • Updated Pamac to v7.2-beta1
  • The usual upstream fixes incl. haskell

We hope with all these changes Manjaro to be more efficient for you all.

The Iconic Spitfire: Now Quad-Core!


Visit StationX now!

#rc-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a rc-build of Manjaro-Xfce 18.0 including the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our rc-build with the latest KDE v5.14 instead. And our GNOME fans may try our rc-build with the latest GNOME v3.30.

Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.124 [EOL]
  • linux44 4.4.161
  • linux49 4.9.134
  • linux414 4.14.77
  • linux417 4.17.19 [EOL]
  • linux418 4.18.15
  • linux419 4.19-rc8
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Fri Oct 19 20:04:00 CEST 2018)

  • stable community x86_64: 1228 new and 1203 removed package(s)
  • stable core x86_64: 28 new and 27 removed package(s)
  • stable extra x86_64: 651 new and 707 removed package(s)
  • stable multilib x86_64: 22 new and 15 removed package(s)

A list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

How to enable smooth-bootup

These steps are only needed when not using any Manjaro 18.0-beta-7 or higher install media.

  • install linux418 or linux419
  • install grub-quiet
  • reinstall grub to MBR (Attention: use the correct cmd for your system!)
    • EFI: sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
    • BIOS: sudo grub-install --recheck /dev/sd[X] (change [X] for your device letter. Check via lsblk -f)
  • reboot to see if all is still booting fine
  • check that you have loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 in /etc/default/grub under GRUB_CMDLINE_LINUX_DEFAULT or GRUB_CMDLINE_LINUX and may remove any background settings
  • sed -i -e 's|fsck||g' /etc/mkinitcpio.conf
  • sudo mkinitcpio -P
  • sudo update-grub
  • reboot your system

If you have issues please use this thread:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.

Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.

Items from previous update sets

AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

rebuilds of nVidia modules for RT kernels have been skipped (linux414-rt-nvidia linux418-rt-nvidia)

:: installing nvidia-utils (1:410.66-1) breaks dependency 'nvidia-utils=1:410.57' required by linux414-rt-nvidia

Removed RT kernel for now for doing update (wasn't the main anyway)

Xfce on kernel 4.14 and nvidia 410.66: no issues to report.

Thank you for getting the latest libssh pushed out and taking care of a significant new vulnerability so quickly.

I received some locale errors during installation:

Updating linux418 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux418.preset: 'default'
  -> -k /boot/vmlinuz-4.18-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.18-x86_64.img
==> Starting build: 4.18.15-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [resume]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
/etc/locale.conf: line 7: warning: setlocale: LC_NUMERIC: cannot change locale (en_US.UTF-8): No such file or directory
/etc/locale.conf: line 10: warning: setlocale: LC_TIME: cannot change locale (en_US.UTF-8): No such file or directory
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
  -> Running build hook: [bootsplash-manjaro-green]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.18-x86_64.img
bsdcpio: Failed to set default locale
==> Image generation successful

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_PAPER = "en_US.UTF-8",
	LC_NAME = "en_US.UTF-8",
	LC_ADDRESS = "en_US.UTF-8",
	LC_NUMERIC = "en_US.UTF-8",
	LC_TIME = "en_US.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

I solved the issue running sudo localedef -f UTF-8 -i en_US en_US.UTF-8.


So far no issue.
Updating kernels went smoothly on OpenBox-regular on main partition with 4.18.12_rt, 4.14.71_rt, 4.14.77-1 and second (also OpenBox) with 4.18.15-1 and 4.14.77-1.

Tomorrow I'll record something to see how rt kernels work after update :slight_smile:

Thank you Manjaro Team :kissing_heart:

I'm getting a very fast blinking cursor on a black screen.

I'm using Manjaro 18 clean install with XFCE (which uses Lightdm and light-locker by default afaik). Once the screen lock is trigger due to the time-out trigger or when push the screen lock button, I will get this blinking cursor. I can't do anything about it, the only way to solve it, is either remote SSH login and restart lightdm or press ctrl+alt+del to force a reboot :frowning: .

I also tried to report this issue here (although I have the feeling nobody takes it seriously):

Yep, they are not yet done (@oberon) - @Lolix: that's why we told you NOT to update just yet :wink:

1 Like

I successfully installed grub-quiet on my HP laptop following the instructions above, but I see a blank screen instead of the advertised manufacturer logo. Does this line need to be changed?


No problems updating my Plasma installation.

1 Like

This worked nicely for me on a Lenovo laptop, Lenovo logo appeared until breeze login.

However, on my workstation with an ASUS MB (Z97 Deluxe), the ASUS logo does not appear and some text is visible (talking about hibernation and other verbose stuff) for a few seconds instead.

EDIT: Both are on 4.19

Here's the error I get:

Warning: tribler: directory permissions differ on /usr/share/applications/filesystem: 755  package: 644
Warning: tribler: directory permissions differ on /usr/share/pixmaps/filesystem: 755  package: 644

But everything seems to work ok.

What? Where? At time of me posting this i've re-read this topic & cannot see anywhere a warning to NOT perform this update. I was about to begin doing it, but now i am confused if i should proceed or not.

Btw, what does "TBD" mean, in the title?

1 Like

TBD stands for To Be Determined/Done.

Thanks for the stable update. I got a tmuxp crash because a conflict version with colorama. For a fix I sent a patch to the Arch Linux developer.

Thank you... but what pragmatically does it mean for users... are we supposed to wait or proceed?

I's sorry. Does this mean we MUST switch to "smooth-bootup" or will it remain optional?

Optional. None of my system are using it.


Good. Too much trouble, too much to go wrong. I will stay with old bootup.

Thank you for your prompt reply.

1 Like

What's the point of uploading updates right now if it's considered not ready to be applied?


Forum kindly sponsored by