[Stable Update] 2018-10-21 - Kernels, GTK3, MHWD, Pamac

Hi community,

Welcome to another stable update.

So what do we have with this one?

  • We updated some of our themes
  • Most of our Kernels got updated
  • Some fixes to mhwd in regard of Virtualbox
  • Pamac is now at v7.2.0-rc1
  • The flickering on mouse hover in gtk3 is now fixed

We hope with all these changes Manjaro to be more efficient for you all.

The Iconic Spitfire: Now Quad-Core!


Visit StationX now!

#rc-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a rc-build of Manjaro-Xfce 18.0 including the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our rc-build with the latest KDE v5.14 instead. And our GNOME fans may try our rc-build with the latest GNOME v3.30.

Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.124 [EOL]
  • linux44 4.4.162
  • linux49 4.9.135
  • linux414 4.14.78
  • linux417 4.17.19 [EOL]
  • linux418 4.18.16
  • linux419 4.19-rc8
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Sun Oct 21 18:34:18 CEST 2018)

  • stable community x86_64: 110 new and 108 removed package(s)
  • stable core x86_64: 15 new and 14 removed package(s)
  • stable extra x86_64: 55 new and 53 removed package(s)
  • stable multilib x86_64: 3 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2018-10-19           2018-10-21
appimagelauncher 1.0alpha+git20181004.632404f-1 1.0alpha+git20181009.b04daee-1
               elementary-xfce-icons                0.7-1             0.13.1-1
     manjaro-application-utility-dev              1.0.2-2                1.1-2
                    matcha-gtk-theme           20181012-1           20181021-3
                        python-evdev              0.7.0-1                    -
                               snapd             2.34.3-1             2.35.5-2
                 xfce-theme-greybird             3.22.8-1           3.22.9+1-1

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-10-19           2018-10-21
                         astromenace              1.3.2-3              1.4.0-1
                                 bat              0.7.1-2              0.8.0-1
                             compton                2.0-1                2.0-2
                          containerd              1.1.2-1              1.1.4-1
                            electron             2.0.11-1             2.0.12-1
                              girara              0.3.0-2              0.3.1-1
                           git-annex        6.20181011-10        6.20181011-13
               gnome-code-assistance 3.16.1+12+g5418ece-2 3.16.1+13+g7f81c19-1
                                gpsd               3.18-2             3.18.1-1
                             grafana              5.2.2-1              5.3.1-1
                             haproxy              1.8.9-1             1.8.14-1
                       haskell-gauge             0.2.3-12              0.2.4-1
             haskell-haddock-library             1.6.0-20             1.6.0-21
                haskell-html-conduit             1.3.1-52              1.3.2-1
                haskell-monad-logger            0.3.29-26             0.3.30-1
                  haskell-persistent             2.8.2-93             2.8.2-94
           haskell-persistent-sqlite             2.8.2-38             2.8.2-39
         haskell-persistent-template            2.5.4-119            2.5.4-120
                   haskell-tree-diff             0.0.1-52             0.0.1-53
                    haskell-trifecta                  2-1
                       haskell-yesod            1.6.0-150            1.6.0-153
                  haskell-yesod-core              1.6.8-7  
               haskell-yesod-default            1.2.0-418            1.2.0-420
                  haskell-yesod-form             1.6.2-77              1.6.3-3
                haskell-yesod-static            1.6.0-118            1.6.0-120
                         hledger-web            1.11.1-16            1.11.1-20
                                 hub              2.5.0-1              2.5.1-1
                            influxdb              1.6.2-1              1.6.3-1
                              ioping                1.0-1                1.1-1
                              kstars            1:2.9.8-3            1:2.9.8-4
                        languagetool                4.2-1                4.3-1
                              libdom              0.3.3-1              0.3.3-2
                          libsvgtiny              0.1.6-1              0.1.7-1
                             libvirt              4.8.0-1              4.8.0-2
                            lollypop            0.9.604-1            0.9.605-1
                        man-pages-de                2.6-1                2.9-1
                      matrix-synapse             0.33.4-1             0.33.7-1
                              mayavi              4.5.0-6              4.6.2-1
                             nanomsg              1.1.4-1              1.1.5-1
                                 ntl             11.3.0-3             11.3.1-1
                    otf-font-awesome              5.3.1-1              5.4.0-1
                              pandoc             2.3.1-14             2.3.1-16
                     pandoc-citeproc             0.14.7-3             0.14.8-1
                              povray          2:          2:
         pulseaudio-equalizer-ladspa              3.0.0-1              3.0.1-1
                     pyprof2calltree              1.4.3-2              1.4.4-1
                    python-ansi2html              1.4.2-2              1.5.1-1
                     python-autobahn             18.9.1-1             18.9.2-1
                       python-bleach              2.1.4-1              3.0.2-1
                       python-cvxopt              1.2.1-1              1.2.2-1
               python-jsonrpc-server              0.0.1-1              0.0.2-1
                      python-mistune              0.8.3-2              0.8.4-1
                     python-openpyxl              2.5.7-1              2.5.9-1
                        python-parse              1.8.4-2              1.9.0-1
                       python-pipenv           2018.7.1-3         2018.10.13-1
                        python-pyicu                2.1-1                2.2-1
                       python-pynacl              1.2.1-3              1.3.0-1
                 python-scikit-learn             0.19.2-1             0.20.0-1
                         python-tqdm             4.27.0-1             4.28.0-1
                        python-wheel             0.32.1-1             0.32.2-1
           python-zope-i18nmessageid                4.3-1              4.3.1-1
                    python2-autobahn             18.9.1-1             18.9.2-1
              python2-backports.lzma             0.0.12-1             0.0.13-1
                      python2-bleach              2.1.4-1              3.0.2-1
                      python2-cvxopt              1.2.1-1              1.2.2-1
              python2-jsonrpc-server              0.0.1-1              0.0.2-1
                     python2-mistune              0.8.3-2              0.8.4-1
                    python2-openpyxl              2.5.7-1              2.5.9-1
                       python2-parse              1.8.4-2              1.9.0-1
                      python2-pipenv           2018.7.1-3         2018.10.13-1
                       python2-pyicu                2.1-1                2.2-1
                      python2-pynacl              1.2.1-3              1.3.0-1
             python2-pyprof2calltree              1.4.3-2              1.4.4-1
                python2-scikit-learn             0.19.2-1             0.20.0-1
                        python2-tqdm             4.27.0-1             4.28.0-1
                       python2-wheel             0.32.1-1             0.32.2-1
          python2-zope-i18nmessageid                4.3-1              4.3.1-1
                                rust           1:1.29.0-2           1:1.29.1-1
                           rust-docs           1:1.29.0-2           1:1.29.1-1
                       sage-notebook              1.1.0-1              1.1.0-2
                        sagemath-doc                8.3-1                8.4-1
                          shellcheck            0.5.0-129            0.5.0-131
                               stack              1.9.1-5              1.9.1-7
                      tamarin-prover            1.4.0-129            1.4.0-131
                                tinc             1.0.34-1             1.0.35-1
                    ttf-font-awesome              5.3.1-1              5.4.0-1
                                 urh              2.3.0-1              2.4.0-1
                              wcslib               5.20-1                6.2-1
                             zathura              0.4.0-4              0.4.1-1
                   zathura-pdf-mupdf              0.3.3-3              0.3.4-1
                     cloudprint-cups               - 1:20160502.r16.g1f27903-1
          epson-inkjet-printer-escpr                    -             1.6.31-1
                         python-rstr                    -              2.2.6-6

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2018-10-19           2018-10-21
                                grub             2.03.0-8             2.03.0-9
                            linux414            4.14.77-1            4.14.78-1
                    linux414-headers            4.14.77-1            4.14.78-1
                            linux418            4.18.15-1            4.18.16-1
                    linux418-headers            4.18.15-1            4.18.16-1
                      linux419 4.19rc8.1019.gc7b70a6-1 4.19rc8.1021.g23469de-1
              linux419-headers 4.19rc8.1019.gc7b70a6-1 4.19rc8.1021.g23469de-1
                             linux44            4.4.161-1            4.4.162-1
                     linux44-headers            4.4.161-1            4.4.162-1
                             linux49            4.9.134-1            4.9.135-1
                     linux49-headers            4.9.134-1            4.9.135-1
                             mhwd-db              0.6.3-3              0.6.3-4
                         grub-fedora                    -        2.03.62.f29-2

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2018-10-19           2018-10-21
                             openssh              7.8p1-1              7.9p1-1
                              tzdata              2018e-2              2018f-2

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2018-10-19           2018-10-21
                 calamares-git 3.2.3.r5086.7bd99940b-1 3.2.3.r5087.a8a317140-1
                        gtk3-classic          3.24.1-2 3.24.1+33+g615fa7cfb6-1
                     libxfce4ui-gtk3             4.13.4-2             4.13.4-3
                   libxfce4util-gtk3             4.13.2-2             4.13.2-4
                  linux419-acpi_call           1.1.0-0.26           1.1.0-0.27
                   linux419-bbswitch             0.8-0.26             0.8-0.27
                   linux419-catalyst   1:15.201.1151-0.26   1:15.201.1151-0.27
                linux419-ndiswrapper            1.61-0.26            1.61-0.27
                     linux419-nvidia        1:410.66-0.26        1:410.66-0.27
               linux419-nvidia-340xx         340.107-0.26         340.107-0.27
               linux419-nvidia-390xx          390.87-0.26          390.87-0.27
                   linux419-nvidiabl            0.88-0.26            0.88-0.27
                      linux419-r8168        8.045.08-0.26        8.045.08-0.27
                        linux419-spl          0.7.11-0.26          0.7.11-0.27
                   linux419-tp_smapi            0.41-0.26            0.41-0.27
                linux419-vhba-module        20161009-0.26        20161009-0.27
   linux419-virtualbox-guest-modules          5.2.20-0.26          5.2.20-0.27
    linux419-virtualbox-host-modules          5.2.20-0.26          5.2.20-0.27
                        linux419-zfs          0.7.11-0.26          0.7.11-0.27
                   linux44-acpi_call            1.1.0-113            1.1.0-114
                    linux44-bbswitch              0.8-113              0.8-114
                    linux44-catalyst    1:15.201.1151-113    1:15.201.1151-114
                 linux44-ndiswrapper              1.61-81              1.61-82
                      linux44-nvidia           1:410.66-1           1:410.66-2
                linux44-nvidia-340xx           340.107-18           340.107-19
                linux44-nvidia-390xx             390.87-7             390.87-8
                    linux44-nvidiabl             0.88-113             0.88-114
                       linux44-r8168          8.045.08-35          8.045.08-36
                         linux44-spl             0.7.11-3             0.7.11-4
                    linux44-tp_smapi             0.41-113             0.41-114
                 linux44-vhba-module          20161009-81          20161009-82
    linux44-virtualbox-guest-modules             5.2.20-1             5.2.20-2
     linux44-virtualbox-host-modules             5.2.20-1             5.2.20-2
                         linux44-zfs             0.7.11-3             0.7.11-4
                  manjaro-tools-yaml             0.15.9-2             0.15.9-3
                           pamac-dev         7.2.0beta1-1           7.2.0rc2-1
         pamac-dev-tray-appindicator         7.2.0beta1-1           7.2.0rc2-1
               gtk-update-icon-cache                 - 3.24.1+33+g615fa7cfb6-0
                                gtk3                 - 3.24.1+33+g615fa7cfb6-0

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-10-19           2018-10-21
                             bijiben             3.30.1-1             3.30.2-1
                                bind             9.13.3-1             9.13.3-2
                          bind-tools             9.13.3-1             9.13.3-2
                              bzflag             2.4.16-1             2.4.18-1
                               cairo            1.15.14-1             1.16.0-1
                         file-roller             3.30.0-1             3.30.1-1
                               gedit             3.30.1-1             3.30.2-1
                               meson             0.48.0-2             0.48.1-1

:: Different overlay package(s) in repository multilib x86_64

                             PACKAGE           2018-10-19           2018-10-21
                  lib32-gtk3-classic          3.24.1-2 3.24.1+33+g615fa7cfb6-1
                          lib32-gtk3                 - 3.24.1+33+g615fa7cfb6-0

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2018-10-19           2018-10-21
                         lib32-cairo            1.15.14-1             1.16.0-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

How to enable smooth-bootup

These steps are only needed when not using any Manjaro 18.0-beta-7 or higher install media.

  • install linux418 or linux419
  • install grub-quiet
  • reinstall grub to MBR (Attention: use the correct cmd for your system!)
    • EFI: sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
    • BIOS: sudo grub-install --recheck /dev/sd[X] (change [X] for your device letter. Check via lsblk -f)
  • reboot to see if all is still booting fine
  • check that you have loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 in /etc/default/grub under GRUB_CMDLINE_LINUX_DEFAULT or GRUB_CMDLINE_LINUX and may remove any background settings
  • sed -i -e 's|fsck||g' /etc/mkinitcpio.conf
  • sudo mkinitcpio -P
  • sudo update-grub
  • reboot your system

If you have issues please use this thread:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.

Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.

Items from previous update sets

AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Please update the gitlab for kernel, I need to recompile to activate this (activate by default in Ubuntu/Debian/Fedora) to have my G27 leds works:

1 Like

Doesn’t boot past 2 lines after grub.
(latest stable xfce Nvidia nonfree )

Or just tell me if there is no more patch added on this version....

Momentan ist es nicht möglich, bei KDE Programm- oder Fensterregeln (Individuelles Fensterverhalten) festzulegen. Die Einstellungen lassen sich nicht speichern.

Edit: Wie ich gerade merke, sind Systemklänge (Warnmeldungen etc.) stumm, obwohl der Sound wie gewohnt funktioniert.

Make just a symbolic link, we have did it on Manjaro TNV ISOS

just link in your .config: marco-compton.conf to compton.conf. Easy
Result when you modify or open marco-compton.conf, in real, you open/modify compton.conf

Have error on this :

loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0

need :

quiet loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0

Perhaps it is more explicit to say that we must "quiet" in front of?
no quiet see all in boot but no see my logo have only a black screen and a little error for resume my hibernation volume.


I you modify marco-compton.conf with mate-tweak if these files are linked you modify the compton.conf too

I updated at once last three updates, so I'm not sure if this is because of this update or any of the previous two.

After the update(s), I cannot see any window!

It gets opened (I see it in task bar) but all I see it is just a desktop. I can blindly click or move the window, but nothing changes - everything is invisible!
Please help, I don't know how to solve this.

XFCE 4.14

Have fixed the problem for my grub !
Switch 4.18 to 4.19 is ok a see a logo :smiley:

I can't upgrade my system because my kernel is not found (Linux 4.14.77-1).
Moreover i cannot change kernels because of an nvidia-utils outdated package that i can't upgrade because i am running Linux 4.14.77-1.

How can I update without having to reinstall the whole system from scratch ?



Screencasts/Screenrecords (with simplescreenrecorder, recordmydesktop, vlc) don't work properly if you use compton, or compiz.
Don't work on KDE, Cinnamon too.
Seems to be manjaro related, because working as intended on Linux Mint with different desktops.

@philm - Is there a webpage under manjaro.org where the supported kernels are listed or can be listed if it is not already? So that everybody can keep an eye whenever they want? And maybe you just have to link it to this Stable updates forum post?
I feel this will make it easy for you guys. And since it is the list of Kernels which is supported by Manjaro, it also is a good thing to be listed somewhere in the the manjaro.org website. What do you think?

No issues with the update! Smooth as usual. Thanks peeps!

Kernel(s): linux414 & linux49.

It's already listed in Manjaro Settings Manager and each update on News page (https://manjaro.org/news/).

After the update, I restarted my computer. One time it froze but I shut down and reopened it, there is no problem.

Ufff! That is true! I completely forgot about that!
OK. I redact my request! :slight_smile:
Thanks @xfix!

A bit more info, maybe it will help somebody to narrow things down:

I can see Settings Manager, and I can see loading scrrens of e.g. Libre Office or Gimp. But when the main window should appear, everything is back to invisible.

I've also tried 4.9 kernel. Didn't help.
Tried switching to the testing branch, but there was nothing to update.

I don't even know where to start looking for a potential problematic package.

EDIT: I've found it. There is some problem with Compton. When I kill Compton, my windows are visible.

I found the offender: in the opacity settings of Compton, both "default opacity of inactive windows" and "default opacity for active windows" were set to 0.00!

Forum kindly sponsored by