[Stable Update] 2018-12-04 - Systemd

Hi community,

Welcome to another stable update.


Seems with our last update we crashed a lot of desktops, especially Cinnamon, Gnome, Mate and others. We still assume the issue is due to commits in systemd. Therefore we had downgraded that packages again to the known working version v239.6. If you already running v239.303-1 or higher, don't worry. Nothing to be done on your end. Since there are multiple security issues with that version, we have to see on how we fix that.

Everyone who want to test newer systemd packages, can grap them from here.

We hope with all these changes Manjaro to be more efficient for you all.

The Iconic Spitfire: Now Quad-Core!


Visit StationX now!

Manjaro v18.0.1 RC1 released!

If you are curious about the latest Manjaro-Illyria 18.0.1 release, you now have the opportunity to download XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.

Current supported Kernels

  • linux316 3.16.61
  • linux318 3.18.128 [EOL]
  • linux44 4.4.166
  • linux49 4.9.142
  • linux414 4.14.85
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.6
  • linux414-rt 4.14.78_rt47
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Sync Package Updates (Sun Dec 2 08:47:30 CET 2018)

  • stable core x86_64: 4 new and 4 removed package(s)
  • stable multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2018-12-02           2018-12-04
                          libsystemd            239.303-1              239.6-2
                             systemd            239.303-1              239.6-2
                  systemd-resolvconf            239.303-1              239.6-2
                  systemd-sysvcompat            239.303-1              239.6-2

:: Different overlay package(s) in repository multilib x86_64

                             PACKAGE           2018-12-02           2018-12-04
                       lib32-systemd            239.303-1              239.6-2

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

"warning: systemd: local (239.303-1) is newer than core (239.6-2)" What do I do?

As said in this announcement, systemd packages has been downgraded to an older version. Hence, as long as the version installed on your system will be on a higher version, you'll receive a warning.

If you already have systemd 239.303 on your system and you have no problem with it, you can just ignore the warning and continue to use systemd 239.303. There's no need to do any action.

If you are still interested to downgrade systemd to 239.6, you can do the downgrade with pamac upgrade --enable-downgrade or sudo pacman -Syyuu.

When checking for updates, Pamac (GUI) freeze at a certain percentage.

Devs are aware of this problem.

Fortunately, this problem doesn't happens everytime. If you have the patience to kill the process each time Pamac freezes, eventually, you should be able to get through the process and be able to apply updates.

As far as we know, Pamac CLI doesn't seems to be affected by this problem at all.

How do I do updates via TTY-terminal?

  • Press CTRL+ALT+F2 (or F3, F4, F5, F6) to go into a pure command line interface.
  • Log in with your credentials.
  • Once logged in, you'll have access to a CLI shell, like if you were using a terminal. Use pamac upgrade or sudo pacman -Syyu (or other equivalent command) to update your system.

To go back to your regular desktop, press CTRL+ALT+F7. On some systems, it can be CTRL+ALT+F1 instead.

Items from previous update sets

i3 changed its default config path

It seems that (from version >= 4.16) i3 is looking for its configuration in ~/.config/i3/config instead of ~/.i3/config.
Copy your config to the new path and all should work as before. (reported from an i3-gaps user).

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.

Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.

AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


I went to update using sudo pacman - Syyu and got this output. Does it mean anything good or bad? Thanks in advance for any help :slight_smile:

:: Synchronizing package databases...
 core                                           147.4 KiB  1915K/s 00:00 [########################################] 100%
 extra                                         1826.8 KiB  3.11M/s 00:01 [########################################] 100%
 community                                        5.1 MiB  3.09M/s 00:02 [########################################] 100%
 multilib                                       185.0 KiB  2.70M/s 00:00 [########################################] 100%
:: Starting full system upgrade...
warning: lib32-systemd: local (239.303-1) is newer than multilib (239.6-2)
warning: libsystemd: local (239.303-1) is newer than core (239.6-2)
warning: systemd: local (239.303-1) is newer than core (239.6-2)
warning: systemd-sysvcompat: local (239.303-1) is newer than core (239.6-2)
 there is nothing to do


that's the reason of your warning.. as the package were downgraded and then are newer on your system.

if your system is running fine.. nothing to do.. you will just have the newer version that seems to cause problem for some.. and your system will be updated as usual when newer version will be available.

if you really want to downgrade to the state of the repos

sudo pacman -Syyuu


Okay thank you very much for the explanation I appreciate it. Also, what exactly is the difference between pacman -Syyu and -Syyuu?

the double "u" is the option to "downgrade" in case you have newer package then the repos like as now.

man pacman:

-u, --sysupgrade
Upgrades all packages that are out-of-date. Each currently-installed package will be examined and upgraded if a newer package exists. A report
of all packages to upgrade will be presented, and the operation will not proceed without user confirmation. Dependencies are automatically
resolved at this level and will be installed/upgraded if necessary.

       Pass this option twice to enable package downgrades; in this case, pacman will select sync  packages whose versions do not match with the local
       versions. This can be useful when the user switches from a testing repository to a stable one.

I'm still unable to boot with Linux kernel 4.19.6-1 and systemd 239.6-2. With Linux kernel 4.14.85-1 and same systemd version is working fine.

What I have is working fine:
warning: lib32-systemd: local (239.303-1) is newer than multilib (239.6-2)
warning: libsystemd: local (239.303-1) is newer than core (239.6-2)
warning: systemd: local (239.303-1) is newer than core (239.6-2)
warning: systemd-sysvcompat: local (239.303-1) is newer than core (239.6-2)
there is nothing to do


Well new kernels introduces the following changes to the default I/O scheduler, what the reason behind these changes? I understand quite much cause of spiritfire probably uses SSD and you default new kernel to mq-deadline but how it can possible hit performance under regular HDD's?

cat /sys/block/sda/queue/scheduler
[mq-deadline] kyber bfq none

The phoronix.com tests shows some upsets with facebook kyber and there is no regular deadline or cfq anymore, as well as bfq-sq it was replaced with regular bfq for now. I have a pretty common HDD from notebook I try to test it with hdparm don't think another benchmarks needs to be executed. Then test regular bfq against mq-deadline and probably leave bfq or none (noop).

I just disable all mitigations and power management on my old E4500 Intel Core2 CPU cause when these on have has recently few system freezes completely. And use some irqpoll and pci quircks for safety and testing. If you interested in or have some issues you can pick what you want to test with your machine setup.
I have also the following on my grub commandline from /etc/default/grub:
Some options are doing the same and posted as twice just for safety of their removal from the kernel I don't know the reason behind few different options doing the same stuff called differently. Its not recommended to having two same acting options on the grub cmdline but I prefer to stay like these. Somebody free to pick up whatever relevant options to their setups and watch here for defailed explanation https://archived.forum.manjaro.org/t/stable-update-2018-12-04-systemd/67536/8:

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID= rw resume=/dev/disk/by-uuid/ acpi_osi=Linux acpi=force acpi_enforce_resources=lax radeon.dpm=1 radeon.audio=1 hpet=force clocksource=hpet elevator=bfq-sq pti=off l1tf=off spectre_v2=off spec_store_bypass_disable=on nospectre_v1 nospec_store_bypass_disable intel_pstate=disable intel_idle.max_cstate=0 processor.max_cstate=0 nospectre_v2 nopti spectre_v2_user=off irqpoll pci=ioapicreroute,use_crs,routeirq,pcie_bus_peer2peer,realloc quiet rd.udev.log-priority=3

PPS Just removed my root and swap UUID doenst matter but for safety...and I double posted these 02-04 December, sorry I do the same in grub despite Linus wasn't recommends doing so ;D I don't care ;D

Added some info about " “warning: systemd: local (239.303-1) is newer than core (239.6-2)” What do I do?". Most of it is pretty much redundant to what is said in announcement though.

Feel free to modify it, I made it pretty quickly.

1 Like

The changes are coming from upstream. Single queue schedulers like cfq are planned to disappear in 4.21.

There is no performance increase for HDD's.

Previous systemd errors are now fixed after downgrading. Thank you!:grinning:

All good my end, XFCE (stable) kernel 4.14.

On a side note @philm any chance of having this (fix for kernel bug 201685) through a bit earlier to the 4.19 kernel.

Thanks :grin:


And until the fix (4.19.7-rc1-2), users should disable blk-mq on 4.19 should not use "none" scheduler on blk-mq.

More info from that "EXT4 File-System Corruption" bug (that wasn't a ext4 bug after all).

1 Like

I already answered some of your questions in the 2018-12-02 update thread.

It's already included (see Manjaro's gitlab page), just wait for the next update.


Syncing package databases ...
Starting full system update ...
Warning: lib32-systemd: local (239.303-1) is newer than multilib (239.6-2)
WARNING: libsystemd: local (239.303-1) is newer than core (239.6-2)
WARNING: systemd: local (239.303-1) is newer than core (239.6-2)
WARNING: systemd-sysvcompat: local (239.303-1) is newer than core (239.6-2)
Error: could not open file /var/lib/pacman/local/cups-pk-helper-0.2.6-2/desc: No such file or directory

Yeah I saw Phil added the patch 3hrs after I asked about it. :+1:

Time for me to build a kernel.....

Already pushed to unstable ...


I always have a rescue DVD as my first boot option (and I pick boot from HD there if I do not want to "rescue")
With this update I got a lot of IO error on sr0 (which is not that surprising since it is a DVD) the update almost stopped there with eternal error messages.

I (barely) managed to eject my DVD (it ejected after a long time so I could remove the DVD) and the update finished normally.

Forum kindly sponsored by