[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine

You're absolutely right, lol! :slight_smile: I'm a bit of a giggler, and used to love watching the program. You too?

3 Likes

Ooh yes, with bells on! That show [like you, apparently] always had me in stitches. It was soooo droll. Sigh, such a long looooooooooooong time ago now... sob sniff. I'm so pleased to learn another Manjaroo remembers & loves it. :grin:

3 Likes

Lol, yes ... there's some great clips on Youtube [Freetube] ... MUTTLEY My Favorite Cartoon Dog (The Best Dog Laugh Ever) . All the different contraptions that Dasterdly fell foul of as well ... rasenfrasen :rofl:
There were so many great programmes back then. Potty time was very funny too. Roobarb and Custard. Bagpuss. Great to rewatch clips now. :+1:t2:
Great to meet a fellow Muttley aficionado :smiley:

3 Likes

and @Kadee

Stop OT :wink: :slight_smile:

79be8ec76bf8a230d04553728e354a52--animated-cartoons-cartoon-fun
dd-m

3 Likes

Hey, what's the big idea? How come you've crashed our DD&M channel? How dare you go OT by talking about Manjaro Stable Updates! Go start your own thread for such immaterial stuff. We know what's truly important -- DD&M :stuck_out_tongue_winking_eye:

3 Likes

Updated a few minutes ago using TTY (my first Manjaro major update!). Everything went smoothly although I got the ptyqt5 error. However waiting for a few days before updating, reading the announcements and applying the proposed fixes made this update a breeze! Thanks for the great work! I used the following procedure to update (taken from Applying manjaro update from TTY, credits to @rahulprabhakar):

  1. Save and close all application.

  2. Logout [Eg. In KDE press Ctrl + Alt + Del and then click logout]

  3. Press Ctrl + alt + F2 and switch to TTY2. You can also try Ctrl + alt + F3 for TTY3 if required.

  4. Login on TTY2

  5. Run nmtui (Ncurses based network manager gui to connect to Lan / Wifi.)

  6. Run sudo pacman-mirrors -f 5 (Update mirrorlist with 5 fastest up to date mirrors)

  7. Run sudo pacman -Syyuw (First only download all packages to manage breaking change during package installation)

  8. Run sudo pacman -Syu

  9. Done with update, Run systemctl reboot

5 Likes

I used pamac in the ttyl and encountered this problem several times. I then used pacman and had a smooth update.

sorry for my frustration but I was already fed up by lot's of bug's I've been experiencing before, but now that libre-office and octopi became unusable I'm pretty sure I'll be reformatting my manjaro laptop soon and move on to some other distro.

Originally coming from Windows and still using it at work and my desktop at home, I'm used to the "Don't turn off you computer" message that is shown on screen during long update processes. Is it possible that some Manjaro users during this last update did a hard reset with the Power button during this update thinking that their computer had crashed and that caused an issue on reboot?

I didn't see any messages during reboot after this update, as I have bootsplash installed and enabled, but knowing what I know, I just waited for the update to complete and had no problems whatsoever.

I also run Manjaro on an old Dell laptop with no fancy configuration, so maybe all the bugs have been worked out in the linux software for my level of hardware.

2 Likes

You are probably fine. (Remember that it is only a bit less than 20% of people having 'problems'.)

If you did not pay attention at the time to the output - I generally read/skim through mine before closing the terminal - much of it is written to var/log/pacman.log.

ublux

8 Likes

In my experience 95% of new people that starts in a linux enviroment, starts with Ubuntu.
Hell i've used it when i started...
Is like music (or whatever you want to put on)... We all started with the commercial music and end up having our taste and going in deeper.
For the linux community i think is exactly the same.

6 Likes

Could be... But i doubt it... Somehow in the middle of the proccess of the update while still in GUI the system breaks and ends up in a black screen.
Systemd and pamac aparently don't like each other.

1 Like

Do not forget to update your mirrors.

2 Likes

I updated my desktop running Manjaro KDE today, and as with my laptop, all went well!

2 Likes

From the Manjaro Wiki: Use pacman-mirrors to Set the Fastest Download Server

Did the same, nothing to pay attention to be found there. Had to do the reboot via command line though. So I guess it worked fine.

Another interesting "gotcha" for the few people who, like me, use at jobs.
I found that after the update, my at jobs weren't running. Putting atd in debug mode, I saw an "authentication error" message when a job should have started.
A bit of searching reveals that the fix is to create /etc/pam.d/atd with the following contents:

auth required pam_unix.so
account required pam_unix.so
password required pam_unix.so
session required pam_unix.so

I don't pretend to understand what this is doing, or why the problem started after the update (neither pam nor atd were updated), but it works, and that's good enough for me.

1 Like

Instead of using nmtui to get network access, simply download the updates in GUI without installing them: sudo pacman -Syuw.
Then switch to TTY and run sudo pacman -Su.

1 Like

I updated my laptop with the XFCE-terminal, and have deleted

/usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc

that was belonging to no package.

I rebooted my computer (with the 2 minutes announced countdown during the first shut down) and it worked but after the following (or the following of the following? - in any case I have not changed anything in Clamav in the meantime) reboot, I had the following message when it was shutting down: "A stop job is running for Clam Antivirus userspace demon" with 1 minute 30seconds countdown. After the boot, a new message appeared telling me that ClamAV-milter is failed.

That is why I made:

systemctl status clamav-milter
● clamav-milter.service - 'ClamAV Milter'
   Loaded: loaded (/etc/systemd/system/clamav-milter.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2019-02-22 13:47:55 CET; 1h 31min ago
  Process: 633 ExecStart=/usr/bin/clamav-milter --config-file /etc/clamav/clamav-milter.conf (code=exited, status=1/FAILURE)

févr. 22 13:47:55 XX systemd[1]: Starting 'ClamAV Milter'...
févr. 22 13:47:55 XX clamav-milter[633]: ERROR: Parse error at /etc/clamav/clamav-milter.conf:296: Unknown option ScanOnAccess
févr. 22 13:47:55 XX clamav-milter[633]: /usr/bin/clamav-milter: cannot parse config file /etc/clamav/clamav-milter.conf
févr. 22 13:47:55 XX systemd[1]: clamav-milter.service: Control process exited, code=exited, status=1/FAILURE
févr. 22 13:47:55 XX systemd[1]: clamav-milter.service: Failed with result 'exit-code'.
févr. 22 13:47:55 XX systemd[1]: Failed to start 'ClamAV Milter'.


The lines 295-296 of /etc/clamav/clamav-milter.conf is:

# Enables on-access scan, requires clamav-daemon.service running
ScanOnAccess true

That is why I have checked:

● clamav-daemon.service - Clam AntiVirus userspace daemon
   Loaded: loaded (/usr/lib/systemd/system/clamav-daemon.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2019-02-22 13:47:55 CET; 1h 45min ago
     Docs: man:clamd(8)
           man:clamd.conf(5)
           https://www.clamav.net/documents/
  Process: 5030 ExecReload=/bin/kill -USR2 $MAINPID (code=exited, status=0/SUCCESS)
 Main PID: 632 (clamd)
    Tasks: 2 (limit: 4915)
   Memory: 3.6M
   CGroup: /system.slice/clamav-daemon.service
           └─632 /usr/sbin/clamd --foreground=true

févr. 22 14:22:57 XX clamd[632]: Fri Feb 22 14:22:57 2019 -> SelfCheck: Database status OK.
févr. 22 14:32:57 XX clamd[632]: Fri Feb 22 14:32:57 2019 -> SelfCheck: Database status OK.
févr. 22 14:42:57 XX clamd[632]: Fri Feb 22 14:42:57 2019 -> SelfCheck: Database status OK.
févr. 22 14:49:49 XX systemd[1]: Reloading Clam AntiVirus userspace daemon.
févr. 22 14:49:49 XX systemd[1]: Reloaded Clam AntiVirus userspace daemon.
févr. 22 14:49:50 XX clamd[632]: Fri Feb 22 14:49:50 2019 -> Reading databases from /var/lib/clamav
févr. 22 14:50:02 XX clamd[632]: Fri Feb 22 14:50:02 2019 -> Database correctly reloaded (6998299 signatures)
févr. 22 15:00:02 XX clamd[632]: Fri Feb 22 15:00:02 2019 -> SelfCheck: Database status OK.
févr. 22 15:10:03 XX clamd[632]: Fri Feb 22 15:10:03 2019 -> SelfCheck: Database status OK.
févr. 22 15:21:38 XX clamd[632]: Fri Feb 22 15:21:38 2019 -> SelfCheck: Database status OK.

clamav-daemon.service is apparently working and has the PID 632 whereas the clamav-milter.service has the following PID 633, so I cannot understand what is not working.

I am writing it here since I think that it should be linked with the update.

Thanks a lot for the update and the work the developers made and for your help.

Forum kindly sponsored by