[Stable Update] 2019-02-23 - Kernels, Systemd, Browsers, Plasma5, Python, Haskell

I am using KDE 5.15.1 with the kernel 4.20.11-1
Since the last update I have the problem that the computer reboot or shutdown with the following message "TLP System startup/shutdown" sticks for 90 seconds. After that the shutdown or reboot is executed correctly. There are no problems when starting.
There are a lot of threads on the TLP issue here in the forum. However, these always concern the problem that the computer does not start in the graphical user interface. I don't have any problems with that.

Bei meinen sieben Betriebssystemen hat insgesamt gesehen alles geklappt. Ich habe bei meinem Desktop-Rechner via chroot und mittels pacman -Syyu gearbeitet. Bei meinem Laptop hat das nicht geklappt, weil ich eine gesonderte var-Partition habe und es nicht schaffe, sie in den chroot-Befehl zu integrieren. Vor dem Anmelden in der grafischen Oberfläche bin ich mittels Strg+Alt+F3 in die Konsole gewechselt und habe dann den Befehl pacman -Syyu gegeben.

Einmal gab es ein Problem, das auch im internationalen Forum angesprochen wurde. Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien) python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc existiert im Dateisystem Fehler sind aufgetreten, keine Pakete wurden aktualisiert.Der vorgeschlagene Befehl hat nicht geholfen;pacman -S python-pyqt5 --overwrite ‘*’also habe ich die Datei umbenannt.
Am Tag vorher hatte ich einen Netzwerkdrucker HP HP_ColorLaserJet_MFP_M278-M281 eingerichtet. Der Scanner ließ sich nicht mehr ansprechen nach dem Update. Durch Zufall stieß ich darauf, dass er ein neuere Version eines Plugins brauchte: hplip-3.19.1-plugin.run Man erhält es auf der Webseite von HP.

[Veröffentlicht auf https://archived.forum.manjaro.org/, https://de.manjaro.org/ und https://www.manjaro-forum.de/]

Hi all I have no issues on my desktop after updating but on my laptop the touchpad horizontal is a bit messed up. It hardly moves the cursor in the horizontal, vertical seems about normal.
The laptop is a hp pavillion g6 with AMD E2 processor. I'm using the 4.14 kernal but did try switching to the 4.19 and that doesn't boot at all.

Plasma TTY. Everything went smoothly.

1 Like

I used the TTYP to update my Dell XPS running Manjaro KDE w/ kernel 4.19. Everything went perfectly.

I updated both Manjaro 4.19 & 4.14 using the XFCE-terminal (next time I will try via TTY2 like it is described there). Everything went good but I remarked now that the keyboard layout that I have personalised is not anymore loaded... This was not the case during the last updates.

I did update my xfce Eee-PC (on tty) and all went smooth
Also a xfce Medion Notebook (on tty) all ok

This is really weird. I refreshed the mirrors page and my primary one is said to be up to date. However, these updates don't show up to me!

sudo pacman -Sy, pamac checking for updates, everything: as far as I can see Plasma is still on 5.15.0, latest Brave is 0.59.35-1, etc.

Edit: Ok, for some reason my mirror list got wiped somewhere around the previous update. sudo pacman-mirrors -f now solved it for me.

Guys what could be a reason that I missed libreOffice on my system? Also there are no Education menu in main application menu. Do we have minimal KDE iso? Looks like - no.

 ██████████████████  ████████     OS: Manjaro 18.0.3 Illyria
 ██████████████████  ████████     Kernel: x86_64 Linux 4.19.24-1-MANJARO
 ██████████████████  ████████     Uptime: 7h 29m
 ████████            ████████     Packages: 1094
 ████████  ████████  ████████     Shell: bash 5.0.0
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: KDE 5.55.0 / Plasma 5.15.1
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     GTK Theme: Breath [GTK2/3]
 ████████  ████████  ████████     Icon Theme: maia
 ████████  ████████  ████████     Font: Noto Sans Regular
 ████████  ████████  ████████     CPU: AMD Ryzen 5 1600X Six-Core @ 12x 3.6GHz
 ████████  ████████  ████████     GPU: GeForce GTX 970
                                  RAM: 7524MiB / 16039MiB

P.S. it's a latest ISO from manjaro.org

Yeah, to figure out where I missed LibreOffice I studied how create Manjaro spins. Good overview video https://www.youtube.com/watch?time_continue=41&v=B--je--m0VI from Philip

I see LibreOffice was turned off to install #>extra libreoffice-fresh not sure why though

Same here, TLP sticking when going for reboot or shutdown. Xfce 4.12 (coming from Mnjaro 17), Latest Kernel.

Otherwise, everything worked smoothly. Thanks for all the work!

Updated from TTY and everything went smoothly. However, I found out later that I got the following error when trying to connect to my VPN from the terminal using openconnect:

Connected as XXX.XXX.XXX.XX, using SSL, with ESP in progress
Unit dbus-org.freedesktop.resolve1.service not found.
Unit dbus-org.freedesktop.resolve1.service not found.
ESP session established with server

A quick Google search about this error brought me to the solution (taken from https://bugs.archlinux.org/task/61738?project=1&cat[0]=31&string=systemd), which is to reactivate systemd-resolved.service using the command

systemctl enable systemd-resolved.service

After that, openconnect works again.

I don't know whether the last systemd update (or previous one) did fail to reactivate this service but I guess it's quite possible.

No issues. Everything went smoothly!

Kernels: linux419 & linux414

Update on 12 Systems and 1 VB without Problems.


XFCE, 4.19.24-1

Everything went smoothly! Thanks for all the hard work.

Didn't see the forum post, so I updated from the DE. Dorked my kernel (missing ..../modules.devname ignoring) and wouldn't boot on reboot. Was able to rectify in live environment with chroot by reinstalling the kernel. I'll TTY from here on out as standard operating procedure.

1 Like

python-pyqt5: can't delete /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc
Dependency: manjaro-printer

I've moved away this file, and everything continue without troubles.

Thanks guys

Where you my Calculus teacher? She said that all the time. The semester ended with a bunch of traumatized kids who knew nothing about calculus.

1 Like

Post update: You HAVE to update in tty this time. It is very imprortant. I made the mistake of not doing this via tty, and ended up having to restore a timeshift snapshot! Anyway, my bad. Everything else went smoothly though!

1 Like

Didnt read the update notes... Fail # 1
Tried to update using YAY.... Fail # 2

Update crashed and tried to reboot part way though, locked up solid and had to do a manual restart. System booted fine but no network manager and many other things broken.

Read the update notes, used timeshift to restore (always have backups Win #1)
Updated using TTY and went flawlessly Win # 2

In conclusion;

Always read the update notes and have verified back ups!!!!


Forum kindly sponsored by