[Stable Update] 2019-02-23 - Kernels, Systemd, Browsers, Plasma5, Python, Haskell

I used the TTYP to update my Dell XPS running Manjaro KDE w/ kernel 4.19. Everything went perfectly.

I updated both Manjaro 4.19 & 4.14 using the XFCE-terminal (next time I will try via TTY2 like it is described there). Everything went good but I remarked now that the keyboard layout that I have personalised is not anymore loaded... This was not the case during the last updates.

I did update my xfce Eee-PC (on tty) and all went smooth
Also a xfce Medion Notebook (on tty) all ok

This is really weird. I refreshed the mirrors page and my primary one is said to be up to date. However, these updates don't show up to me!

sudo pacman -Sy, pamac checking for updates, everything: as far as I can see Plasma is still on 5.15.0, latest Brave is 0.59.35-1, etc.

Edit: Ok, for some reason my mirror list got wiped somewhere around the previous update. sudo pacman-mirrors -f now solved it for me.

Guys what could be a reason that I missed libreOffice on my system? Also there are no Education menu in main application menu. Do we have minimal KDE iso? Looks like - no.

 ██████████████████  ████████     OS: Manjaro 18.0.3 Illyria
 ██████████████████  ████████     Kernel: x86_64 Linux 4.19.24-1-MANJARO
 ██████████████████  ████████     Uptime: 7h 29m
 ████████            ████████     Packages: 1094
 ████████  ████████  ████████     Shell: bash 5.0.0
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: KDE 5.55.0 / Plasma 5.15.1
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     GTK Theme: Breath [GTK2/3]
 ████████  ████████  ████████     Icon Theme: maia
 ████████  ████████  ████████     Font: Noto Sans Regular
 ████████  ████████  ████████     CPU: AMD Ryzen 5 1600X Six-Core @ 12x 3.6GHz
 ████████  ████████  ████████     GPU: GeForce GTX 970
                                  RAM: 7524MiB / 16039MiB

P.S. it's a latest ISO from manjaro.org

Yeah, to figure out where I missed LibreOffice I studied how create Manjaro spins. Good overview video https://www.youtube.com/watch?time_continue=41&v=B--je--m0VI from Philip

I see LibreOffice was turned off to install #>extra libreoffice-fresh not sure why though

Same here, TLP sticking when going for reboot or shutdown. Xfce 4.12 (coming from Mnjaro 17), Latest Kernel.

Otherwise, everything worked smoothly. Thanks for all the work!

Updated from TTY and everything went smoothly. However, I found out later that I got the following error when trying to connect to my VPN from the terminal using openconnect:

Connected as XXX.XXX.XXX.XX, using SSL, with ESP in progress
Unit dbus-org.freedesktop.resolve1.service not found.
Unit dbus-org.freedesktop.resolve1.service not found.
ESP session established with server

A quick Google search about this error brought me to the solution (taken from https://bugs.archlinux.org/task/61738?project=1&cat[0]=31&string=systemd), which is to reactivate systemd-resolved.service using the command

systemctl enable systemd-resolved.service

After that, openconnect works again.

I don't know whether the last systemd update (or previous one) did fail to reactivate this service but I guess it's quite possible.

No issues. Everything went smoothly!

DE: XFCE.
Kernels: linux419 & linux414

Update on 12 Systems and 1 VB without Problems.

DK3

XFCE, 4.19.24-1

Everything went smoothly! Thanks for all the hard work.

Didn't see the forum post, so I updated from the DE. Dorked my kernel (missing ..../modules.devname ignoring) and wouldn't boot on reboot. Was able to rectify in live environment with chroot by reinstalling the kernel. I'll TTY from here on out as standard operating procedure.

1 Like

python-pyqt5: can't delete /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc
Dependency: manjaro-printer

I've moved away this file, and everything continue without troubles.

Thanks guys

Where you my Calculus teacher? She said that all the time. The semester ended with a bunch of traumatized kids who knew nothing about calculus.

1 Like

Post update: You HAVE to update in tty this time. It is very imprortant. I made the mistake of not doing this via tty, and ended up having to restore a timeshift snapshot! Anyway, my bad. Everything else went smoothly though!

1 Like

Didnt read the update notes... Fail # 1
Tried to update using YAY.... Fail # 2

Update crashed and tried to reboot part way though, locked up solid and had to do a manual restart. System booted fine but no network manager and many other things broken.

Read the update notes, used timeshift to restore (always have backups Win #1)
Updated using TTY and went flawlessly Win # 2

In conclusion;

Always read the update notes and have verified back ups!!!!

7 Likes

I can't say for sure it happened on this update but I'm assuming this one was responsible. I usually use kernel 4.14, but I check in on 4,20 now and then.

The last time I tried 4,20 a few weeks back my wifi driver for rtl8812 suffered a breakage, The good news was, it is now working again on 4.20.

The bad news is, I discovered a bug involving my NFS share mounts that was very strange. I had my NFS shares initially mounted via fstab and when I first switched to 4,20. I encountered a 2 min stop job at shutdown because of my NFS mounts.

I knew that a systemd mount unit sometimes handles these issues better, so I disabled my share mounts in fstab, and enabled my systemd mount units for the shares.

With the mount units the stop job at shutdown was resolved, so I was happy. Until a little while later, when I tried to suspend. Then the system would not enter suspend because of issues with my NFS shares again.

SO...back to 4,14 where all is fine again.

...AND only use sane appropriate update commands.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by