[Stable Update] 2019-02-23 - Kernels, Systemd, Browsers, Plasma5, Python, Haskell

Updated from TTY -- everything went smoothly. Dell XPS running KDE with kernel 4.19. Cheers.


All 5 KDE machines updated through a tty. No issues to report :+1:


Updated TTY after reading announcement and smooth result. Many thanks.
Cheers to all.

TTY + systemctl isolate multi-user.target. All working on my end.

Edit: Other machines TTY only. All working.

Update was successful but after restart kde plasma failed as mentioned in known issue.
All the autostart app opens but launcher is not visible.

Tried the above command but db.lck file not found.

How can I solve this?

Edit: startx from tty starts the plasma smoothly.

I will restart and check if this solves my problem.

NO LUCK even after restart. I will follow the restart plasma steps one by one again.

Updated three laptops using Pamac, no problemo.

everything smoth...

Yeah, I learnt my lesson the hard way. At least the impact was mostly graphical for me (plasma, kde related stuff).

Let us hope we remember this. How about posting this in the Tutorials section, so others in a similar position to you could fix it?

what an absolute madlad to do it in konsole, kudos to you!

I found an issue with the Manjaro 18.03 ISO for the 6th stable update, posting here as I didn't want to bump an obsolete post. When I attempt to boot into Manjaro 18.03 using USB, Grub failed to load, saying "grub_filters_list was not found", and I was dropped into an emergency shell (with no functionality), I had to use the 18.02 ISO. I don't know if that issue has been fixed.

Did you try to use "sudo pacman -Syyu" in the console?

I have only one a little "problem". I have Xfce and Qtile, and Qtile is my default enviroment, but LightDM sets Xfce as default.

Yes it shows nothing to update

Lesson learned:

This time I executed pacman -Syyu from TTY and everything goes fine without troubles.

Update went smooth from tty. Budgie DE.

Huh? Why is autologin turned on automatically in this update? There is good reason my system does not log in automatically, so why is an update messing with user settings?

And more importantly... how do I turn it off again?

Edit: anyway, found the setting I needed in the Login Window Settings. Still not amused.

:wink: He who dares wins(and all that stuff blah blah blah)!!:sunglasses:

Manjaro Deepin user checking in. I updated through the terminal. Saw no reason to use TTY to update, a bit of overkill if you ask me. Update went fine and smooth and no issues to report. Thank you kindly to the Manjaro Devs and shoutout to @oberon for being so awesome


Two Dell Laptops updated fine, one is a Studio 1535 Duo Core, legacy BIOS, The other is a Dell Inspiron 5537 uefi BIOS. Both running kernel 4.19. Used TTY to update.

Third Laptop, Dell Studio 1537 , via TTY, which is almost identical to the Studio 1535 had issues.
First issue was the python issue which stalled the update. I did the sudo pacman overwrite command detailed here and I was able to proceed. After the update I rebooted to an emergency shell with no access to the keyboard. I had error.modules. devname not found. This appeared to be an issue with kernel 4.19 module dependencies.
I was able to boot with a live usb and chroot in, updated grub successfully. I rebooted and same issue. I rebooted and used advanced options and successfully rebooted to my 4.14 kernel. I removed kernel 4.19. Then re-installed kernel 4.19 and now all is well. All installs are xfce

No problems at all; everything is fine (Thinkpad, Gnome). Thank you.

Forum kindly sponsored by