[Stable Update] 2019-03-21 - Kernels, Deepin, Browsers, Pamac, Plasma, Python

-Syyuu forces a downgrade, -Syyu doesn't. It really doesn't make that much of a difference


I got an update request which is not announced here. Is this safe??
sudo pamac checkupdates
3 available updates:
firefox 66.0.1-0 extra
menulibre 2.2.0-4 community
openssh 7.9p1-1.0 core

Yes it is. :slight_smile:



1 Like

everything ok, I thank the developers of manjaro and I thank @Ste74

Kernel 4.19 - Gnome

1 Like

Yep, I'm experiencing issues similar to Dropped into emergency shell without keyboard access due to a failed hibernation ; this completely broke my installation.

Two things of note: (1) I'm not using a laptop; (2) I've never used hibernate mode in Manjaro. I rebooted, actually, because Manjaro stopped recognizing one of my USB flash drives after the upgrade.

I can boot to a Manjaro USB stick, but restoring grub doesn't fix the problem. In other words, I open a terminal and do chroot followed by the usual sudo pacman -Syyuu && sudo update-grub, but that doesn't solve it. Nothing does. I get the same error after reboot, no matter the kernel version.

Without the exact error messages you see, it is difficult to help you. Are you seeing the exact same error messages in that thread? Or is it different?

Please create a separate topic and link it in your post. Read this if you're not sure what information to include.

1 Like

Great. Sounds like Windows in 2000

Problems with nvidia modul 414-rt kernel. Solved in german subforum:

1 Like

Multiple major problems with this update. The update hung in the middle. I was able to complete this with pacman, but that didn't help. My swap partition somehow lost its UUID, and this trivial detail (I have 16GB RAM) apparently was sufficient to yield the "Dropped into emergency shell..." nonsense. The suggested fixes for that accomplished nothing. I ran fsck on the root partition, and that seems to have helped. Now the system starts, but when I try to (GUI) login, my password is not accepted. So I login as root, and discover that my user password is indeed unchanged. WTH?

Most likely this is related to kernel. Maybe try booting another one, preferrably an older LTS. Which one are you on now? What's your laptop exactly?

You are right.
I suspect the loss of your settings must be related to the bunch of new kde plasma packages - although I'm afraid I don't know enough about kde to tell you more about that ... :disappointed:

What hardware are you running?
Please install an alternative kernel and try to boot into that one.
I suggest you try older LTS linux414

This is 414, still no joy; I had to login as root. I'm running an Intel i3 in a desktop with 16GB RAM and an 1TB disk.

Installed XFCE 18.0.4 from DVD, and the network (Realtek r8168) module is not installed because MODPROBE IS BROKEN.

No problems after the update. All is well! :slight_smile:

Kernels linux414 & linux419!

Thank you for the reply. Indeed I am using kernel 5 now and posted about the issue here System cannot boot after updating to kernel 4.19.30-1 - we are testing stuff like reinstall the kernel 419. I didn't have the time to test that but I will today. Cheers!

My Bad. When I made another installation, I shared the /home partition, and the other installation used different UID, causing some X files to be unreadable.

The next problem is that my file size is limited to about 800M, which means I can't run things like Skype and Thunderbird. I'm using kernel 4-19.30 and ext4 on root, xfs on /home. Same problem with 4-14.

= ulimit -Hf

I've never seen this problem before. When I run a fresh installation of Manjaro 18.0.4, I get unlimited file size on the same machine.

You were offline yesterday and now the mirrors are not working properly, tried to update mirrors and got an error with pacman -Syyu

Tired again, this time it went through

Forum kindly sponsored by