[Stable Update] 2019-04-20 - Nvidia, Kernels, Deepin

Hi community,

Our twelfth stable update is online.
With this we upgrade most of our kernels and Nvidia driver to latest version 418.56.
Please note that realtime kernel linux418 has now been removed from the repos. If you are a realtime kernel user you now have the choice to use either LTS linux419-rt or latest linux50-rt (in which we agreed to try CONFIG_HZ_1000 as opposed to CONFIG_HZ_300 in linux419-rt).

Also a bunch of Deepin packages receive updates, aswell as some for Gnome and KDE, Python, Haskell and Grub.
We update Thunar and Thunar-gtk3 to a newer git-snapshot, fixing the right-click 'New Document' bug.

We update gtk3 to 3.24.8, Firefox , Thunderbird and Chromium have new versions, we bring Evolution 3.32.1 and stable release 1.2.2 of Appimagelauncher.

  • vte3 receives its update to 0.56.1

PLEASE NOTE: For now we drop maintaining brave browser in our repos. Please update it from the AUR!

We hope that this update goes smoothly for you and wish you a beautiful Easter weekend!

Manjaro v18.0.4 released!

We updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.15 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.

Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.138 [EOL]
  • linux44 4.4.167 [FZN]
  • linux49 4.9.168
  • linux414 4.14.111
  • linux419 4.19.34
  • linux420 4.20.17 [EOL]
  • linux50 5.0.7
  • linux51 5.1-rc1 (no extramodules yet)
  • linux419-rt 4.19.31_rt18
  • linux50-rt 5.0.7_rt8

A detailed list of the package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

TLP 1.2.1, .pacnew file: Merges may be needed

TLP 1.2.1 got released in [Stable Update] 2019-04-20 update set, replacing TLP 1.1. Therefore, if you have customized your configuration file for TLP (/etc/default/tlp), a .pacnew file will be created when the tlp package will be upgraded. This .pacnew file is the new default configuration file provided by the package. Your old configuration file won't be edited or replaced automatically; by default, your old configuration file will be kept as it is and you will have to merge relevant part the new configuration file manually with a text editor. Guidance can't really be more precise since each person has its own configuration.

You may use a tool such as Meld (package: meld) in order to compare your old configuration file with the .pacnew file and see the differences more easily.

If you haven't modified your configuration file for TLP, normally, you will automatically go on the new configuration file for TLP provided in the package without any manual intervention needed.

If you use the current version of TLPUI (tlpui r109.703bade-1), it may complain with the following error with some settings: "expected item missing in config file." It is most likely because some new parameters introduced with TLP 1.2.1 are not in /etc/default/tlp. To get rid of those messages, you will need to do some merges between your old configuration files and the .pacnew files and manually add all those new settings, even if you end up using the default value for those settings.

TLPUI cannot be launched

There was a bug in a previous version of TLPUI (confirmed on tlpui r89.d6363f0-1) that changed the permissions of /etc/default/tlp to 600 (rw-------). The default permissions for this file is 644 (rw-r--r--).

It is most likely that TLPUI doesn't launch because it doesn't have the right permissions for /etc/default/tlp. TLPUI must be allowed to read that file in order to launch.

First, verify if the permissions of /etc/default/tlp are set correctly. You may verify that with ls -l /etc/default/tlp in a terminal. Here's an example of how the output will look like:

$ ls -l /etc/default/tlp
-rw-r--r-- 1 root root 14238 Apr 11 15:26 /etc/default/tlp

If you have -rw------- instead of -rw-r--r--, change the permissions of that file so this file becomes readable to the group and others too. You may do so in the terminal with sudo chmod 644 /etc/default/tlp.

Once it is done, TLPUI should work properly.

MComix 1.2.1: Can't launch after the upgrade

This is a known issue that is due to breaking changes introduced in python2-pillow 6.0.0 (see this document). It is a package imported from Arch Linux and the issue has already been reported on Arch Linux side. See this ticket on the bug tracker: https://bugs.archlinux.org/task/62242

A true fix requires to do modifications in the source code of MComix.

Since python2-pillow (and python-pillow) is used by many programs, similar problems may happen with other software too.

Submenus in Thunar (File Manager in Xfce) issue

Should now be fixed with thunar-gtk3 1.8.4-3 or thunar 1.8.4-2, whichever you use.

If you used the known workaround and ignored updates for gtk3 or gtk3-classic (and their 32-bits equivalent) in order to keep the package downgraded, you should consider stopping to do so and do the upgrade as you would normally do. Continuing to ignore upgrades for particular packages may become a problem in long term.

Brisk Menu on MATE 1.22: No icons for the categories

Should now be fixed with brisk-menu 0.5.0-3.2.

"Spring cleanup" on Arch Linux: impact on Manjaro

Recently, Arch Linux did a "spring cleanup" of their Community repository (see the full discussion on the mailing list and seach for "spring"). Many package got removed from the Arch Linux official repositories and dropped to the AUR. Therefore, it means that many packages that were in our repositories because they were imported from Arch Linux got removed from our repositories too. Here's a non-exhaustive list of packages that got removed:

  • cherrytree - Hierarchical note taking application featuring rich text and syntax highlighting
  • docky - Full fledged dock application that makes opening common applications and managing windows easier and quicker
  • mate-menu - Advanced menu for MATE Panel, a fork of MintMenu (Not to be confused with mate-menus)
  • medit - GTK+ text editor
  • thermald - The Linux Thermal Daemon program from 01.org
  • wine-staging-nine has been removed / replaced with wine-nine. In case it is installed, it should be removed manually. http://archlinux.2023198.n4.nabble.com/Removing-wine-staging-nine-replaced-with-wine-nine-td4722447.html

If you want to continue to use those packages, you will have to use the AUR from now on.

You may try to do a package request in this category, but note that there is a high chance that your demand will be refused.

Items from previous update sets

Gnome 3.32: Two extensions removed from our repos.

We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extension-topicons-plus-huttli and gnome-shell-extension-taskbar. We won't maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.

Gnome 3.32: Various problems

There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue with a third-party extension (that doesn't come from Manjaro's official repositories) called Extensions.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread and this ticket from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. As a workaround, you may use X.org instead of Wayland for now.

4. Miscellaneous
Some programs don't get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too. (Should be fixed by now.)

My icon theme is not applied anymore for programs like Gnome Terminal, System Monitor, Gnome Screenshot, Gnome Disks, File Roller, etc.

With version 3.32 of these programs, upstream changed the icon used for many programs part of the Gnome Applications. Instead of using a generic icon shared by many programs, they chose to ship a new icon and use it. Therefore, launchers located in /usr/share/applications (.desktop files) for those programs has been modified to use the new icon instead of the generic one. Here's an example with Gnome Terminal.



Since your icon theme most likely doesn't have an icon named org.gnome.X, it falls back to the hicolor theme instead. This is why the icon changed after the system upgrade and "your theme is not applied anymore for those programs."

There is nothing you can really do for now, except living with it for a while. Icon theme designers will have to adapt their theme to the changes made by Gnome developers.

Yaourt: Rest in peace

Yaourt has been removed from our repositories completely. We won't maintain the yaourt package anymore, which means that you will not receive any updates from us for this package. A very old package named yaourt-gui-manjaro has been removed at the same time too.

If you are still using Yaourt, we strongly encourage you to switch to an alternative like Pamac CLI (package: pamac-cli), Trizen (package: trizen), Yay (package: yay) or Pacaur (package: pacaur); and uninstall Yaourt from your system.

In addition to that, we have dropped support for several packages that depended on yaourt: allservers, pacli and pacli-jwm. Those packages has been removed from the official repositories completely.

"Warning: accountsservice: directory permissions differ on /var/lib/AccountsService/users/filesystem: 755 package: 700"

Normally, the permissions of the /var/lib/AccountsService/users/ directory get ajusted automatically to the one in the package at the next boot.

If it doesn't, you can change the permissions manually with sudo chmod 700 /var/lib/AccountsService/users/.

"Replace pamac with extra/pamac-gtk? [Y/n]"

Accept the replacement. The original pamac package is now split into three packages: pamac-gtk, pamac-cli and pamac-common.

vlc-nightly has been dropped

The vlc-nightly package, which was really useful in a time when VLC 3 was not officially out yet, has been dropped on our side and is not in the official repositories anymore. If you still have this package and you want the latest stable version of VLC media player, simply install the vlc package (the vlc-nightly package should be removed at the same time, in the same transaction).

Otherwise, you can continue to use vlc-nightly from the AUR (but you'll have to compile it yourself).

"NOTE, 4.20.17 was the last maintenance release by Greg Kroah-Hartman.; It is recommend to move on to linux50-series." What should I do?

Linux 4.20 (which is not an LTS kernel) is now marked as End Of Life (EOL), so if you want to continue to use an non-LTS kernel, you should consider using Linux 5.0, and also uninstall kernel 4.20 soon.

Keeping EOL kernel installed on your system for too long can lead up to problems for future upgrades (especially if using NVIDIA drivers). When using non-LTS kernel, you must do maintenance/cleanup more often.

" Replace xorg-mkfontdir with extra/xorg-mkfontscale? [Y/n]"

Accept the replacement.

Linux kernel 5.0.X available. Early problems reported.

The newest kernel series is now available for everyone. Please note that some issues has been reported with version 5.0.1 such as having a long delay at shutdown and losing sound output when using suspend. It is still available for the early adopters. You are free to install and use it or not.

As reported by some users, if you use WireGuard, you may have to manually run sudo dkms autoinstall in a terminal to get the kernel module working properly with Linux 5.0.1.
More info about dkms autoinstall (and DKMS in general) here.

Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn't work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.

ProjectM: projectm-pulseaudio v.s. projectm-qt, file conflict with /usr/share/pixmaps/prjm16-transparent.svg

Starting with version 3.1.0 of ProjectM, there are now only three packages instead of six and the QT part has been merged to the projectm-pulseaudio package.

Remove the projectm-qt package before upgrading your system.


All good here on i3wm.

Actually, this update has fixed some minor issues that I've been experiencing. Nice.


No problem on plasma with Ryzen APU.


I have updated with no hassle on xfce. Thank you Manjaro team!

1 Like

I like the rabbit @oberon :smile:


Yomyommm !!

I edited the wiki post. I suggest to nuke all old issues up to the infamous 2019-02-19 update (two months ago): everything below " If you have not kept up with [Stable Update] 2019-02-19 yet, please read the information below too." will be removed. Also, I would put everything up to " Gnome 3.32: Two extensions removed from our repos." in Items from previous update sets.

Do you allow me do to so as I said above?

(I'll remove the pool once I have approval or not.)

(11 yes, 0 no, done.)


Thank you. :slight_smile:

Synchronizing the package databases is currently running slower than dial-up internet speeds. Websites in browsers are not having this issue. I will abort and try later.

I think we can delete this thing. With the last update this bug doesn't exist anymore to xorg session.

1 Like

Sure, I'll strike it if it is confirmed to be fixed. (EDIT: Welp, already done.)


Thx for your work! :yum:

Manjaro Deepin

Positive side

I don't know if it's you or Deepin, but this update finally solved Manjaro-only deepin root file manager random crash i had on all of my machines!

I really hope you know exactly what fixed it, because if this will appear again in future there's no room for luck on debug such random stuff, especially considering that i had it on all of my machines and VMs and you couldn't reproduce...

I've spent weeks to just find a way for reliable reproducible example :laughing:

Negative side

  1. Obviously dde-dock & dde-control-center cordeumps / crashes on boot and in the process of work.

    I don't understand what's the rush, if we had luxury to know it while .iso rc testing and ability not to push buggy stuff ourselves (despite the fact that it's not our fault that it was pushed by Deepin in the first place)?

    I believe today's updates on Arch which just came out fixes this one finally, can you please verify and fast-track changes if it's so?

  2. Same question as 1, we knew about it.

  3. Desktop icons are forced to sort by name on each reboot

P.S. I know that only 1 is serious, but 2 and 3 will certainly spark Support for community editions section of forum, so...Worth to note :upside_down_face:

Sounds very much like you should update your mirror list... :wink:

I don't have the slightest idea! :rofl:

This might be tricky as latest Archlinux update includes newer toolchain with gcc 8.3.0 :crazy_face: We shall see...

Having problems with xfce4-terminal. Text disappears and reappears from the current line while typing.

Doesen't seem to be a tmux issue as alacritty works fine, so I'm assuming it's related to the vte3 update...

Dang. That's bad :crazy_face:

Well...All we got is hope for the better then!

I still don't get why you rushed known ones though, it's bad practice, regardless of Deepin's faults :confused:
Better safe than sorry, i think!

Well I can not hold back whole stable update for deepin packages with their more or less known or fixed issues and it's extremely difficult to pick out individual packages or groups of packages. We might run into quite a chaos with dependencies. For a lot of other reasons packages now had to be moved on, sorry.


All good. Thank you!

1 Like

Lenovo Ideapad 110 - everything fine. PC with Intel Core i5 Haswell, GTX970 - Everything fine, except that i had to rebuild the GRUB bootloader with "sudo update-grub" afterwards, because grub didn't show up on boot - after update-grub my windows installation was successfully added again - everything else, at least what i've tested, runs perfectly.

plasma seems alot smoother now :smiley:

thx guys and girls :wink: happy easter / frohe ostern.

Forum kindly sponsored by