[Stable Update] 2019-04-28 - Gcc, Systemd, Kernels, Virtualbox, Qt5, Deepin

Hi community,

here comes our stable update number thirteen.
We have quite a big bundle here and hope to have done our best to make another transition as smooth as possible for you.
Package upgrades include:

  • Gcc 8.3
  • point releases for kernels 4.14, 4.19, 4.4, 4.9 and 5.0
  • qt5 5.12.3
  • Systemd which has received some bugfixes in the 242.16 build
  • KDE-framework 5.57 with Plasma applications 19.04
  • also more fresh Deepin and Gnome packages
  • vte3 0.56.2
  • Bash 5.0.003
  • Mesa 19.0.3
  • wine 4.6
  • qemu 4.0 aswell as some
  • python updates.


  • After holding back for a while I have now updated linux44. We were able to fix the catalyst compiling issue, nvidia-340xx unfortunately not. So be aware that, if you rely on this nvidia legacy driver you will have to switch to one of our other kernels.
  • We had to remove xplayer due to its incompatability with updated gstreamer 1.16. We recommend you use vlc or another player of your choice as a replacement - at least for now...
  • The updates of Nextcloud and Tmux might require you to adjust your config.
  • already with last stable update we have dropped inhouse maintenance of brave browser. Please make sure you update from the AUR!

We hope you enjoy another flawless update and wish you a great remaining Sunday.


Manjaro v18.0.4 released!

We updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.15 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.

Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.138 [EOL]
  • linux44 4.4.178 (no legacy nvidia-340 module, see above!)
  • linux49 4.9.170
  • linux414 4.14.113
  • linux419 4.19.36
  • linux420 4.20.17 [EOL]
  • linux50 5.0.9
  • linux51 5.1-rc1 (no extramodules yet)
  • linux419-rt 4.19.31_rt18
  • linux50-rt 5.0.7_rt8

A detailed list of the package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


hurray and many :hugs:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

COMMAND-NOT-FOUND error during update/installation

During upgrade/installation the package command-not-found tries to sync its database with a mirror that seems to be currently (or permanently ?) offline, resulting in an error message

(1/1) installing command-not-found                                     [########################################] 100%
Could not download catalog file ... aborting
error: command failed to execute correctly

I (oberon) have already opened an issue upstream about the problem.

Kaffeine: Digital television doesn't work anymore

Unfortunately, this functionality of Kaffeine is currently broken with v4l-utils 1.16.5-1.

It has already been reported to the Arch Linux bugtracker, see this: https://bugs.archlinux.org/task/62402

According to this ticket, Manjaro and Arch Linux are not the only distros affected by a similar issue.

As a temporary workaround, you may try to downgrade the v4l-utils package from 1.16.5-1 to 1.16.3-1. You may do so graphically with Pamac (with Install Local Package on /var/cache/pacman/pkg/v4l-utils-1.16.3-1-x86_64.pkg.tar.xz) using or with the command-line interface with pamac install /var/cache/pacman/pkg/v4l-utils-1.16.3-1-x86_64.pkg.tar.xz, sudo pacman -U /var/cache/pacman/pkg/v4l-utils-1.16.3-1-x86_64.pkg.tar.xz or any equivalent.

Please note that this is merely a temporary workaround and not a definitive solution. Do not keep this package downgraded forever as keeping downgraded packages for too long may become an issue in itself.

The KDE Updates Can Cause The Screenlocker To Crash

If you update from within a GUI session and use screenlock (e.g. it kicks in while the large update is being processed), it will crash the screenlocker.

To restore access, press CTRL+ALT+F2 to switch to another tty and log in with your username.

Then type in the following and press enter:

loginctl unlock-session 2

Press CTRL+ALT+F1 to switch back to a now unlocked KDE desktop.

XPlayer removal

Because XPlayer doesn't work anymore alongside GStreamer 1.16.0, the following packages got removed from official repositories: xplayer and xplayer-plparser. Upstream is aware of the issue, but we do not know when it will be fixed. Those packages may come back eventually.

We suggest using alternatives such as VLC media player (package: vlc).

TLP 1.2.1, .pacnew file: Merges may be needed

TLP 1.2.1 got released in [Stable Update] 2019-04-20 update set, replacing TLP 1.1. Therefore, if you have customized your configuration file for TLP (/etc/default/tlp), a .pacnew file will be created when the tlp package will be upgraded. This .pacnew file is the new default configuration file provided by the package. Your old configuration file won't be edited or replaced automatically; by default, your old configuration file will be kept as it is and you will have to merge relevant part the new configuration file manually with a text editor. Guidance can't really be more precise since each person has its own configuration.

You may use a tool such as Meld (package: meld) in order to compare your old configuration file with the .pacnew file and see the differences more easily.

If you haven't modified your configuration file for TLP, normally, you will automatically go on the new configuration file for TLP provided in the package without any manual intervention needed.

If you use the current version of TLPUI (tlpui r109.703bade-1), it may complain with the following error with some settings: "expected item missing in config file." It is most likely because some new parameters introduced with TLP 1.2.1 are not in /etc/default/tlp. To get rid of those messages, you will need to do some merges between your old configuration files and the .pacnew files and manually add all those new settings, even if you end up using the default value for those settings.

TLPUI cannot be launched

There was a bug in a previous version of TLPUI (confirmed on tlpui r89.d6363f0-1) that changed the permissions of /etc/default/tlp to 600 (rw-------). The default permissions for this file is 644 (rw-r--r--).

It is most likely that TLPUI doesn't launch because it doesn't have the right permissions for /etc/default/tlp. TLPUI must be allowed to read that file in order to launch.

First, verify if the permissions of /etc/default/tlp are set correctly. You may verify that with ls -l /etc/default/tlp in a terminal. Here's an example of how the output will look like:

$ ls -l /etc/default/tlp
-rw-r--r-- 1 root root 14238 Apr 11 15:26 /etc/default/tlp

If you have -rw------- instead of -rw-r--r--, change the permissions of that file so this file becomes readable to the group and others too. You may do so in the terminal with sudo chmod 644 /etc/default/tlp.

Once it is done, TLPUI should work properly.

MComix 1.2.1: Can't launch after the upgrade

This is a known issue that is due to breaking changes introduced in python2-pillow 6.0.0 (see this document). It is a package imported from Arch Linux and the issue has already been reported on Arch Linux side. See this ticket on the bug tracker: https://bugs.archlinux.org/task/62242

A true fix requires to do modifications in the source code of MComix.

Since python2-pillow (and python-pillow) is used by many programs, similar problems may happen with other software too.

"Spring cleanup" on Arch Linux: impact on Manjaro

Recently, Arch Linux did a "spring cleanup" of their Community repository (see the full discussion on the mailing list and seach for "spring"). Many package got removed from the Arch Linux official repositories and dropped to the AUR. Therefore, it means that many packages that were in our repositories because they were imported from Arch Linux got removed from our repositories too. Here's a non-exhaustive list of packages that got removed:

  • cherrytree - Hierarchical note taking application featuring rich text and syntax highlighting
  • docky - Full fledged dock application that makes opening common applications and managing windows easier and quicker
  • mate-menu - Advanced menu for MATE Panel, a fork of MintMenu (Not to be confused with mate-menus)
  • medit - GTK+ text editor
  • thermald - The Linux Thermal Daemon program from 01.org
  • wine-staging-nine has been removed / replaced with wine-nine. In case it is installed, it should be removed manually. http://archlinux.2023198.n4.nabble.com/Removing-wine-staging-nine-replaced-with-wine-nine-td4722447.html

If you want to continue to use those packages, you will have to use the AUR from now on.

You may try to do a package request in this category, but note that there is a high chance that your demand will be refused.

Items from previous update sets

Gnome 3.32: Two extensions removed from our repos.

We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extension-topicons-plus-huttli and gnome-shell-extension-taskbar. We won't maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.

Gnome 3.32: Various problems

There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue with a third-party extension (that doesn't come from Manjaro's official repositories) called Extensions.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread and this ticket from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. As a workaround, you may use X.org instead of Wayland for now.

4. Miscellaneous
Some programs don't get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too. (Should be fixed by now.)

My icon theme is not applied anymore for programs like Gnome Terminal, System Monitor, Gnome Screenshot, Gnome Disks, File Roller, etc.

With version 3.32 of these programs, upstream changed the icon used for many programs part of the Gnome Applications. Instead of using a generic icon shared by many programs, they chose to ship a new icon and use it. Therefore, launchers located in /usr/share/applications (.desktop files) for those programs has been modified to use the new icon instead of the generic one. Here's an example with Gnome Terminal.



Since your icon theme most likely doesn't have an icon named org.gnome.X, it falls back to the hicolor theme instead. This is why the icon changed after the system upgrade and "your theme is not applied anymore for those programs."

There is nothing you can really do for now, except living with it for a while. Icon theme designers will have to adapt their theme to the changes made by Gnome developers.

Yaourt: Rest in peace

Yaourt has been removed from our repositories completely. We won't maintain the yaourt package anymore, which means that you will not receive any updates from us for this package. A very old package named yaourt-gui-manjaro has been removed at the same time too.

If you are still using Yaourt, we strongly encourage you to switch to an alternative like Pamac CLI (package: pamac-cli), Trizen (package: trizen), Yay (package: yay) or Pacaur (package: pacaur); and uninstall Yaourt from your system.

In addition to that, we have dropped support for several packages that depended on yaourt: allservers, pacli and pacli-jwm. Those packages has been removed from the official repositories completely.

"Replace pamac with extra/pamac-gtk? [Y/n]"

Accept the replacement. The original pamac package is now split into three packages: pamac-gtk, pamac-cli and pamac-common.

vlc-nightly has been dropped

The vlc-nightly package, which was really useful in a time when VLC 3 was not officially out yet, has been dropped on our side and is not in the official repositories anymore. If you still have this package and you want the latest stable version of VLC media player, simply install the vlc package (the vlc-nightly package should be removed at the same time, in the same transaction).

Otherwise, you can continue to use vlc-nightly from the AUR (but you'll have to compile it yourself).

"NOTE, 4.20.17 was the last maintenance release by Greg Kroah-Hartman.; It is recommend to move on to linux50-series." What should I do?

Linux 4.20 (which is not an LTS kernel) is now marked as End Of Life (EOL), so if you want to continue to use an non-LTS kernel, you should consider using Linux 5.0, and also uninstall kernel 4.20 soon.

Keeping EOL kernel installed on your system for too long can lead up to problems for future upgrades (especially if using NVIDIA drivers). When using non-LTS kernel, you must do maintenance/cleanup more often.

" Replace xorg-mkfontdir with extra/xorg-mkfontscale? [Y/n]"

Accept the replacement.

Linux kernel 5.0.X available. Early problems reported.

The newest kernel series is now available for everyone. Please note that some issues has been reported with version 5.0.1 such as having a long delay at shutdown and losing sound output when using suspend. It is still available for the early adopters. You are free to install and use it or not.

As reported by some users, if you use WireGuard, you may have to manually run sudo dkms autoinstall in a terminal to get the kernel module working properly with Linux 5.0.1.
More info about dkms autoinstall (and DKMS in general) here.

Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn't work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.

ProjectM: projectm-pulseaudio v.s. projectm-qt, file conflict with /usr/share/pixmaps/prjm16-transparent.svg

Starting with version 3.1.0 of ProjectM, there are now only three packages instead of six and the QT part has been merged to the projectm-pulseaudio package.

Remove the projectm-qt package before upgrading your system.


No Kodi 18.2 in stable yet ...

1 Like

True! :stuck_out_tongue_winking_eye: I guess I'll take that back :laughing: kodi 18.1-3

The update went fine this time!

No problems at all.


@oberon Don't know if I'm being nitpicky or not, but perhaps mentioning the introduction of systemd 242 in the list could be a good idea.


A really big update ... 1,5GB ... but not problems :star_struck:

Thanks to the Manjaro-Team :+1:


Absolutely. It's in the title and was on my list for the post - somehow it got lost on the way apparently :stuck_out_tongue_winking_eye: Adding it right now.
btw. thank you so much for taking care of the wiki post! :+1: :beers:


Hey guys :slight_smile: thanks again for supporting manjaro with this update !

I am just a little unsure at the beginning of the update i get asked
"Replace libmagick with extra/imagemagick?" and i am not sure with which to answer

moreover this is the first time this question was stated

Thank you for this, this update fixed all Deepin issues mentioned in previous one! :+1:

Although i really hope that you'll find some common ground with BLumia & Deepin team, at least proper dialog have started :slightly_smiling_face:

For people with high-dpi screen on Manjaro Deepin

You most likely will find that after first reboot, your font size will look super big / super small, due to bug in previous update.

To fix it:

  1. Just set your preferable scaling again in settings
  2. Logout - Login or reboot
1 Like

Absolutely smooth, no problems. Some preinstalled packages I removed now, so next time less traffic for the servers.

1 Like

Answer yes, because imagemagick provides libmagick


I have found this doesn't actually work most of the time. The sequence that seems to work is setting a different display scaling (from what its currently on), logout - login then set your preferred scaling logout -login then I get properly scaling icons and menu items

For example if you had it previously set to x2 it's enough to:

  1. Set it to x1.5
  2. Set it to x2
  3. Logout - Login / Reboot

I've tested it, so no need to logout 2 times, at least this time)

This is clearer since you mention the sequence. Also have you noticed the kernel modules fail when you use a 5.xx kernel on Deepin? I had to use dkms autoinstall to get it working right otherwise I'd get freezes from time to time

I'm not user of 5.xx yet, but i have suspicions that i know why it happens for you :upside_down_face:

There's external kernel module used by deepin-anything package (for search indexing), @oberon have made some work to get pacakge without this module use:
deepin-file-manager-nomodule, instead of deepin-file-manager

more info

This should fix your problem i think, but let us know :slight_smile:

I am trying to upgrade from the German mirrors and I get all the the time the same error for a couple of packages

error: electron: la firma de «Nicola Squartini <tensor5@gmail.com>» no es válida
:: El archivo /var/cache/pacman/pkg/electron-4.1.4-1-x86_64.pkg.tar.xz está dañado (paquete no válido o dañado (firma PGP)).

The firm of some packages seems to be broken or it is not valid, should I installed despite the error? If I delete the these problematics packages and try to upgrade again I get the same error

Perfect update via tty as always , KDE on 4.19 using Nvidia running fast and rock solid , Thanks Team .

The system blocks, there were kernel modules not loaded, it stops at cups load, help, please, thanks

Forum kindly sponsored by