[Stable Update] 2019-04-28 - Gcc, Systemd, Kernels, Virtualbox, Qt5, Deepin

After latest update I got this kernel panic. Can I fix it without reinstalling my whole system? image

1 Like

After a lot of messing about this seemed to help.

Thank you.

1 Like

I have mounted into a live environment of manjaro and chrooted into my installation. I tried to install a new kernel other then 4.19 and 5.0. But I can't since

error: could not open file: /etc/mtab: No such file or directory
error: could not determine filesystem mount points
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

I also tried to

sudo mkinitcpio -P

But that give's me this:

==> ERROR: /proc must be mounted!

Did you follow this steps:


You used "manjaro-chroot -a" in the terminal?
It is always good to have another kernel installed, in case of this things happen.

Oh no I didn't thought you could just use regular chroot. Tho solved it by mounting /proc using

mount -t proc proc /proc

I also mounted /sys and /dev using

mount -t sysfs sys /sys
mount -t devtmpfs udev /dev

Tho I don't know if I had to do that. I just did it cause in the solution I found they did it.
And then I could do

sudo mkinitcpio -P

So, your problem is solved?
But using manjaro-chroot is a better solution from the Manjaro team.
And having another kernel that you can choose from the grub is a good thing.

1 Like

No issues. XFCE

Smooth sailing with KDE, and now Dolphin shows little thumbnails of my Blender files. :heart:

2 Likes

No issues on my five DELL Manjaro Plasma machines. As always excellent job from the Manjaro team. :+1:

Alex

Thanks for updating the gnome safe password! Now it's working like a charm :grin:

I've had to reinstall Clementine (Qt5 version from AUR)
It seems like Qt update is a reason.

Normally you would do:

mount -o bind /sys sys/
mount -o bind /dev dev/

Hi,

Is there a date when we get the bug fix that was released for Atom 1.36.1?

Atom 1.36 broke some functionality, namely some packages and 'Reopen Project' reopens a project as a subfolder in the current project instead of a new window.

This current update did not include it.

I have confirmed on other distros that 1.36.1 does fix these issues.

Everything went smooth for me on both of my machines. Thanks :heart:

1 Like

atom is an Archlinux package and it hasn't been updated, yet. I will look into possibly forwarding the fix as an overlay.

2 Likes

I know this was already asked but did you solve your issue? After you run manjaro-chroot in the live iso you should be able to use the downgrade tool from the live iso. I've never used the tool from chroot live iso mode but I imagine it should work fine to revert to your previous kernel. https://wiki.manjaro.org/index.php?title=Using_Downgrade After that and reboot just set your GUI package manager to ignore kernel updates so it doesn't bug you daily. You can delete the rule when the next kernel update is released.

I have attempted to update the package but realize that it's more than just a simple rebuild. The current patched would need some adjustment and, since I am not the maintainer of this package and don't have the extra time for fun right now :wink: I suggest you keep an eye on the archlinux package and download it directly with the link provided when you see that it's ready. I have notified the packager of the update already.
If you feel like it and ar up to, of course you can fix the patches and build the update yourself. Package sources can be found here.

3 Likes

Everything got ok :smiley:

Should I downgrade automake or wait forawhile
cd . && /bin/sh /home/mgundogdu/Program_Files/AUR/pamac-build/epson-inkjet-printer-escpr/src/epson-inkjet-printer-escpr-1.6.40/missing automake-1.15 --gnu Makefile
/home/mgundogdu/Program_Files/AUR/pamac-build/epson-inkjet-printer-escpr/src/epson-inkjet-printer-escpr-1.6.40/missing: line 81: automake-1.15: command not found
WARNING: 'automake-1.15' is missing on your system.
You should only need it if you modified 'Makefile.am' or
'configure.ac' or m4 files included by 'configure.ac'.
The 'automake' program is part of the GNU Automake package:
http://www.gnu.org/software/automake
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
http://www.gnu.org/software/autoconf
http://www.gnu.org/software/m4/
http://www.perl.org/
make: *** [Makefile:378: Makefile.in] Error 127
==> ERROR: A failure occurred in build().
Aborting...
Edited: I reported my issue on AUR website and packager solve this issue. Thank you!

Yeah I have the same. Ittried to reinstall guest additions but my windoze guests started to act weird after update...

Perhaps something related to:
https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/virtualbox&id=321cac1ee72e685e4333df47f1109cdfc9d2f3a4

"rebuilt with old acpica 20190215-1 for fix guest ACPI breakage (FS#62381)"

Forum kindly sponsored by