[Stable Update] 2019-05-17 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

echo "kernel.dmesg_restrict=0" > /etc/sysctl.d/99-dmesg_restrict.conf
For those who want it old way.

2 Likes

Even if all you are writing is correct, it doesn't concern the situation. It's just another trait of the reality :slight_smile:

At any case thank you for strategic information related to zfs :slight_smile: Have started Moving from zfs to... where?

Well, the last update set in Testing used to prepare this Stable update set was done like right at the moment when those vulnerabilities were disclosed and the early patches for Linux were released.

Stable was held off for like more than 14 days, so it was really due for a release, Zombieload/etc. or not.

2 Likes

Also, if you are in the wheel group, you can load kernel messages without typing a password with journalctl -k. It is possible because journalctl allow members of wheel to load system logs directly. Quoting the manual:

All users are granted access to their private per-user journals.
However, by default, only root and users who are members of a few
special groups are granted access to the system journal and the
journals of other users. Members of the groups "systemd-journal",
"adm", and "wheel" can read all journal files. Note that the two latter
groups traditionally have additional privileges specified by the
distribution. Members of the "wheel" group can often perform
administrative tasks.

1 Like

Had the signature is marginal trust problem.. this fixed it.
Followed the first steps of the guide @TotallyNotElite proposed here [Stable Update] 2019-05-17 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd
and the went back to downoading step 7 of Updating From TTY

Thanks a lot !:grinning:

Hello, i'm running Manjaro i3 and i couldn't update via tty (with sudo pacman -Syyu).

"python-pillow-simd and python-pillow are in conflict. Remove python-pillow? [y/N]"

I chose both yes/no and i got an error message.
"error:unresolvable package conflicts detected"
"error: failed to prepare transaction (conflicting dependencies)"

On the dependency tree i saw that python-pillow was used by openshot, deleted that but it's still the same.

How should i proceed with this? Is there something that i have to remove manually?
Thanks in advance

What should those who do not use a Qt4 do? What packages need to be removed?

Xfce 4.13, update fine, kernel 5.1.1-2 now. Great work! I voted ”no probs“.

Just wanted to let you know though: Language issue of grub not solved here, grub keeps saying ”Advanced options...“ instead of the German phrase. Just cosmetic I guess. On the other hand, an update for grub under Tumbleweed had fixed this matter a few days ago... :wink:

Further wrt grub: Any definitive statement regarding that ”udev.log_priority=3 audit=0“ stuff in GRUB_CMDLINE_LINUX_DEFAULT? Necessary, optional? What if not inserted? I have it in now.

After updating, my bluetooth keyboard had to be setup again as it cannot connect to the laptop. The keyboard was previously paired and it is still present in the bluetooth settings. However, the device was unable to connect to each other.

Solution was to remove the keyboard device on the laptop, and reset the pairing of the keyboard.

OS: Manjaro XFCE
Kernel: 4.19.42
Keyboard: Filco Majestouch Convertible 2 TKL
Bluetooth hardware on laptop: Intel Wireless-AC 9560

When you removed Openshot, did you specify to remove python-pillow as well? If not it will still be there and causing the conflict. Try removing python-pillow manually and try again.

flawless update for me.. Even vmware didn't break :grin:

Is it bad that I hope this update breaks something so I can have an excuse not to study for finals? I AM STRESS!!!

3 Likes

No issues with the update! Smooth as usual. :+1:
LXQT, NVIDIA nonfree with Kernel 5.0.
XFCE, AMD free with Kernel 5.1
Thanks!

I suppose this vulnerability and the patches just came at the "wrong" moment, when Manjaro was already on the way of releasing a Stable update set.

But now that it is done, we can focus on this issue. Ideally, if we could get the newest kernels and microcodes (well, ATM, only the Intel one is available on Arch Stable, the AMD one is still in Arch Testing) on Testing today or tomorrow so we could see how our "guinea pigs" react to it, it could be great.

It is not that surprising to see Ubuntu being patched that quickly. Don't forget that Ubuntu is not just a distro meant for personal, home computers. It is also a major distro in corporations and organizations, notably on servers; and also, regular Ubuntu and Ubuntu Server uses the same repos and even the same kernel by default (the -generic one). Considering that corporations/organizations are generally holding sensible and valuable data for thousands, if not millions of people, it was much more an emergency for Ubuntu, and much more an emergency for Red Hat/CentOS, SuSE, etc.

Well, you are the only master of your computer, so in theory, you could sabotage your own computer with partial upgrades? :thinking:

(I am obviously not serious. Don't ask for help if you really do that.)

3 Likes

I keep audit=0 on my command line; don't want/need audit, and just never know when an update might try to enable it for my own good.

I had the same problem and this solution gave me a smooth update. Thanks Manjaro Team and to the Manjaro Forum.

i love the new look in gnome edition.

I second that. @Jagadeesh

Upgrade went perfect, but I did get a problem with Evolution. Looking into that now...

Selection_010

Forum kindly sponsored by