[Stable Update] 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT

Hello community,

I am happy to announce another Stable Update.

Stay tuned for the cooperation we started with Tuxedo Computers!

Some might noticed that since the #snapcraftsummit a lot of package changes went into Manjaro and our available RCs. XFCE and Gnome will come with Gnome-Software and our KDE edition has Discover, both with snap support enabled.


This way everybody can easily access the snap store by a click and don't has to hassle to get snaps enabled. This enables us to ship even more proprietary software, which we couldn't before. For example check out on how you may install Spotify on Manjaro.

This update holds the following changes:

  • most of our Kernels got updated. Some of them got already built with gcc 9.1. All EOL kernels got removed!
  • KDE Plasma is now at 5.16.2
  • Nvidia driver got update to 430.26
  • Mesa is now at 19.1.1
  • Texlive got it's first 2019 update
  • apparmor got his own profiles package, which ships those in complain mode.
  • Kodi got updated to 18.3
  • Systemd gained more stable patches. Report any issues you may have with it.
  • Pamac is now at its v8.0 release series
  • updates to XFCE 4.14-pre2
  • amdvlk got updated to its latest release
  • more updates to our KDE-Git branch
  • Octopi gained more features and fixes
  • Firefox-Dev and Thunderbird got updated
  • usual Haskell and Python updates
  • Manjaro Juhraya ISOs got updated, including snap support pre-activated: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.

Current supported Kernels

  • linux316 3.16.69
  • linux44 4.4.183 (no legacy nvidia-340 module!)
  • linux49 4.9.183
  • linux414 4.14.130
  • linux419 4.19.56
  • linux51 5.1.15
  • linux52 5.2-rc6 (few extramodules build, but not all yet!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.21_rt14

Package Updates (Sun Jun 30 06:44:09 CEST 2019)

  • testing community x86_64: 481 new and 476 removed package(s)
  • testing core x86_64: 7 new and 7 removed package(s)
  • testing extra x86_64: 97 new and 102 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)

A detailed list of all package updates may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

File conflict: "snapd: /snap already exists in filesystem"

If you have this file conflict, we recommend to use the command-line interface for this time and use the --overwrite option. In a command-line interface, use the following command or any equivalent of your choice:

sudo pacman -Syu --overwrite '/snap' 

Warning: audit: directory permissions differ on /var/log/audit/filesystem: 755 package: 700

Execute sudo chmod 700 /var/log/audit/ in terminal

mariadb 10.4.x update requires manual intervention

(Source: https://www.archlinux.org/news/mariadb-104x-update-requires-manual-intervention/ , 2019-06-27, by Christian Hesse)

The update to mariadb 10.4.6-1 and later changes configuration layout as recommended by upstream.

The main configuration file moved from /etc/mysql/my.cnf (and its include directory /etc/mysql/my.cnf.d/ ) to /etc/my.cnf (and /etc/my.cnf.d/ ). Make sure to move your configuration.

Instantiated services (like mariadb@foo.service ) are no longer configured in separate files (like /etc/mysql/myfoo.cnf ). Instead move your configuration to configuration blocks with group suffix in main configuration file, one for each service. A block should look something like this:

datadir = /var/lib/mysql-foo
socket = /run/mysqld/mysqld-foo.sock

Like every mariadb feature update this requires the data directory to be updated. With the new configuration in place run:

systemctl restart mariadb.service && mariadb-upgrade -u root -p

Some KDE System Settings may have been re-set to their defaults

  • System Settings > Input Devices > Touchpad > Tap-to-click
  • Scrolling
  • The compositor could get disabled during the upgrade which will stop all of the KDE eye-candy
  • (Font-)Hinting could get reset to none

Items from previous update sets

XFCE 4.14-pre2 : I do not see XFCE 4.14-pre2 in the repositories!?

You won't see explicitly 4.14-pre2 anywhere on our xfce-gtk3 packages. We follow the versioning used by upstream. Here's the list of all components that are part of XFCE 4.14-pre2.

Kvantum theme reset

If you are using the Matcha theme in kvantum you may experience a theme reset. Simply install kvantum-theme-matcha if not happend yet and select the new provided variants. Manjaro 18.1 releases will ship with the new themes by default.

Issues with Octopi

Currently several users report different issues for Octopi. So if you encounter some of them, you may switch to pamac for now: sudo pacman -Syu pamac

(Note that sudo pacman -Syu pamac will both install Pamac and upgrade all upgradable packages on your system at the same time.)

Issues with DisplayCAL

DisplayCAL - Missing python2-dbus causes failure to launch application.

Solution - Install the python2-dbus package for now. Version 3.8.2 fixes the dependency error. As and when DisplayCAL 3.8.2 reaches stable branch you can remove python2-dbus as it does not require it. Only remove python2-dbus again if you installed it specifically for DisplayCAL.

Regression with Linux firmwares on machine running Vega GPUs.

June 2, 2019: We expect it to be fixed with linux-firmware 20190514-711d329-1.1. We downgraded the firmware related to Vega GPUs to a previous version. You should now be able to use Linux 4.19 correctly.

[Stable Update] 2019-05-26 - Kernels, XFCE 4.14-pre1, Virtualbox, LibreOffice

linux-firmware 20190514-711d329-1 introduced a regression that can make the system unbootable on systems that use a AMD Vega GPUs (for example: Vega 64, Vega 56, Vega 10) and Linux 4.19.

It is a regression that affects both Manjaro and Arch Linux. Here's some links.

Arch Linux bugtracker: https://bugs.archlinux.org/task/62666
Manjaro forum: Most recent stable branch update problem
Manjaro forum: Manjaro update prevents system booting
Manjaro forum: 'linux-firmware 20190514.711d329-1' update prevents my system booting.

If you are affected by this issue, you have essentially two choices: either use a different kernel or downgrade linux-firmware. The most preferred method is the first one since it doesn't involve keeping a package to an older version. Either way, if your system is completely unbootable (not even with a command line interface), you will need to do a chroot to repair your system. For each solution suggested below, we will suppose that you need to do a chroot; skip the chroot part if you manage to reach an usable command line interface.

For the first solution, as far as we know, it works fine on Linux 5.1 and supposedly also on Linux 5.0. Follow these steps in order to be able to install a new kernel:

  • Launch a live session with an installation medium;
  • Open a terminal;
  • Chroot your system. You may do so automatically with manjaro-chroot -a. On more complex system where manjaro-chroot may simply fail, you may have to do a manual chroot.;
  • Once you have chrooted on your system, use mhwd-kernel -i linux51 to install Linux 5.1 and all extra modules needed for your system. You may also try with Linux 5.0 (replace linux51 with linux50), although Linux 5.0 is expected to be End of Life soon.

(If you have multiple kernels installed on your machine, you may want to boot with other kernels before trying to install a new one.)

For the second one:

  • Chroot to your system from a live session;
  • Downgrade the linux-firmware package to version 20190424.4b6cf2b-1 with pacman -U /var/cache/pacman/pkg/linux-firmware-20190424.4b6cf2b-1-any.pkg.tar.xz. If the package is not available in your local cache, use pacman -U https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20190424.4b6cf2b-1-any.pkg.tar.xz instead.

(Note that if you know how to use downgrade, you may also use downgrade.)
(Remember that downgrading a package is merely a temporary solution, do not hold the package to a previous version forever.)

signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is marginal trust

Update manjaro-keyring first. For more options read this thread:

Issues with "signature is marginal trust" or "invalid or corrupted package"

replace steam-devices with community/game-devices-udev?

Yes. The package name changed. Accept the replacement.

Linux 5.1 - Which extra modules are currently missing?

As said in the announcement, while the newest Linux version has been released in this update set, not every extra modules are currently available in our official repositories. Before jumping on Linux 5.1, please verify if you do not need any of those missing extra modules on your system.

(Last verification: May 26, 2019)
The following extra modules are missing:

The following extra modules are available:

  • ACPI call (linux51-acpi_call);
  • BBSwitch (linux51-bbswitch);
  • Broadcom wireless driver (linux51-broadcom-wl);
  • Catalyst drivers (linux51-catalyst);
  • Legacy NVIDIA 340.XX drivers (linux51-nvidia-340xx);
  • Legacy NVIDIA 390.xx drivers (linux51-nvidia-390xx);
  • NDIS wrapper (linux51-ndiswrapper);
  • Current NVIDIA drivers (linux51-nvidia);
  • NVIDIA backlight (linux51-nvidiabl);
  • Realtek 8168 drivers (linux51-r8168);
  • Realtek 8732bu drivers (linux51-rtl8732bu);
  • Thinkpad SMAPI (linux51-tp_smapi);
  • SCSI emulation (linux51-vhba-module);
  • VirtualBox guest modules (linux51-virtualbox-guest-modules);
  • VirtualBox host modules (linux51-virtualbox-host-modules).

Small cleanup of Manjaro official repositories

Please note that the following packages got removed from our repositories.

  • chromium-chromevox
  • gimp-gtk3
  • pamac-classic
  • pamac-dev
  • pamac-dev-tray-appindicator

COMMAND-NOT-FOUND error during update/installation

During upgrade/installation the package command-not-found tries to sync its database with a mirror that seems to be currently (or permanently ?) offline, resulting in an error message

(1/1) installing command-not-found                                     [########################################] 100%
Could not download catalog file ... aborting
error: command failed to execute correctly

I (oberon) have already opened an issue upstream about the problem.

The KDE Updates Can Cause The Screenlocker To Crash

If you update from within a GUI session and use screenlock (e.g. it kicks in while the large update is being processed), it will crash the screenlocker.

To restore access, press CTRL+ALT+F2 to switch to another tty and log in with your username.

Then type in the following and press enter:

loginctl unlock-session 2

Press CTRL+ALT+F1 to switch back to a now unlocked KDE desktop.

TLP 1.2.1, .pacnew file: Merges may be needed

TLP 1.2.1 got released in [Stable Update] 2019-04-20 update set, replacing TLP 1.1. Therefore, if you have customized your configuration file for TLP (/etc/default/tlp), a .pacnew file will be created when the tlp package will be upgraded. This .pacnew file is the new default configuration file provided by the package. Your old configuration file won't be edited or replaced automatically; by default, your old configuration file will be kept as it is and you will have to merge relevant part the new configuration file manually with a text editor. Guidance can't really be more precise since each person has its own configuration.

You may use a tool such as Meld (package: meld) in order to compare your old configuration file with the .pacnew file and see the differences more easily.

If you haven't modified your configuration file for TLP, normally, you will automatically go on the new configuration file for TLP provided in the package without any manual intervention needed.

If you use the current version of TLPUI (tlpui r109.703bade-1), it may complain with the following error with some settings: "expected item missing in config file." It is most likely because some new parameters introduced with TLP 1.2.1 are not in /etc/default/tlp. To get rid of those messages, you will need to do some merges between your old configuration files and the .pacnew files and manually add all those new settings, even if you end up using the default value for those settings.

TLPUI cannot be launched

There was a bug in a previous version of TLPUI (confirmed on tlpui r89.d6363f0-1) that changed the permissions of /etc/default/tlp to 600 (rw-------). The default permissions for this file is 644 (rw-r--r--).

It is most likely that TLPUI doesn't launch because it doesn't have the right permissions for /etc/default/tlp. TLPUI must be allowed to read that file in order to launch.

First, verify if the permissions of /etc/default/tlp are set correctly. You may verify that with ls -l /etc/default/tlp in a terminal. Here's an example of how the output will look like:

$ ls -l /etc/default/tlp
-rw-r--r-- 1 root root 14238 Apr 11 15:26 /etc/default/tlp

If you have -rw------- instead of -rw-r--r--, change the permissions of that file so this file becomes readable to the group and others too. You may do so in the terminal with sudo chmod 644 /etc/default/tlp.

Once it is done, TLPUI should work properly.

"Spring cleanup" on Arch Linux: impact on Manjaro

Recently, Arch Linux did a "spring cleanup" of their Community repository (see the full discussion on the mailing list and seach for "spring"). Many package got removed from the Arch Linux official repositories and dropped to the AUR. Therefore, it means that many packages that were in our repositories because they were imported from Arch Linux got removed from our repositories too. Here's a non-exhaustive list of packages that got removed:

  • cherrytree - Hierarchical note taking application featuring rich text and syntax highlighting
  • docky - Full fledged dock application that makes opening common applications and managing windows easier and quicker
  • mate-menu - Advanced menu for MATE Panel, a fork of MintMenu (Not to be confused with mate-menus)
  • medit - GTK+ text editor
  • thermald - The Linux Thermal Daemon program from 01.org
  • wine-staging-nine has been removed / replaced with wine-nine. In case it is installed, it should be removed manually. http://archlinux.2023198.n4.nabble.com/Removing-wine-staging-nine-replaced-with-wine-nine-td4722447.html

If you want to continue to use those packages, you will have to use the AUR from now on.

You may try to do a package request in this category, but note that there is a high chance that your demand will be refused.


When i try to update it give me this error:

:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux420-nvidia
:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux50-nvidia

All went fine, except the following:
I had to reboot the computer using terminal and "reboot".

These kernels are EOL. Remove them first.
Also read Phil's reply down below :arrow_down:
In brief, if linux50 and/or linux420 are your only kernels, you need to install linux419 and/or linux51 after the update. Everything can be done with mhwd, which will take care of nvidia modules automatically. And one more thing: do not reboot until linux419/linux51 are installed, otherwise your system may become unbootable.
If you are currently running linux50 or linux420, then refer this post for details:

And remember: don't blame Manjaro for Nvidia being cancer :wink:


Bumping into an issue I don't recognize:

Total Installed Size:  4556.40 MiB
Net Upgrade Size:        97.68 MiB

:: Proceed with installation? [Y/n] y
(275/275) checking keys in keyring                                                               [########################################################] 100%
(275/275) checking package integrity                                                             [########################################################] 100%
(275/275) loading package files                                                                  [########################################################] 100%
(275/275) checking for file conflicts                                                            [########################################################] 100%
error: failed to commit transaction (conflicting files)
python-click: /usr/lib/python3.7/site-packages/click/__init__.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/__init__.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/_bashcomplete.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/_compat.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/_termui_impl.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/_textwrap.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/_unicodefun.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/_winconsole.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/core.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/decorators.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/exceptions.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/formatting.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/globals.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/parser.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/termui.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/testing.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/types.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/__pycache__/utils.cpython-37.pyc exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/_bashcomplete.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/_compat.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/_termui_impl.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/_textwrap.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/_unicodefun.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/_winconsole.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/core.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/decorators.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/exceptions.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/formatting.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/globals.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/parser.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/termui.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/testing.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/types.py exists in filesystem
python-click: /usr/lib/python3.7/site-packages/click/utils.py exists in filesystem
Errors occurred, no packages were upgraded.

Kernel 5.1.15-1
I have no recollection of installing this. I do have Python 2 click installed.
Octopi doesn't show it as installed.

If 4.20 and 5.0 are your only kernels, you may do this:

sudo pacman -Sdd linux51 $(pacman -Q | grep linux50 | sed 's|linux50|linux51|g')

Then remove the nvidia drivers:

sudo pacman -Rdd linux420-nvidia linux50-nvidia

After that you may update your system as usual.


Thank you!

after removing the EOL Kernel, it worked like a charm. Thanks for the Updates!

Check to which package those existing files belong. If pacman returns none you may safely delete them first.

pacman -Qo /usr/lib/python3.7/site-packages/click/init.py

1 Like

I started running the update but the download speed was very slow I'll run it tomorrow.

No issues , updated via tty , KDE with 4.19 and Nvidia , perfect update , smooth as silk .

That worked,

Thank you!

Thank you kind sir. Pacman reported no ownership, and after the orbital nuking the install went smooth as usual. Love you guys! :blush:

Updated via TTY Asus Z97 I7 4790 desktop, Kernel 4.19.56-1, NVidia GT730 graphics,420.26 driver, Plasma desktop. Per your warning a number of the Plasma settings were changed. Checked & the compositor was still enabled. Attempted a number of times to reset System Settings/Application Style/Gnome-GTK Application Style to (Gtk2) Adwita Dark and (GTK3) Breeze Dark. Pressing Apply freezes the entire System Settings menu (application systemsettings is not responding wait longer or terminate application). Trying to change to any other theme, same results, systemsettings freezes after apply. Rebooting doesnt help. Plasma is taking a lot longer than before to start and exit the desktop when either logging out, or on a reboot/shutdown. Decided to boot into XFCE desktop and the panel at the bottom of the primary monitor disappeared. Was able to rectify that and XFCE functionality seemed ok. Started KSysguard and looked at the process table looking for mem or CPU hogs in PLasma. Did not see anything out of the ordinary. 2 other production systems to update this is a little rough around the edges going to wait. This is the first time DE functionality on a Stable update has been affected in this manner since I have been using Manjaro.

On Manjaro Cinnamon, updated through pamac. I got this warning:

Warning: audit: directory permissions differ on /var/log/audit/filesystem: 755  package: 700

I'm not technical enough and still in the process of familiarizing myself with running a Linux distro. Is this safe to ignore? Or is it better if I address this, and if so, how? It may have been a relic from back when I ran testing branch (back when the architect installer couldn't validate stable packages or whatever), but I've followed the steps to switch to stable on the wiki and I'm pretty sure I'm on stable now.

1 Like

Sorry for dumb reply, but I can't see any update by running "sudo pacman -Syu" or "sudo pacman -Syyu" commands. It returns:

Synchronizing package databases...

  • core is up to date*
  • extra is up to date*
  • community is up to date*
  • multilib is up to date*
    :: Starting full system upgrade...
  • there is nothing to do*

Or should I do it in another way?

PS: New user here.

I think the mirror you're using is not synced with the updates yet. Either you switch to a mirror that's already updated or wait until the mirror you're using gets synced. It used to happen to me all the time until I switched to mirrors that sync relatively more frequently.


hi avndp
this command
sudo pacman-mirrors --fasttrack && sudo pacman -Syyu
will check for the best mirrors, may take a while plus it will update if it finds anything. If you look at the first window in the thread just below the user poll, you see a button that says mirror check service. This will tell you which mirrors have been sync'ed with the packages for this update. Hope this helps. Good luck & good updating.


That worked and thanks also for the "mirror check service" tip :slight_smile:


you are very welcome. We try to help each other around here, helps build the community. Have any probs with the update come back and report them someone will help. Always a great idea before doing an update to read the thread, particularly philm's posts pretty closely before doing the update to see what can be expected.


Forum kindly sponsored by