[Stable Update] 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT

For safety reasons, it is probably better to adjust to the new more strict directory permissions. You can do it with a simple:
sudo chmod 700 /var/log/audit/
Btw, had that too, so it isn't a testing->stable issue, its just an installed package that with the update switched to more strict directory permissions...

5 Likes

It would be wise to read the $ man pacman-mirrors page as well. There is sooo much to learn! Such fun too.:smile:

1 Like

Alright, I'll do that. Thanks.
I think the last time something like that happened, it was stated on the official known bugs statement along with the workaround so I knew what to do that time, and I was at a loss this time.

Getting npm error:

Error al confirmar la transacción:
archivos en conflicto:
npm : /usr/lib/node_modules/npm/node_modules/query-string/index.d.ts ya existe en el sistema de archivos

Error when confirming the transaction:
conflicting files:
npm : /usr/lib/node_modules/npm/node_modules/query-string/index.d.ts already exists in the file system

Read this

3 Likes

Thanks! It's resolved.

Hi.

I'm using 5.0.21-1-MANJARO. I cannot install kernel 5.1 nor 4.19:

The following packages will be installed:

linux419
linux419-virtualbox-host-modules
linux419-nvidia
linux419-bbswitch

Starting
resolving dependencies...
looking for conflicting packages...

:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux50-nvidia
The following packages will be installed:
linux51
linux51-virtualbox-host-modules
linux51-nvidia
linux51-bbswitch

Starting
resolving dependencies...
looking for conflicting packages...
:: installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux50-nvidia


Done ...

I cannot perform system update:

Failed to prepare transaction

could not satisfy dependencies:
installing nvidia-utils (1:430.26-1) breaks dependency 'nvidia-utils=1:430.14' required by linux50-nvidia

Pamac message is too enigmatic - it should switch to supported (newer) kernel or inform the user about kernel upgrade requirement.

Manjaro Settings Manager tells "100% Done" when failed - that's misleading.

mhwd-tui asks for kernels but does nothing.

So no GUI tool can handle this case. I'm going to solve the issue manually.

Thanks a lot for all your efforts! Another (almost) smooth update for me on XFCE using TTY :slight_smile:

Initially, I couldn't update because pacman complained about conflicting files because the folder /snap existed on my filesystem. Indeed, I installed the snapd package and the snap store following this guide. This involded creating a symlink from /var/lib/snapd/snap to /snap. This prevented the update to run. I just completely uninstalled snapd and remove this symlink and then the update went flawlessly.

You mention in the first post that gnome-software will provide snap compatibility and is now part of the XFCE edition. After the update, gnome-software is not installed. Should I install it manually to access the snap store?

2 Likes

Pamac 8 has some issues
1.Localization in Russian is incomplete
2.When I try to update AUR package"build" button does not work

Users above reported it helped them. Maybe you forgot to write something, but according to your message I can assume you didn't try to remove linux50 before performing update or installing linux51, which was the whole point of my post.

Well, yes. But I was unable to remove running kernel and unable install another one :wink:

Please bear in mind that removing current kernel (any touching the kernel by a regular user) is a risky and too complex operation. System updater didn't notified a regular user about necessity to remove (!) current kernel.

The process should be smooth as possible. If this is not possible, error messages should be understandable for a regular user. He/she should be able to follow the instructions.

In my case the solution was:

1. pacman -R nvidia-utils linux50-nvidia cuda lib32-nvidia-utils
2. install kernel 5.1 using Manjaro Settings Manager
3. pacman -S nvidia-utils linux51-nvidia cuda lib32-nvidia-utils
4. do update
5. remove old kernel

Definitely not so easy for a regular user.

5 Likes

Thanks. I had to do this as well.

Another thing... pamac (gui) had issues with downloading some packages. The transfer was broken at some point. Now it complains:

Screenshot_20190703_093806

Who knows which package is corrupted? :wink:

Try to launch update from terminal
sudo pacman -Syu

Thank you, I know that. Just telling here that gui have some serious issues.

I also had issue with "waiting for another package manager to quit" (I had to remove /var/lib/pacman/db.lck manually).

There is also an issue with progress bar, when pamac (gui) is downloading files in parallel - as an user you are not able to see the progress (progress bar and package names are flickering)

EDIT: These issues are related to the previous version of Pamac. I'll re-check them using the new one.

pacman -Syu went smoothly...

Can your confirm issue with AUR packages?

My AUR packages were updated in a batch, I haven't had to push a "Build" button. I'll check this.

After recent stable update pamac-qt is not running properly though I can install packages pretty easily. Two problems,at this moment,I'm facing is- (1) can't get to see details of any packages & (2) can't update through the ui.

Btw, I'm using kernel- 5.1.x. Pamac-qt was running pretty well with occasional crashes before this update. Is there any immediate workaround?

On Plasma:

Error reading (roll-in) file QML: file:///home/user/.local/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/main.qml:29:1: module "org.kde.plasma.private.notifications" version 1.0 is not installed

What to do about it?

Also icon of show desktop widget is not displayed properly

Edition:
Bug reported:
https://bugs.kde.org/show_bug.cgi?id=409449
Edition 2:
I reinstalled knotifications package and everything is ok now.

1 Like

Forum kindly sponsored by