[Stable Update] 2019-10-14 - Pamac 9.0, LLVM9, Firefox, KDE Apps 19.08.2

No problems , updated KDE with 4.19 and Nvidia via TTY and pacman , perfect update as usual .

Smooth as usual, and I'm happy that my VPN whose daemon is built off AUR files that came over on the Mayflower still works!

Blackmagic Intensity Pro 4K now works with kernel 5.3. Everything went smoothly!

Still freeze before loading desktop on kernel 5.3
Works fine on 5.2 and 5.4. (kde and optimus laptop)

trouble here on old macpro2008

  • with kernel 5.3.6 , error mce & microcode on start
  • with 5.3.6 or 4.19.79 no real poweroff
    just after update

no more error after poweroff and boot

Please start a topic for troubleshooting. It seems weird... :scream:

At first you should have checked for package differences with pacdiff. I suppose there was a grub update that had reset settings.
Nevertheless use this (probably the method of manual booting from grub prompt):
Boot OS with broken bootloader

I'm running Manjaro on a 10 year old Dell desktop and it stills runs without issues. I did choose to use Linux 4.19 LTS on it, though.

No issues: KDE, 4.19
Thanks guys :slightly_smiling_face:

Upgraded with pamac update --allow-downgrade and rebooted. No issues yet as far as I can see. XFCE user. I won't be installing pamac-snap-plugin though, and hope to see a flatpak version in the future. Keep up the great work! :slight_smile:

Can you boot with the new entry or do you need to revert to the old form to boot?
And do you have encrypt and lvm2 in the HOOKS line of mkinitcpio.conf?

Getting the following error during update, already tried to change mirror multiple times without success:

$ sudo pacman -Syyuu
:: Synchronising package databases...
 core [...]
 extra [...]
 community [...]
 multilib [...]
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'libwhereami.so=0.3.0-64' required by facter

Seems like facter currently requires the wrong libwhereami version.

Some additional information:

$ pacman -S --info facter
Repository      : community
Name            : facter
Version         : 3.14.5-2
[...]
Depends On      : [...] libwhereami  libwhereami.so=0.3.0-64  [...]
[...]
Build Date      : Sa 12 Okt 2019 19:58:12 CEST
[...]
$ pacman -S --info libwhereami
Repository      : community
Name            : libwhereami
Version         : 0.3.1-1
[...]
Provides        : libwhereami.so=0.3.1-64
[...]
Build Date      : Mo 07 Okt 2019 21:00:18 CEST
[...]

Strangely, according to upstream it should require version 0.3.1-64 and not 0.3.0-64.

EDIT: Ok, this should be fixed once this is made available, aka facter version 3.14.5-3 (up from 3.14.5-2).

Thank you Phil.

Update went smooth.

After Dolphin is now updated to 19.08.02 I can not search for files:
Trying to search FOCUS adds double quotes into the search field like """"FOCUS*""
Seems like some keypresses yield additional quotes. Seems to depend on typing speed also.
In Kate or KAddressBook searching is fine.

UPDATE:
I just tried a apt full-upgrade on KDE Neon -> same bug
there we have KDE Frameworks 5.64.0

Workaround:
do a fast insert from an editor

UPDATE 2:
Could be a kernel issue: today I am running 4.19.79-1 and search is fine
I was running 5.2.21.1...
KDE Neon is on 5.0.0-31-generic - still an issue there after the updates of 2019-10-19

Small update ...

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-14           2019-10-15
-------------------------------------------------------------------------------
                        adwaita-maia           20191013-1           20191014-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-14           2019-10-15
-------------------------------------------------------------------------------
                     manjaro-release             18.1.0-1             18.1.1-1
                                sudo                    -             1.8.28-0


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-14           2019-10-15
-------------------------------------------------------------------------------
                           calamares             3.2.14-2             3.2.15-1
               calamares-git 3.2.15.r6661.62c13e6ea-1 3.2.15.r6675.29548f70a-1
                       manjaro-hello              0.6.2-1              0.6.2-2

4 Likes

Update went smoothly on
Manjaro Gnome, 5.3 kernel, proprietary nvidia 135.21
Update via TTY using
sudo pacman -Syyu
no warning or issues encountered.

Thanks to the Manjaro team for yet another perfectly stable udpate

sorry for asking. but is RCs of manjaro is a stable releases? Should I download 18.1 or 18.1.1 rc2 for stable channel. Cause the scheme is a bit confusing - is it release candidate or is it stable channel? Thx

I've a new AMD build and just wondering when this is likely to become an ISO for download ?

In short: Updates Stable 2019-10-10 and 2019-10-14 just were smooth sailing regarding the updates themselves - good work (sigh, finally ...), and thanks a lot to all devs.

System info: Manjaro Xfce, Intel CPU, NVIDIA legacy graphics card on nvidia 418.88. Updates were > 1.4 GB in size.

I experienced a hickup with the netatop-dkms kernel module (from AUR), though. There was a failure to build automatically when I installed the new kernel 5.3.6 using the Manjaro Settings Manager. I looked at the make.log mentioned (netatop.o not found). So I just went ahead and issued a "Build" for netatop-dkms in Pamac. This did successfully build netatop for all kernels installed. Unfortunately, the previous make.log got overwritten, nothing to post here left.

So my basic questions are:

  • Should the dkms system build all required kernel modules for all kernels installed and the new one that is being installed automatically? I mean is one call from MSM to install a new kernel good enough to take care of a piece of software from the AUR (netatop-dkms)?
  • Or, do I need to explicitly rebuild the netatop-dkms from the AUR using Pamac after installing a new kernel?
  • Do I have to rebuild any one or all initcpio's myself thereafter? What would be the correct mkinitcpio command(s) then? What command for rebuilding one specific initcpio? What command to rebuild all initcpio's for all installed kernels in one go?

Please forgive me for asking a set of basic questions here. I know it should be its own thread, but sorry, couldn't find a way to get a short writeup.

@philm i still have a really serious problem with this update/installation. i figured out that there is something with the partitioning/grub that does not work properly at my system. i installed the new manjaro but as previous described it hangs up at the bios-post. what i figured out is that as i opened the bios i found a curious message telling that my samsung 970 pro ssd does not support hdd mode. if i tried to backup the previous system via clonezilla i got the message that clonezilla can't start because only one drive was detected. for sure it was the external disc that clonezilla detected but not the internal disc. i did an efi install, 300MB fat32 for boot, 250 gigs for system / the rest vor /home. is there some issues with the partioning of the install? i had to reset the whole bios settings to get the samsung back to work. it is something with the new manjaro install that causes the crash, the hardware is ok.

As with the previous (2019-10-10) update, Ethernet fails to reconnect after Resume from Sleep.

Kernel: 5.3.6-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.16.5
Network: Device-1: Intel Ethernet I219-V driver: e1000e

Restarting Network Manager fixes the problem until the next sleep.

Forum kindly sponsored by