[Stable Update] 2019-10-14 - Pamac 9.0, LLVM9, Firefox, KDE Apps 19.08.2

Well, that was fast.

Thanks for the new updates.

After updating pamac to 9.0.0-3 with sudo pacman -Syyu I tried to update the AUR packages with the usual pamac upgrade -a, but I couldn't confirm the update.

Total download size: 36,0 MB
Total installed size: 178,8 MB
Edit build files ? [y/N] n

Apply transaction ? [y/N] y
Transaction cancelled.

Seems like pamac ignores the input, I couldn't edit the build files as well.

Solved with pamac upgrade -a --no-confirm

No issues! Thanks for the fast update Philm and team!

Kernel: linux419
DE: XFCE

Updated 2 machines, KDE in a VM and Gnome on bare metal, via TTY without any issues. Thank you to the dev team.

Time to do a Timeshift back-up again.

On a Side Note: The mirror check service is out of date, it still shows that the mirror in Thailand is out-of-date. As of the time of this post, it is up to date.

@philm
i restored my previous full working manjaro to the system. after restoring i started the regular update via the terminal with sudo pacman -Syyu. the update went without failures but at the end i get a warning. i'm using a samsung ssd that is recogniced as "nvem". the warning says there is a unknown device called nvem01 in /etc/default/grub.probe. if i irestart the updated system it crashes again at the boot-up and halts at the bios-post. any suggestions ? i hope this information helps. my system is a ugly acer-predator 300 laptop.

@philm

Update went fine here so far.
Small thing: Manjaro Hello has Google+ at the bottom left linked up which is discontinued by Google now so its obsolete.
Also idk if many people notice the applications button where they can change preinstalled softwares or add a few more that arent installed. So maybe u might want to clarify that option a bit more during or post-install somehow or maybe open it after install so people can see.

2 Likes

In Manjaro Hello it is giving error 404, page unavailable in Google Plus.
Screenshot_20191014_131304

For me it went to the standard page from Google telling it was discontinued.

1 Like

Do you have fast boot enabled in the bios? Or super fast boot?

Browser cache is often to blame it seems. I've seen this a few times as well.
Just try to refresh the page.

2 Likes

Another update went great! Thank you Manjaro Team :clap:

My bootloader entries got reset with this update (and also the last one on 10/10). I have systemd-boot with LUKS and LVM. What could be causing this?

My entry conf file before upgrade
title	Manjaro Linux 4.19
linux	/vmlinuz-4.19-x86_64
initrd	/amd-ucode.img
initrd	/intel-ucode.img
initrd	/initramfs-4.19-x86_64.img
options	root=UUID=bdb75391-ab56-45eb-8389-a4da73ba888b rw cryptdevice=UUID=614d4999-66da-48c1-9185-c33355ae3f59:cryptroot
My entry conf file after upgrade
title	Manjaro Linux 4.19
linux	/vmlinuz-4.19-x86_64
initrd	/amd-ucode.img
initrd	/intel-ucode.img
initrd	/initramfs-4.19-x86_64.img
options	root=UUID=bdb75391-ab56-45eb-8389-a4da73ba888b rw

Update on 12 Systems and 1VB without Problems.

DK3

1 Like

No problems , updated KDE with 4.19 and Nvidia via TTY and pacman , perfect update as usual .

Smooth as usual, and I'm happy that my VPN whose daemon is built off AUR files that came over on the Mayflower still works!

Blackmagic Intensity Pro 4K now works with kernel 5.3. Everything went smoothly!

Still freeze before loading desktop on kernel 5.3
Works fine on 5.2 and 5.4. (kde and optimus laptop)

trouble here on old macpro2008

  • with kernel 5.3.6 , error mce & microcode on start
  • with 5.3.6 or 4.19.79 no real poweroff
    just after update

no more error after poweroff and boot

Please start a topic for troubleshooting. It seems weird... :scream:

At first you should have checked for package differences with pacdiff. I suppose there was a grub update that had reset settings.
Nevertheless use this (probably the method of manual booting from grub prompt):
Boot OS with broken bootloader

I'm running Manjaro on a 10 year old Dell desktop and it stills runs without issues. I did choose to use Linux 4.19 LTS on it, though.

Forum kindly sponsored by