[Stable Update] 2019-11-14 - Kernels, Plasma, KDE Apps, KDE Frameworks, Mesa, Nvidia

Hello community,

I am happy to announce another Stable Update.

Get the latest install medias here.

It took us a while to provide this update-set of packages. Most of our effort went into the new way we generate initramfs kernel images. The intention is to make the kernel packages more self-contained, as well as making the boot process more flexible, while also keeping it backwards compatible. As of now, only mkinitcpio has hooks for handling kernels installations and removals. We do not ship any for dracut yet, but it will have similar hooks in the near future.

What else changed?

  • latest Kernels fixing some security issues on Intel CPUs.
  • Plasma is now at 5.17.3
  • Apps are at 19.08.3
  • KDE Frameworks are at 5.64.0
  • Brave Browsers are now updated to 0.71 and 0.72 series
  • Nvidia drivers got updated
  • We dropped linux52
  • Thunderbird got some needed fixes in 68.2.2
  • The bi-weekly Mesa update 19.2.3 brings some fixes and stabilizations
  • The usual upstream fixes and updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-vanilla, which we build on a regular basis against kde-git master packages.

As always we appreciate your input and feedback for the updates.

Our current supported kernels:

  • linux316 3.16.75
  • linux44 4.4.201
  • linux49 4.9.201
  • linux414 4.14.154
  • linux419 4.19.84
  • linux53 5.3.11 (no catalyst module!)
  • linux54 5.4.0-rc7 (not all modules build yet!)
  • linux419-rt 4.19.72_rt26
  • linux52-rt 5.2.21_rt13

Package Changes (Wed Nov 13 11:48:51 CET 2019)

  • stable community x86_64: 776 new and 903 removed package(s)
  • stable core x86_64: 44 new and 46 removed package(s)
  • stable extra x86_64: 748 new and 832 removed package(s)
  • stable multilib x86_64: 41 new and 40 removed package(s)

A detailed list of changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here


why the "broken" mesa version, and not the fixed one? https://www.phoronix.com/scan.php?page=news_item&px=Mesa-19.2.4-Released

from the announcement at freedesktop.org: https://lists.freedesktop.org/archives/mesa-dev/2019-November/223773.html

anyone using 19.2.3 should immediately upgrade to 19.2.4
or downgrade to 19.2.2.


Arch is still on 19.2.3 ...


I booted up the spare desktop in the study and saw an update. Figured I'd forgotten to update this machine last time and ran the update from TTY. Turns out it was today's fresh update. No issues :wink:

Cinnamon DE, kernel 4.14, Intel video, modesetting.


Once again, everything is fine, without any problems (Gnome, Kernel 5.3) :slightly_smiling_face:

Sorry, only this one appears:

Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)

What can I do?

You probably installed fontconfig from AUR and that's why it's newer. You don't need to do anything, but you can reinstall fontconfig from the repos if you like.

I don't believe that's it, I think it's because Manjaro downgraded fontconfig because the people who use Snaps for some reason kept having issues

1 Like

Thank you, but i didn't install it from AUR. Normally, i only use the Manjaro repos.
For me, it looks like:

I'm not shure, if i should use the lib32, because i installed x86_64 GNU/Linux.

After update i have a error message on my two updated machines

sudo journalctl -p err --since today

Nov 14 12:21:01 manjaro-pc crond[442]: (root) CAN'T OPEN (/etc/crontab): Datei oder Verzeichnis nicht gefunden

after a second reboot the error is gone...OK

sudo pacman -Syyuu should take care of it.

just found a good solution announced regarding mesa:


my update today has broken.
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
i tried after the broken update sudo pacman -Syyuu but it doesn't solve the problem. what can i do ?

edit: sudo pacman -Scc fixed it. sorry

1 Like

got a grub pacnew file, not sure wether to replace




1 Like

That's not the case. I have exactly the same issue on all Manjaro machines since last stable update, and I didn't install fontcnfig from AUR. This error is displayed every single time I try to install or update ANY package. Like I said, it happens since last stable update for me.

1 Like

I'm sorry if that is an AUR issue. I can't launch Firefox KDE Opensuse bin after the update. It says
XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so: libdav1d.so.2: cannot open shared object file: No such file or directory Couldn't load XPCOM.

1 Like

@Danielsuarez369 explained it.

If it annoys you, just downgrade the package (there is an option in pamac, "Enable downgrade").
Or via pacman with next upgrade: sudo pacman -Syuu

It does not harm though. If you don't have any issues, just ignore the message. Sooner or later there will be an update again.


About fontconfig

Just because of issues with Snaps

Yeah, but if you don't use Snaps and just use the AUR like most, it doesn't affect you minus that small annoyance

Well, 19.2.4 just got released like less than 24 hours ago, right?

If everything goes well, we should get the new Mesa soon.

Forum kindly sponsored by