[Stable Update] 2019-11-23 - Kernels, Mesa 19.2.6

from new zealand. i see someone has installed the updates. i haven't yet as the mirrors in nz haven't synced

just got the updates installed. no problem at all. thanks guys

below is my hardware list

System:    Host: johns-pc Kernel: 5.3.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=2132b488-639e-409e-b44b-56f27164c8f3 rw quiet apparmor=1 
           security=apparmor resume=UUID=db7dfbb7-320e-418f-b143-7725ee5744e1 udev.log_priority=3 modprobe.blacklist=radeon 
           amdgpu.dcfeaturemask=0x4 
           Desktop: KDE Plasma 5.17.3 tk: Qt 5.13.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A315-21G v: V1.12 serial: <filter> 
           Mobo: SR model: Squirtle_SR v: V1.12 serial: <filter> UEFI [Legacy]: Insyde v: 1.12 date: 06/19/2018 
Battery:   ID-1: BAT1 charge: 36.8 Wh condition: 36.8/37.0 Wh (99%) volts: 8.7/7.7 model: PANASONIC AP16M5J type: Li-ion 
           serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Topology: Dual Core model: AMD A9-9420e RADEON R5 5 COMPUTE CORES 2C+3G bits: 64 type: MCP arch: Excavator 
           family: 15 (21) model-id: 70 (112) stepping: N/A microcode: 6006705 L2 cache: 1024 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 7188 
           Speed: 1190 MHz min/max: 1200/1800 MHz boost: enabled Core speeds (MHz): 1: 1238 2: 1287 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Acer Incorporated ALI 
           driver: amdgpu v: kernel bus ID: 00:01.0 chip ID: 1002:98e4 
           Device-2: AMD Jet PRO [Radeon R5 M230 / R7 M260DX / Radeon 520 Mobile] vendor: Acer Incorporated ALI driver: N/A 
           bus ID: 01:00.0 chip ID: 1002:6665 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD STONEY (DRM 3.33.0 5.3.12-1-MANJARO LLVM 9.0.0) v: 4.5 Mesa 19.2.6 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:01.1 chip ID: 1002:15b3 
           Device-2: Advanced Micro Devices [AMD] Family 15h Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:09.2 chip ID: 1022:157a 
           Sound Server: ALSA v: k5.3.12-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: kernel port: 2000 bus ID: 02:00.1 chip ID: 10ec:8168 
           IF: enp2s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel 
           port: 2000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 74.07 GiB (8.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-21Z10T0 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A02 scheme: MBR 
Partition: ID-1: / raw size: 922.71 GiB size: 907.23 GiB (98.32%) used: 74.07 GiB (8.2%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 34.8 C mobo: N/A gpu: amdgpu temp: 34 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 187 Uptime: 4m Memory: 7.31 GiB used: 1.05 GiB (14.4%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.36 

I have updated the system with pacman -Syyu and all went fine.
The second computer also updated correctly.

Updated in TTY no problem found.

1 Like

Updated via Pamac and no issues whatsoever on XFCE, AMDGPU, Kernel 5.3.

XFCE, Kernel 414, I updated few minutes ago and all seems fine.
However, why we didn't received also these updates from 14 November 2019? [Unstable Update] 2019-11-14 - Python 3.8, ICU and Poppler rebuilds - BREAKAGE expected! and from today? [Testing Update] 2019-11-23 - Python 3.8, ICU and Poppler rebuilds - BREAKAGE expected! too many breakages? (I think that a lot of packages needs to be rebuilt, I think about python especially: on my system I have a lot of dependencies and sub-dependencies on python: i fear a mess about).
Well, on the stable branch, in facts, is ok to wait for major updates and fixes about, I'm ok with this :slight_smile:

No problems on 2 KDE machines, thank you.

1 Like

Edit: I resolved my issues. Update works fine; and in both kernels.

For me, the update got caught in an infinite loop and I had to shutdown. Upon reboot no kernel found (4.19 LTS and Nvidia 440xx). I had the 5.3 kernel installed, though it was unable to boot completely prior to update...(I think maybe a network issue--don't really know) anyway, I was able to open a TTY and roll back using Timeshift. Timeshift is awesome.

No problems on KDE machine.
Thank you.

1 Like

Updated KDE system with no issue. Thank you team Manjaro.

One question: does anyone know if it is safe to remove the "AMD_DEBUG=nongg,nodma" when using my rx 5700 xt or should i still keep these until later kernel/mesa?

Is there anything that needs to be changed in a config file or elsewhere for alpm-hook to be active?

No user action is required.

This is worrying

==> Image generation successful
(4/7) Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.3-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.3-x86_64.img
Found initrd fallback image: /boot/initramfs-5.3-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
**/usr/bin/grub-probe: warning: unknown device type nvme0n1.**

done

nvme0n1 is my OS drive.

You can ignore that message, see

3 Likes

I guess if they are updates from Unstable and Testing, then this is why we don't have them in Stable.

Manjaro team THANK YOU for including Dynamic Wallpaper Editor. I did not know it exist, now I am playing with it. Before I have to use some scripts to change wallpapers periodically! :heart_eyes:
Screenshot%20from%202019-11-24%2009-52-40

6 Likes

The update caused no issues. Following the previous update, Nvivdia drivers version 435 are used to enable kernel 4.14 and 4.19 to boot. Can anyone confirm if with this update version 440 is compatible with 4.14 and 4.19.

Kind Regards.

Sudhir

I am running nVidia 440 with kernel 4.19 without any issues.

Update went fine. Updated via TTY on a Gnome install.

1 Like

Installed via pamac-manager on nVidia 440, kernel 5.3 without any issues.

What is this blasphemy @philm... that poor, innocent PBP will be scared for life now, having had Windows run on it! :laughing:

@linesma

Thank you very much for confirming. I will switch to version 440 and post an update.

Appreciate your prompt response.

Regards.

Sudhir

Forum kindly sponsored by